get back to the gdm( login screen ) screen after log out

If none of the more specific forums is the right place to ask

get back to the gdm( login screen ) screen after log out

Postby specialist125 » 2006-02-12 18:17

In KDE environment I end the session (log out) and then their is a beep and screen goes blank. I wanted to login as a different user using the graphical mode. I used the ctrl+alt+f(n) but all I can get is the differnt terminals but not the graphical login. What should I do?
specialist125
 
Posts: 139
Joined: 2006-02-08 06:13

Postby touge_dorifuto » 2006-02-14 16:31

I don't know entirely how it works in KDE, but Gnome has a new login under the applications menu. I'll go over to KDE and see what the equivalent is.
touge_dorifuto
 

Postby touge_dorifuto » 2006-02-14 16:36

Okay, under the KDE menu, under system, there are two items, new login and new login (nested window). The new login will bring you back to the GDM screen without logging out. You can even log in again as the same user on a different session. When you log out of that, it will bring you back to a locked screen of the first login.
touge_dorifuto
 

Postby specialist125 » 2006-02-21 02:40

Well I see the one with new login but it doesnt work either. just a black screen . I also notice if I restart and return to the gdm and press ctrl+alt+F(n) when I press the F7 key the gdm is black again. I think it is still their but I dont know why it is not displayed. Could it be a problem with the gdm. I would switch to the kde Display manager but I dont know how to change it.
specialist125
 
Posts: 139
Joined: 2006-02-08 06:13

Postby sstone » 2006-02-23 15:22

To set kdm as default change in /etc/X11/default-display-manager
set it to:
/usr/bin/kdm
sstone
 
Posts: 72
Joined: 2005-06-07 08:31

Postby specialist125 » 2006-02-24 15:46

Ok so I've been playing around with this login problem I have and what I've found is that the gdm is still their in the background because I blindly typed my screen name and passwd and I can here it log me on but my monitor is not displaying anything. I dont know how to fix this because If I reboot everything shows properly but if at the gdm or after login I use the ctrl+alt+f(n) command or end session then my screen doesnt display the gui agian.
specialist125
 
Posts: 139
Joined: 2006-02-08 06:13

Postby specialist125 » 2006-03-06 22:57

Ok I have no clue what is going on with the screen at this point. Someone anyone help.Why doesnt the screen appear after log out or after switching from console mode with the ctrl-alt-f(n) keys f7 appear as a black screen.At first I thought maybe the x enviroment wasn't running but It is. I can login blinkly but once its login it still doesnt show any thing so I have to either swith to a console, log in as su, and reboot.I dont understand why it wounld display correctly during those times but if I dont switch or log out eveything works fine. I have another user but its a pain when you have to reboot just to let another user log in. So can someone help?? or have any suggestions. Oh and I tried switching the display manager like said above but kde didn't want to start I think programs where looking for gdm. The command line came up to log in as a user but it keep restarting or somthing their were code of somthing I guesss the start up for the kdm but it would execute. I had to type the user name and password quickly or it would start over again.
specialist125
 
Posts: 139
Joined: 2006-02-08 06:13

Postby Lux » 2006-03-07 08:33

You could check the .xsession-errors file in your home directory for any relevant errors. You could also check the XFree86 or Xorg startup log file in /var/log/ for any warnings or errors -- lines telling about warnings begin with (WW) and lines telling about errors begin with (EE).

If your problem is some misbehaving application during an X session, then the .xsession-errors might give you clues for detecting the guilty application. But, more likely, the problem may be in your X server configuration because using the ctrl-alt-f(n) key combination leaves you with a blank/black screen. The log file under /var/log/ might tell you which section of your X server configuration needs fine-tuning.

It's also possible that Debian's X server doesn't fully support your hardware. If you have a relatively new computer and you're running Debian stable, then it might be worth considering to upgrade the x-window-system package to the latest available version from backports.org.
"Hit the philistines three times over the head with the Elisp reference manual."
-- Michael A. Petonic --
User avatar
Lux
 
Posts: 474
Joined: 2006-01-25 13:00
Location: Finland

Postby specialist125 » 2006-03-07 18:37

This is what I found in Xfree86.0.log assuming this is what I need these where the (ww) I found but no EE


(WW) The directory "/usr/lib/X11/fonts/cyrillic" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/lib/X11/fonts/CID" does not exist.
Entry deleted from font path.

(WW) Open APM failed (/dev/apm_bios) (No such file or directory)

*(WW) (1600x1200,SVA_VR17S) mode clock 162MHz exceeds DDC maximum 140MHz

(WW) (1280x1024,SVA_VR17S) mode clock 157.5MHz exceeds DDC maximum 140MHz

(WW) System lacks support for changing MTRRs

Warning: font renderer for ".pcf" already registered at priority 0
Warning: font renderer for ".pcf.Z" already registered at priority 0
Warning: font renderer for ".pcf.gz" already registered at priority 0
Warning: font renderer for ".snf" already registered at priority 0
Warning: font renderer for ".snf.Z" already registered at priority 0
Warning: font renderer for ".snf.gz" already registered at priority 0
Warning: font renderer for ".bdf" already registered at priority 0
Warning: font renderer for ".bdf.Z" already registered at priority 0
Warning: font renderer for ".bdf.gz" already registered at priority 0
Warning: font renderer for ".pmf" already registered at priority 0
Could not init font path element unix/:7100, removing from list!
SetClientVersion: 0 9
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState - enabled
SetClientVersion: 0 9
SetGrabKeysState - disabled
SetGrabKeysState – enabled


but then I have a Xfree86.20.log in which has the same info I dont know what all this stuff means?????
specialist125
 
Posts: 139
Joined: 2006-02-08 06:13

Postby Lux » 2006-03-07 19:44

Those warnings in Xfree86.0.log don't seem like anything serious in my non-expert opinion.

Maybe you should post some information about your graphics card ("lspci | grep VGA"), your monitor (manufacturer, model) and also the content of /etc/X11/XF86Config-4. There might be a chance that we can do something to fine-tune your Xserver configuration to the extent that the problem goes away.
"Hit the philistines three times over the head with the Elisp reference manual."
-- Michael A. Petonic --
User avatar
Lux
 
Posts: 474
Joined: 2006-01-25 13:00
Location: Finland

Postby specialist125 » 2006-03-08 03:50

lspci | grep VGA

0000:00:02.0 VGA compatible controller: Intel Corp. 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 03)

Monitor
SVA Vr17" LCD Monitor

etc/x11/XF86Config-4

# cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom
# md5sum /etc/X11/XF86Config-4 >/var/lib/xfree86/XF86Config-4.md5sum
# dpkg-reconfigure xserver-xfree86

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
Load "xtt"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "Generic Video Card"
Driver "vesa"
EndSection

Section "Monitor"
Identifier "SVA_VR17S"
HorizSync 31-80
VertRefresh 56-75
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "SVA_VR17S"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection
specialist125
 
Posts: 139
Joined: 2006-02-08 06:13

Postby Lux » 2006-03-08 11:17

Section "Device"
Identifier "Generic Video Card"
Driver "vesa"
EndSection

Hmm.. So your graphics controller is an integrated Intel 82845G/GL chipset and it works with the generic "vesa" driver, although not perfectly. Monitor settings (horizsync & vertrefresh) appear to be OK in your X server config file.

Maybe you should try changing the "vesa" driver to Intel's own "i810" driver -- if that works, "i810" may be able utilize your graphics controller's capabilities better than the "vesa" driver. In other words, I suggest that you should edit your /etc/X11/XF86Config-4 and make the above quoted section look like this:

Section "Device"
Identifier "Generic Video Card"
Driver "i810"
EndSection

If Xsession fails to start with the "i810" driver, you can edit /etc/X11/XF86Config-4 back to the "vesa" driver, so there's no harm done if you experiment a bit.

You could also experiment with specifying the exact amount of videoram (like 16384 or 32768 kBytes) for the graphics controller, like this:

Section "Device"
Identifier "Generic Video Card"
Driver "vesa"
VideoRam 32768
EndSection

Or, like this:

Section "Device"
Identifier "Generic Video Card"
Driver "i810"
VideoRam 32768
EndSection

If none of these tweaks help, there's still a chance that upgrading the X Window System from XFree86 to X.org might introduce improved support for your specific graphics controller. X.org is available for Debian stable via the (unofficial) backports repository: http://backports.org/
"Hit the philistines three times over the head with the Elisp reference manual."
-- Michael A. Petonic --
User avatar
Lux
 
Posts: 474
Joined: 2006-01-25 13:00
Location: Finland

get back to the gdm( login screen ) screen after log out

Postby glf2818 » 2006-03-08 22:45

specialist125
In KDE environment I end the session (log out) and then their is a beep
and screen goes blank. I wanted to login as a different user using the
graphical mode. I used the ctrl+alt+f(n) but all I can get is the
differnt terminals but not the graphical login. What should I do?

You can change to any other user (if you know the password) with su.
If you want to get back to the login screen, just CNTL-ALT-BACKSPACE.
George
glf2818
 
Posts: 193
Joined: 2005-11-21 01:54
Location: Portage, Indiana

Postby specialist125 » 2006-03-09 01:25

Thank Lux that seem to fix my problem I just changed the driver to the i810. So should i still specify the videoram now? If I do what results should I see ? Will I make a major difference from what I have now?
specialist125
 
Posts: 139
Joined: 2006-02-08 06:13

Postby Lux » 2006-03-09 10:37

If it works, you don't need to bother with setting videoram.

I just mentioned this option because I thought the blank screen you experienced before might be due to your video card running out of available memory. AFAIK, Intel's integrated graphics controllers don't have their own RAM memory, they "steal" it from the system's main RAM. It seems that the i810 driver does a better job in RAM management than the vesa driver, and this makes specifying videoram in /etc/X11/XF86Config-4 unnecessary.
"Hit the philistines three times over the head with the Elisp reference manual."
-- Michael A. Petonic --
User avatar
Lux
 
Posts: 474
Joined: 2006-01-25 13:00
Location: Finland

Next

Return to General Questions

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable