Sound /dev/dsp locked

If none of the more specific forums is the right place to ask

Sound /dev/dsp locked

Postby glf2818 » 2006-02-18 01:17

I have been fighting with sound off and on since I got my
computer (Dell dimension 4700). Every program I have tried
(lately amarok and rythmbox) ends with the note /dev/dsp
locked by another process. Actually what is said is: OSS device "/dev/dsp" is already in use by another program. I was writing from memory and that sounded like "locked" to me.
There are no other processes using sound at the same time. I have tried starting rythmbox just after booting and get the same message.
Is there a file somewhere that lists locks? Possibly if there is I could, as root, remove the lock, or at least find out what is causing it.
The programs work a little--I can rip tracks and make up a playlist. Some programs appear to be trying to play a cd. The slide-bar moves and some of them show a visual to reflect the music playing.
Nothing appears to be muted.
George
Last note, I used sound on the microsoft system that came with the computer, so the hardware isn't the problem.
glf2818
 
Posts: 193
Joined: 2005-11-21 01:54
Location: Portage, Indiana

Postby domecq » 2006-02-24 00:47

What sound card we have here?

In recent posts, people exposed similar problems, with various sound cards.

From those posts, what I noticed is, talking in a general way, that there are some old cards that demand OSS libs, some cards that might not be that old and are detected by installation program and have an open-source driver that imposes this lock issue.

Still talking in a general way, the possible solutions could be: installing manufacturer's Linux driver, installing that driver and do some tweak here and there, or yet, just do some tweak here and there with alsa.

If you can determine exactly what card you have, we could see what's the best path...

Cheers,

domecq
User avatar
domecq
Moderator Team Member
 
Posts: 560
Joined: 2005-10-18 00:53
Location: Montréal, Canada

Sound /dev/dsp locked

Postby glf2818 » 2006-02-24 02:28

domecq
lsusb says:
0000:00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
I tried esd and got this message:
debian:~# esd
esd: Esound sound daemon already running or stale UNIX socket
/tmp/.esd/socket
This socket already exists indicating esd is already running.
Exiting...
---------------------------------------
from syslog:
Intel 810 + AC97 Audio, version 1.01, 19:06:39 Dec 27 2005
PCI: Setting latency timer of device 00:1e.2 to 64
i810: Intel ICH4 found at IO 0xe8c0 and 0xec00, MEM 0xdffffe00
and 0xdffffd00, IRQ 23
i810: Intel ICH4 mmio at 0xe0815e00 and 0xe0817d00
i810_audio: Primary codec has ID 2
i810_audio: Audio Controller supports 6 channels.
i810_audio: Defaulting to base 2 channel mode.
i810_audio: Resetting connection 0
i810_audio: Connection 0 with codec id 2
ac97_codec: AC97 Audio codec, id: ADS112 (Unknown)
i810_audio: AC'97 codec 2 supports AMAP, total channels = 6
--------------------
later in syslog:
usb.c: registered new driver audio
localhost kernel: audio.c: v1.0.0:USB Audio Class
driver
-------------------------------------------------------------
I tried
# rm /tmp/.esd/socket
Ran Rythmbox--still got
Code: Select all
OSS device "/dev/dsp" is already in use by another program.

Thanks for your help.
George
:wink:
Still trying! I found this line when I did
~/.gconf/apps/totem$ nano %gconf.xml
<entry name="volume" mtime="1137880495" type="int" value="0">
I changed the last 0 to 50 and then tried 20. Still no sound, but I didn't get the /dev/dsp message.
I suspect the problem is in gconf.
glf2818
 
Posts: 193
Joined: 2005-11-21 01:54
Location: Portage, Indiana


Return to General Questions

Who is online

Users browsing this forum: No registered users and 14 guests

fashionable