[SOLVED] noob trying to upgrade to testing

If none of the more specific forums is the right place to ask

[SOLVED] noob trying to upgrade to testing

Postby kostaris » 2006-02-21 20:02

hello there i just re-entered the world of debian after ubuntu 5.10 (too "gloss" slow and unstable in comparisson with proper debian anyway) and since this is by far the best community ever just wanted to ask if there is a way of upgrading from sarge(3.1) to etch (testing), i reconfigured my /etc/apt/sources.list and did the aptitude configuration thing after apt-get update but some dependecy problem left the system into terminal. Now i got up and running but stil in sarge any help appreciated would love to get my hands on kde 3.4 gnome 2.10 and so forrth

keep the open source spirit alive:)))
Last edited by kostaris on 2016-06-25 17:13, edited 1 time in total.
kostaris
 
Posts: 56
Joined: 2006-02-18 02:14
Location: Greece

Postby Demetrius » 2006-02-21 20:22

All you should need to do is change your /etc/apt/sources.list file to use the testing repositories instead of the stable, then run apt-get update && apt-get dist-upgrade. You may want to simulate the upgrade first to see what all is going to be changed before commiting to the installation. In which case, run apt-get -s dist-upgrade in place of the second command.

Also, after the upgrade, you will probably want to install a new kernel, as dist-upgrade most likely will leave you with your old kernel from Sarge. To see what precompiled kernels are available use apt-cache search linux-image -n.
Demetrius
 
Posts: 49
Joined: 2005-09-15 17:20

Noob eventually upgraded to testing

Postby kostaris » 2006-02-24 20:13

Hello there everybody
Apologies for double posting the same post previously to 2 different forums regarding my testing upgrade. Many thnaks to Demetrious about the sharp response to it. Demetrious i did what u have described and after the dist-upgrade commant (with X server switched off) the installation was interrupted due to some dependency problem(again...),i tried aptititude too using teh -fr command but no luck
Then i ve seen at the network install documentation an announcement from debian stating that this a transition moment for testing and net-install from Sarge to Etch will most likely fail.
However, and this is the funny bit i got a testing image from

www.cdimage.debian.org

and installed etch with 2.6.15.1 kernel and the latest gnome and it works so nice for me:))) so i can recommend this method if anybody is interested

Once again thanks a billion and apologies for the lengthy mail

Take care
kostaris
 
Posts: 56
Joined: 2006-02-18 02:14
Location: Greece


Return to General Questions

Who is online

Users browsing this forum: No registered users and 13 guests

fashionable