errors while installing graphviz from source

If none of the more specific forums is the right place to ask

Postby EdBoran » 2006-03-08 03:00

You are so right! I have forgot about this.
I think it’s worth a try. I hope it’s not going to break since its dependencies are already installed.
Posts: 10
Joined: 2006-03-07 21:35

Postby Harold » 2006-03-08 05:24

Ed> I am afraid to start getting packages from testing or unstable... The [packages] from stable are at least 2 or 3 releases behind the current ones:
nessus - 2.2.3 versus 3.0
snort 2.3.2 versus 2.4.3

My preference is to install packages from Testing, and if Testing isn't recent enough, then I build from source rather than install from Unstable. YMMV.

Ed> The reason I've got on my /usr/local/lib is because I have compiled libiconv1.9.1 from the source code.

Debian packages are configured to install libraries in /usr/lib/ and to run ldconfig as part of the installation process (in order to "register" the libraries with the OS). Libraries installed from source almost always go into /usr/local/lib/, and the person doing the install has to remember to do ldconfig step himself -- and to config ldconfig so that it knows to look inside /usr/local/lib/. It sounds as though you already know all this. I don't know why adding /usr/local/ to /etc/ forces Debian to look for libraries in /usr/local/lib/. But I am wondering if adding /usr/local/lib/ to /etc/ forces Debian to look for libraries in the non-existent directory /usr/local/lib/lib/. I don't claim to be a computer wizard.

Ed> Any way I can tell apt and/or synaptic that I've got the packages that I need and don't have to install them from the repository?

dpkg, apt, et al. know nothing about resources or applications built from source. All they know is what was installed from Debian packages.

Ed> During graphviz make install the program called dot is calling and it complains that it cannot be found. There are no permissions issues.

I find it interesting (?) that you make it through ./configure and make with no problems, then the whole process goes south during make install. I went back to my make install log, and I don't see anything unusual in there. I do see that Graphviz generates lots of "dot" files.
Posts: 1502
Joined: 2005-01-07 00:15

Postby EdBoran » 2006-03-08 13:27

I have came across while googleling for some other issues that sometimes you have to skip the ending folder (like lib from /usr/local/lib) because the install adds the /lib at the end of the path. Why? There were no explanations. However, since I’m not pulling the package from the repository, I should be aware that strange things can happen.

The reason I decided to compile the source code is because is have implemented sguil (real-time monitor for snort) that requires snort and barnyard to be patched and recompiled. Also, sguil doesn't support tcl compiled with multi-thread option on.
I have no idea if a deb package can have patches injected in it so I did what the author said in the install instructions.

I’ll give it a try today and get back to you.

Thanks for your help.
Posts: 10
Joined: 2006-03-07 21:35

Postby EdBoran » 2006-03-09 01:45

Modifying solved the problem!
Thank you guys!
Posts: 10
Joined: 2006-03-07 21:35

Postby domecq » 2006-03-09 01:59

I don't claim to be a computer wizard.

No? Watch this...
Modifying solved the problem!

Now you are! ;) That was awesome! Watch my picture... I'm smiling!
User avatar
Moderator Team Member
Posts: 560
Joined: 2005-10-18 00:53
Location: Montréal, Canada


Return to General Questions

Who is online

Users browsing this forum: No registered users and 2 guests