No /etc/X11/xorg.conf

If none of the more specific forums is the right place to ask

No /etc/X11/xorg.conf

Postby cola » 2010-06-11 05:05

I did:
Code: Select all
cd /etc/X11
Xorg -configure

But i got error
Last few lines:
Code: Select all
(II) intel(0): Printing DDC gathered Modelines:
(II) intel(0): Modeline "800x600"x0.0   56.25  800 832 896 1048  600 601 604 631 +hsync +vsync (53.7 kHz)
(II) intel(0): Modeline "800x600"x0.0   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz)
(II) intel(0): Modeline "800x600"x0.0   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz)
(II) intel(0): Modeline "640x480"x0.0   31.50  640 656 720 840  480 481 484 500 -hsync -vsync (37.5 kHz)
(II) intel(0): Modeline "640x480"x0.0   31.50  640 664 704 832  480 489 492 520 -hsync -vsync (37.9 kHz)
(II) intel(0): Modeline "640x480"x0.0   30.24  640 704 768 864  480 483 486 525 -hsync -vsync (35.0 kHz)
(II) intel(0): Modeline "640x480"x0.0   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz)
(II) intel(0): Modeline "720x400"x0.0   28.32  720 738 846 900  400 412 414 449 -hsync +vsync (31.5 kHz)
(II) intel(0): Modeline "1024x768"x0.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz)
(II) intel(0): Modeline "832x624"x0.0   57.28  832 864 928 1152  624 625 628 667 -hsync -vsync (49.7 kHz)
(II) intel(0): Modeline "800x600"x0.0   49.50  800 816 896 1056  600 601 604 625 +hsync +vsync (46.9 kHz)
(II) intel(0): Modeline "800x600"x0.0   50.00  800 856 976 1040  600 637 643 666 +hsync +vsync (48.1 kHz)
(II) intel(0): Modeline "640x480"x0.0   36.00  640 696 752 832  480 481 484 509 -hsync -vsync (43.3 kHz)
(II) intel(0): Allocate new frame buffer 1024x768 stride 1024
(II) Power Button: Close
(II) UnloadModule: "evdev"
(II) Power Button: Close
(II) UnloadModule: "evdev"
(II) AT Translated Set 2 keyboard: Close
(II) UnloadModule: "evdev"
(II) ImPS/2 Generic Wheel Mouse: Close
(II) UnloadModule: "evdev"
User avatar
cola
 
Posts: 287
Joined: 2009-03-09 21:28
Location: Dhaka,Bangladesh

Postby llivv » 2010-06-11 20:43

.
Last edited by llivv on 2019-04-27 14:09, edited 1 time in total.
In memory of Ian Ashley Murdock (1973 - 2015) founder of the Debian project.
User avatar
llivv
 
Posts: 5488
Joined: 2007-02-14 18:10
Location: cold storage

Re: No /etc/X11/xorg.conf

Postby BioTube » 2010-06-11 22:53

If you've got xserver-xorg-video-vmware installed, it's been known to cause problems preventing a proper config generation.
Image
Ludwig von Mises wrote:The elite should be supreme by virtue of persuasion, not by the assistance of firing squads.
User avatar
BioTube
 
Posts: 7551
Joined: 2007-06-01 04:34

Re: No /etc/X11/xorg.conf

Postby cola » 2010-06-12 03:25

llivv wrote:what version of debian are you asking about? Lenny/Stable - Squeeze/Testi9ng - Sid/Unstable
when Xorg -configure works properly you will get a new config file in /root
/root/xorg.conf.new
and it should instruct you to run a command to test the "xorg.conf.new" file it just generated..
Beware if you are using Squeeze/Testing or Sid that you will not be able to quit fron the test without killing it from a VT
Becasue the "Don't Zap" server flag option is set in the xserver default config for squeeze and sid
To kill the initial xserver test:
Switch to VT2 (CTRL+ALT+F2)
login as root
run ps aux
than
kill (pid #)
of the "/usr/bin/X" process....
post back if you need more help or don't understand my directions...

Debian testing
User avatar
cola
 
Posts: 287
Joined: 2009-03-09 21:28
Location: Dhaka,Bangladesh

Re: No /etc/X11/xorg.conf

Postby cola » 2010-06-12 04:59

BioTube wrote:If you've got xserver-xorg-video-vmware installed, it's been known to cause problems preventing a proper config generation.

Yes that's installed.
Should i remove it?
User avatar
cola
 
Posts: 287
Joined: 2009-03-09 21:28
Location: Dhaka,Bangladesh

Re: No /etc/X11/xorg.conf

Postby BioTube » 2010-06-12 13:14

If you want to use Xorg -configure, yes. You'll probably need to make sure the correct driver for your card's manually installed.
Image
Ludwig von Mises wrote:The elite should be supreme by virtue of persuasion, not by the assistance of firing squads.
User avatar
BioTube
 
Posts: 7551
Joined: 2007-06-01 04:34

Re: No /etc/X11/xorg.conf

Postby cola » 2010-06-12 17:18

I removed xserver-xorg-video-vmware and configured /etc/X11/xorg.conf doing Xorg --configure.
User avatar
cola
 
Posts: 287
Joined: 2009-03-09 21:28
Location: Dhaka,Bangladesh

Re: No /etc/X11/xorg.conf

Postby jheaton5 » 2010-06-12 17:55

cola wrote:I removed xserver-xorg-video-vmware and configured /etc/X11/xorg.conf doing Xorg --configure.

...and the result was...
debian sid
User avatar
jheaton5
 
Posts: 1489
Joined: 2008-08-20 01:40
Location: Newnan, GA, USA

Re: No /etc/X11/xorg.conf

Postby handheldCar » 2010-06-30 16:28

jheaton5 wrote:
cola wrote:I removed xserver-xorg-video-vmware and configured /etc/X11/xorg.conf doing Xorg --configure.

...and the result was...

I tried to make a xorg.conf file by stopping kdm and entering Xorg -configure, but the X server had a segmentation fault. I tried --configure, but it was an unrecognized option. I'm using Squeeze (testing). I saw the note about xserver-xorg-video-vmware, so I removed that and xserver-xorg-video-all since aptitude said it was safe to remove. I ran X -config /root/xorg.conf.new, and got some more errors:
Code: Select all
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
   Entry deleted from font path.
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Mouse0
(WW) Disabling Keyboard0
(EE) NV: Kernel modesetting driver in use, refusing to load
(EE) No devices detected.

Fatal server error:
no screens found
I moved the xorg.conf.new to /etc/X11/xorg.conf anyway and changed the driver from the free nv to nvidia, and X wouldn't work at all. I got some more errors in /var/log/Xorg.0.log:
Code: Select all
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0):  *** Aborting ***
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
Now, my normal resolution is disabled, and the resolution is taken down a notch. (I changed the driver back) I might have to remove the xorg.conf file or see if wiki.x.org has any help. By the way, I have to use the legacy 173xx source and driver from sid, but I've commented out the unstable repos after installing those.
handheldCar
 
Posts: 221
Joined: 2009-11-27 02:31
Location: North Cackalack

Re: No /etc/X11/xorg.conf

Postby ramack » 2010-07-02 13:07

There was a major Xorg change several months ago, and part of that change was removal of xorg.conf. I noticed it when I was trying to track down the reason another Testing box broke. The box that I'm on right now does not have xorg.conf by default.

Code: Select all
ramack@debian64:~$ sudo locate xorg.conf
/usr/share/X11/xorg.conf.d
/usr/share/X11/xorg.conf.d/10-evdev.conf
/usr/share/X11/xorg.conf.d/20-wacom.conf
/usr/share/X11/xorg.conf.d/50-synaptics.conf
/usr/share/doc/xserver-xorg/examples/xorg.conf
/usr/share/doc/xserver-xorg-video-nouveau/examples/xorg.conf
/usr/share/man/man5/xorg.conf.5.gz
ramack@debian64:~$
homemade AMD64, Acer AspireOne 150, Asus eeePC 900, i386; Testing
i386,Dell Vostro 1000 AMD64, Dell Inspiron 1100; Sid
XFCE on all.
ramack
 
Posts: 453
Joined: 2008-01-28 15:31
Location: Centennial, CO

Re: No /etc/X11/xorg.conf

Postby bugsbunny » 2010-07-02 20:43

NV: Kernel modesetting driver in use, refusing to load


You need to turn of kernel modesetting if you want to use the nvidia driver.
xorg.conf isn't required in most cases any more (you will need a barebones one to specify the nvidia driver).
Code: Select all
Section "Device"
   Identifier   "Default Device"
   Driver      "nvidia"
EndSection

should be enough.

To turn off modesetting add "nomodeset" as a kernel boot time parameter.
User avatar
bugsbunny
 
Posts: 5355
Joined: 2008-07-06 17:04

Re: No /etc/X11/xorg.conf

Postby craigevil » 2010-07-02 21:08

bugsbunny wrote:
NV: Kernel modesetting driver in use, refusing to load


You need to turn of kernel modesetting if you want to use the nvidia driver.
xorg.conf isn't required in most cases any more (you will need a barebones one to specify the nvidia driver).
Code: Select all
Section "Device"
   Identifier   "Default Device"
   Driver      "nvidia"
EndSection

should be enough.

To turn off modesetting add "nomodeset" as a kernel boot time parameter.


Add it to /etc/default/grub if you are using grub2.
GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset"
Debian Sid KDE Kernel 3.17 Thinkpad R40 Intel M 1.3 CPU 2GB RAM Radeon Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Debian upgrade script smxi | sysinfo script inxi
User avatar
craigevil
 
Posts: 5192
Joined: 2006-09-17 03:17
Location: Oz

Postby llivv » 2010-07-02 22:21

.
Last edited by llivv on 2019-04-27 14:08, edited 1 time in total.
In memory of Ian Ashley Murdock (1973 - 2015) founder of the Debian project.
User avatar
llivv
 
Posts: 5488
Joined: 2007-02-14 18:10
Location: cold storage

Re: No /etc/X11/xorg.conf

Postby handheldCar » 2010-07-03 03:58

Thanks, I tried both suggestions. I don't know what's going wrong, but I'm not going to worry about it anymore because my resolution is fine. I have a trunk kernel that I'm not using because X never worked on it. I tried these fixes, but I didn't notice they were affecting my trunk kernel until I was undoing them; so I don't know if they work. I'll probably try again if I want some desktop effects. I don't think my favorite one, Invert, works on Nvidia cards.
handheldCar
 
Posts: 221
Joined: 2009-11-27 02:31
Location: North Cackalack

Re: No /etc/X11/xorg.conf

Postby bugsbunny » 2010-07-03 14:05

I'm pretty sure that nouveau is the default once modesetting comes into play. I know that nv is going away (although I'm not sure of the timeline). Nvidia has officially deprecated the nv driver back in March.

Invert should work fine with nvidia cards. At least it works for me (Compiz). And this thread has a post in it that indicates it should work for the KDE invert Cannot enable invert effect • KDE Community Forums


What's lsmod tell you about what driver is actually being used?

"trunk" kernel has been superseded for a while now and isn't found in the repos any more. Remove it. Latest official Debian kernel is 2.6.32-5
User avatar
bugsbunny
 
Posts: 5355
Joined: 2008-07-06 17:04

Next

Return to General Questions

Who is online

Users browsing this forum: No registered users and 13 guests

fashionable