No /etc/X11/xorg.conf

If none of the more specific forums is the right place to ask

Re: No /etc/X11/xorg.conf

Postby handheldCar » 2010-07-03 14:44

bugsbunny wrote:What's lsmod tell you about what driver is actually being used?
Which module tells that?

bugsbunny wrote:"trunk" kernel has been superseded for a while now and isn't found in the repos any more. Remove it. Latest official Debian kernel is 2.6.32-5
How do I remove a trunk kernel?
handheldCar
 
Posts: 221
Joined: 2009-11-27 02:31
Location: North Cackalack

Re: No /etc/X11/xorg.conf

Postby BioTube » 2010-07-03 16:28

handheldCar wrote:Which module tells that?
You'll have either nouveau or nvidia.
Image
Ludwig von Mises wrote:The elite should be supreme by virtue of persuasion, not by the assistance of firing squads.
User avatar
BioTube
 
Posts: 7551
Joined: 2007-06-01 04:34

Re: No /etc/X11/xorg.conf

Postby AMLJ » 2010-07-03 17:15

I had the same problem, if you got NVIDIA, then install all the needed packages. (You can find them easily, a little search, even in this website.) After that run:
Code: Select all
nvidia-xconfig

AND ENJOY! :wink:
AMLJ**0-1-47
User avatar
AMLJ
 
Posts: 973
Joined: 2009-03-18 07:40
Location: Mierlo, Netherlands

Re: No /etc/X11/xorg.conf

Postby handheldCar » 2010-07-03 17:20

BioTube wrote:
handheldCar wrote:Which module tells that?
You'll have either nouveau or nvidia.
I was asking because saw several nouveaus and dozens of other lines.
handheldCar
 
Posts: 221
Joined: 2009-11-27 02:31
Location: North Cackalack

Re: No /etc/X11/xorg.conf

Postby handheldCar » 2010-07-05 19:24

I guess I got this working, now. I ran nvidia-xconfig which made an XF86 file that didn't work after restarting kdm. I logged into tty1 as root and changed the XF86 file to xorg.conf which still didn't work. I tested it with X -config $PATHNAME, got a blank screen, switched back to the tty w/ Ctrl Alt F1, quit the test with Ctrl c and got an error about GLX and the NVIDIA driver, so I changed the driver to nouveau; and that gave me the graphical login. Compositing didn't just work; I changed the type to XRender. I'm not sure if compositing is working because 3D effects are working or just because of something I could've done all along. I ran the following and got the following results:
Code: Select all
$ glxinfo |grep rendering
bash: glxinfo: command not found
My hard drive has been making a little noise since yesterday, and it's light has been blinking a bit. Maybe I enabled too many effects, and maybe I was sloppy yesterday.
handheldCar
 
Posts: 221
Joined: 2009-11-27 02:31
Location: North Cackalack

Re: No /etc/X11/xorg.conf

Postby AnInkedSoul » 2010-07-05 19:26

install mesa-utils
AnInkedSoul
 
Posts: 461
Joined: 2010-06-11 05:05

Re: No /etc/X11/xorg.conf

Postby craigevil » 2010-07-05 19:57

The dpkg bot in #debian knows it all.

From squeeze onwards, you can often use an <empty xorg.conf>. Configure your keyboard layout for both X and console in
/etc/default/console-setup or "dpkg-reconfigure console-setup" (not xorg.conf).
If you have further things you wish to configure, use "X -configure" ("X -configure :1" if server is already active) to produce a xorg.conf template. Ask me about. http://wiki.debian.org/XStrikeForce/InputHotplugGuide

To use an NVIDIA graphics card with Debian, see http://wiki.debian.org/NvidiaGraphicsDrivers

The nvidia drivers currently in squeeze are compatible with the squeeze kernel. No need for a testing/unstable mix now. Use either
module-assistant or DKMS to compile them. They are incompatible with <nouveau> <KMS> (nouveau kernel module blacklisted as of nvidia-kernel-common 20100522).

nvidia m-a
For Lenny and Squeeze users. Ensure you have <non-free sources> added.
Code: Select all
aptitude install module-assistant && m-a a-i   nvidia-kernel

After successful module compilation,
Code: Select all
aptitude install nvidia-glx nvidia-xconfig && nvidia-xconfig -o /etc/X11/xorg.conf


nvidia-dkms
For Squeeze users. Ensure you have <non-free sources> added.
Code: Select all
aptitude -r install linux-headers-2.6-`uname -r | sed  's,.*-,,'` nvidia-glx nvidia-xconfig && nvidia-xconfig -o /etc/X11/xorg.conf


Or even easier just use smxi
do, as root:
Code: Select all
 cd /usr/local/bin && wget smxi.org/smxi.zip && unzip smxi.zip && smxi
or (#2)
you can also just download the file and run it, like so:
Code: Select all
cd /usr/local/bin && wget -Nc smxi.org/smxi && chmod +x smxi && smxi
Debian Sid KDE Kernel 3.17 Thinkpad R40 Intel M 1.3 CPU 2GB RAM Radeon Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Debian upgrade script smxi | sysinfo script inxi
User avatar
craigevil
 
Posts: 5192
Joined: 2006-09-17 03:17
Location: Oz

Re: No /etc/X11/xorg.conf

Postby handheldCar » 2010-07-06 02:53

Thanks AnInkedSoul. Apparently, my machine was having trouble loading the GLX driver.

craigevil, your reply was pretty unclear, and I ended up doing just about everything in it when I was supposed to do the first or the second. I hate it when people list lots of instructions and then list the easier alternative. The Debian wiki does a much better job of saying, "There are two ways, and here's information to help you choose one or the other." I don't know what dpkg is talking about; although I'm running testing for KDE 4.4, my legacy drivers for GeForce FX 5200 are in unstable. Anyway, I can't get X at all now without the nv driver which is killing me with its 1024x768 resolution. Desktop effects work except for invert. What does this NVIDIA driver do anyway? I don't play video games. I must be wasting my energy.

I can't tell if these are the NVIDIA libraries or something else. One of them doesn't have a pointer, and this is just an example. I don't know what else I could be checking. (/usr/share/doc/NVIDIA*/README* chp 5)
Code: Select all
$ ldd /usr/bin/glxgears
        linux-gate.so.1 =>  (0xb76e7000)
        libGL.so.1 => /usr/lib/libGL.so.1 (0xb762d000)
        libm.so.6 => /lib/i686/cmov/libm.so.6 (0xb7607000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0xb74e9000)
        libpthread.so.0 => /lib/i686/cmov/libpthread.so.0 (0xb74d0000)
        libc.so.6 => /lib/i686/cmov/libc.so.6 (0xb7389000)
        libGLcore.so.1 => /usr/lib/libGLcore.so.1 (0xb6649000)
        libnvidia-tls.so.1 => /usr/lib/tls/libnvidia-tls.so.1 (0xb6647000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0xb6637000)
        libdl.so.2 => /lib/i686/cmov/libdl.so.2 (0xb6633000)
        /lib/ld-linux.so.2 (0xb76e8000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb661a000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xb6617000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb6612000)
handheldCar
 
Posts: 221
Joined: 2009-11-27 02:31
Location: North Cackalack

Re: No /etc/X11/xorg.conf

Postby AMLJ » 2010-07-06 09:05

handheldCar wrote:I guess I got this working, now. I ran nvidia-xconfig which made an XF86 file that didn't work after restarting kdm. I logged into tty1 as root and changed the XF86 file to xorg.conf which still didn't work. I tested it with X -config $PATHNAME, got a blank screen, switched back to the tty w/ Ctrl Alt F1, quit the test with Ctrl c and got an error about GLX and the NVIDIA driver, so I changed the driver to nouveau; and that gave me the graphical login. Compositing didn't just work; I changed the type to XRender. I'm not sure if compositing is working because 3D effects are working or just because of something I could've done all along. I ran the following and got the following results:
Code: Select all
$ glxinfo |grep rendering
bash: glxinfo: command not found
My hard drive has been making a little noise since yesterday, and it's light has been blinking a bit. Maybe I enabled too many effects, and maybe I was sloppy yesterday.

To see if compositing is working, go to System Settings>Desktop.
AMLJ**0-1-47
User avatar
AMLJ
 
Posts: 973
Joined: 2009-03-18 07:40
Location: Mierlo, Netherlands

Re: No /etc/X11/xorg.conf

Postby handheldCar » 2010-07-08 00:58

craigevil, thank you very much. I installed stable kde today, and smxi installed the driver; and my resolution is larger :) I resorted to it because there was no package for stable, but curiously, there is now a package for testing. go figure. I appreciate your help
handheldCar
 
Posts: 221
Joined: 2009-11-27 02:31
Location: North Cackalack

Re: No /etc/X11/xorg.conf

Postby AMLJ » 2010-07-08 17:19

By the way, today I got something else too, when configuring NVIDIA drivers for my brother.
Install nvidia-xconfig.
Also, apt-cache search nvidia drivers, then find the package for your kernel (Do a uname -a if you don't know what your kernel is) and install it.
And then type nvidia-xconfig.
That should build you your file.
AMLJ**0-1-47
User avatar
AMLJ
 
Posts: 973
Joined: 2009-03-18 07:40
Location: Mierlo, Netherlands

another success story

Postby handheldCar » 2010-07-08 18:00

Although Konsole was much faster, I got sick of KDE 3.5 and decided to install testing again for 4.3/4.4. Upgrading from 3 to 4 has been buggy anyway. First thing I did after making sure I had non-free and contrib sources was come here and start smxi. I removed the generic kernel and the trunk, but smxi wasn't able to remove the nouveau module again. First, the instructions said reboot and reboot again if problems, and then they said shutdown for 30 seconds. Last time, I shutdown and reboot, but this time I just shutdown and then started smxi again since I couldn't remember the other package that actually does the install. It removed the nouveau module and installed the driver for what it's worth. At least I can enable Invert now, but it just turns things black :| might be able to find a fix later
handheldCar
 
Posts: 221
Joined: 2009-11-27 02:31
Location: North Cackalack

Re: No /etc/X11/xorg.conf

Postby handheldCar » 2010-07-19 18:41

I got nouveau working by building a libre kernel. I just accepted all of the defaults except for the one pertaining to nVidia in the make oldconfig step.
handheldCar
 
Posts: 221
Joined: 2009-11-27 02:31
Location: North Cackalack

Previous

Return to General Questions

Who is online

Users browsing this forum: No registered users and 18 guests

fashionable