apt-get problem

If none of the more specific forums is the right place to ask

apt-get problem

Postby spector » 2006-05-18 07:57

I tried to install some packages that have broken depemdencies.

Now evry time i try to install something new packages i can't do nothing because first i must do ap-get -f install that whants to remove half of my distibution (apt-get also)

How could i say to apt-get to ignore that packages?

I have already try with apt-get clean and apt-get autoclean with no results...

THx
User avatar
spector
 
Posts: 21
Joined: 2006-04-17 16:11

Postby lacek » 2006-05-18 09:31

You probably can't just ignore apt's warnings about broken packages. You have to solve this situation before you can use apt again. Please write what you tried to do, and what error message you got.
lacek
Moderator Team Member
 
Posts: 769
Joined: 2004-03-11 18:49
Location: Budapest, Hungary

Postby ajdlinux » 2006-05-18 10:03

Also, did you manually download these packages? If so you may have got them for the wrong Debian version, i.e. sarge, etch or sid.
ajdlinux
 
Posts: 2480
Joined: 2006-04-23 09:37
Location: Port Macquarie, NSW, Australia

Postby spector » 2006-05-18 11:53

If i type

apt-get install xmms i have

Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso... Fatto
È consigliabile eseguire 'apt-get -f install' per correggere questi problemi:
I seguenti pacchetti hanno dipendenze non soddisfatte:
engage: Dipende: libe ma non sta per essere installato
Dipende: libedje0 ma non sta per essere installato
Dipende: libeet0 ma non sta per essere installato
Dipende: libesmart0 ma non sta per essere installato
Dipende: libevas0 ma non sta per essere installato
Dipende: examine ma non sta per essere installato
iconbar: Dipende: libedb1 ma non sta per essere installato
Dipende: libedje0 ma non sta per essere installato
Dipende: libeet0 ma non sta per essere installato
Dipende: libesmart0 ma non sta per essere installato
Dipende: libevas0 ma non sta per essere installato
libecore0: Dipende: libdirectfb-0.9-22 ma non sta per essere installato
Dipende: libeet0 ma non sta per essere installato
Dipende: libevas0 ma non sta per essere installato
libemotion0: Dipende: libecore0-con ma non è installabile
Dipende: libecore0-config ma non è installabile
Dipende: libecore0-dbus ma non è installabile
Dipende: libecore0-evas ma non è installabile
Dipende: libecore0-fb ma non è installabile
Dipende: libecore0-file ma non è installabile
Dipende: libecore0-ipc ma non è installabile
Dipende: libecore0-job ma non è installabile
Dipende: libecore0-txt ma non è installabile
Dipende: libecore0-x ma non è installabile
Dipende: libeet0 ma non sta per essere installato
Dipende: libevas0 ma non sta per essere installato
libewl0: Dipende: libedb1 ma non sta per essere installato
Dipende: libedje0 ma non sta per essere installato
Dipende: libeet0 ma non sta per essere installato
Dipende: libevas0 ma non sta per essere installato
libstdc++6: Dipende: gcc-4.1-base (= 4.1.0-2) ma 4.1.0-1+b1 sta per essere installato
xmms: Dipende: libglib1.2 (>= 1.2.0) ma non sta per essere installato
Dipende: libgtk1.2 (>= 1.2.10-4) ma non sta per essere installato
E: Dipendenze non soddisfatte. Provare 'apt-get -f install' senza pacchetti (o specificare una soluzione).


"Dipende" means depends on and "ma non sta per essere installato means " but is not going to be installed"


I use this repositories

deb http://ftp.it.debian.org/debian/ etch main
deb-src http://ftp.it.debian.org/debian/ etch main

deb http://security.debian.org/ etch/updates main
deb-src http://security.debian.org/ etch/updates main

deb http://soulmachine.net/debian unstable/


These program are not so important, so even if they do not function is not a big problem... a

I jus need to let my apt function

Thx
User avatar
spector
 
Posts: 21
Joined: 2006-04-17 16:11

Postby simen » 2006-05-18 13:02

Have you tried to uninstall the offending packages? I'd do
Code: Select all
apt-get remove engage iconbar libecore0 libemotion0 libewl0 xmms libstdc++6/testing+
You might also try to add debian's official unstable repository before doing apt-get -f install.

Good luck,
--Simen

[edit: PS. apt-get clean doesn't install or uninstall anything, it just removes deb packages from /var/cache/apt/archives.]
User avatar
simen
 
Posts: 206
Joined: 2005-07-02 15:00
Location: Berlin

Postby spector » 2006-05-18 16:32

Thx a lot!

It function!

I try to remove the package but i did

apt-get remove engage iconbar libecore0 libemotion0 libewl0 xmms libstdc++6

And apt told me that star office and a lot of other packages depends on libstd++, with your code it Downgraded it.

Thx again
User avatar
spector
 
Posts: 21
Joined: 2006-04-17 16:11

Postby Lou » 2006-05-18 17:12

You have 2 different repositories open, if you are on Etch (testing) then you should comment (#) the line for Sid (unstable).
# apt-get update

and then try to install your app.
Lou
 
Posts: 1775
Joined: 2006-05-08 02:15

Postby spector » 2006-05-19 08:44

Yoiu know where i can find more repositories for my debian?

Excluding soulmachine the other are just the official repo that i have from the installation.
User avatar
spector
 
Posts: 21
Joined: 2006-04-17 16:11

Postby ajdlinux » 2006-05-20 00:06

You can get a good list at http://apt-get.org but a lot of them are unmaintained and only work with Woody (3.0), I have seen some there that only work with Potato (2.2) as well.
ajdlinux
 
Posts: 2480
Joined: 2006-04-23 09:37
Location: Port Macquarie, NSW, Australia

Postby jjx » 2006-05-21 09:36

Try "apt-get -f install" with differenet repositories ;)
jjx
 
Posts: 97
Joined: 2006-05-09 09:48


Return to General Questions

Who is online

Users browsing this forum: No registered users and 11 guests

fashionable