I don't get it

If none of the more specific forums is the right place to ask

I don't get it

Postby mark » 2004-03-25 19:16

I get the following error from my router:
    [ip address] sent an invalid ICMP error to a broadcast


Normaly this wouldn't be a problem because you can tell you kernel to ignore this error by editing /proc/sys/net/ip4/icmp_ignore_bogus_error_response.
But when I edit the default value (0) in to 1 and reboot, the default value is back in the file.
I'm sure I saved it correctly before rebooting.

Does somebody have an explanation for this?
mark
 
Posts: 37
Joined: 2004-02-15 22:28

Postby lacek » 2004-03-26 10:40

The /proc entries are not saved between reboots, so, if you need to edit anything among these files, you need to do it every time the system boots.
lacek
Moderator Team Member
 
Posts: 769
Joined: 2004-03-11 18:49
Location: Budapest, Hungary

Postby mark » 2004-03-26 19:41

Is there a way to do this automaticly?
mark
 
Posts: 37
Joined: 2004-02-15 22:28

Postby lacek » 2004-03-29 07:52

Put your settings to the startup scripts. These are located in /etc/rc[1-5].d, and are called S[0-9][0-9]<name>.
Debian systems starts on runlevel 2 by default, so if you put a script to /etc/rc2.d/ named, for example S99systemscripts, and write your stuff into it, then your settings will be applied on startup (be sure to make the script executable).
lacek
Moderator Team Member
 
Posts: 769
Joined: 2004-03-11 18:49
Location: Budapest, Hungary

Postby mark » 2004-03-30 17:48

Thanks for your reply

Sorry for the late response, I was away for the weekend.

I'm going to try it right away.
mark
 
Posts: 37
Joined: 2004-02-15 22:28


Return to General Questions

Who is online

Users browsing this forum: fred44nl and 10 guests

fashionable