New to debian

If none of the more specific forums is the right place to ask

New to debian

Postby UbuntiX » 2006-07-15 13:34

Alright I've been running ubuntu for a while,
really like it and thought I'd try debian.

Liking debian too,
but a few problems I'll need to sort out of course ;)

So I guess I'll post them here.

Firstly:

I need to set my screen resolution to 1280x1024...But the only options are 800x600 and 640x480...

So how do I set it as I want it?
UbuntiX
 
Posts: 9
Joined: 2006-07-11 23:01
Location: Dublin lol

Postby Grifter » 2006-07-15 13:57

At the bottom of the X config file there are modes, that's where you specify the resolution

/etc/X11 and the file is called XF86Config for xfree and xorg.conf for xorg
Eagles may soar, but weasels don't get sucked into jet engines...
Grifter
 
Posts: 1572
Joined: 2006-05-04 07:53
Location: Svea Rike

Postby UbuntiX » 2006-07-15 14:43

I tried edit it as root but the resolution is the same,
and I did reboot.
UbuntiX
 
Posts: 9
Joined: 2006-07-11 23:01
Location: Dublin lol

Postby Grifter » 2006-07-15 16:13

did you edit it for the depth you're using?
Eagles may soar, but weasels don't get sucked into jet engines...
Grifter
 
Posts: 1572
Joined: 2006-05-04 07:53
Location: Svea Rike

Postby Penguin Skinner » 2006-07-15 16:43

Open up your /etc/X11/xorg.conf file, and find the section labeled "Screen".

You will find one or more subsections labeled "Display" each of which specifies available modes for a given color depth (you may only need the subsection corresponding the the "DefaultDepth" you're using.)

Under each "Display" subsection you wish to keep/have, add the "1280x1024" desired resolution to the beginning of the "Modes" line. I would also include "1024x768" so that you have that available.

Here's a sample of how the "Screen" section of your xorg.conf file should look when you're done:

Code: Select all
Section "Screen"
        Identifier      "Default Screen"
        Device          "ATI Technologies, Inc. RV370 5B60 [Radeon X300 (PCIE)]"
        Monitor         "DELL E773s"
        DefaultDepth    24
        SubSection "Display"
                Depth           1
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           4
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           8
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           15
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           16
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Depth           24
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection


Good luck, and welcome to Debian!
Last edited by Penguin Skinner on 2006-07-15 18:38, edited 1 time in total.
Penguin Skinner
 
Posts: 709
Joined: 2005-09-15 20:37
Location: North by Northwest

Postby UbuntiX » 2006-07-15 18:06

bash: /etc/xorg.conf: No such file or directory

Strange...But I'll leave the resolution for now :)

Having some MySQL problems,
when I installed it I was never asked to make a super user, password, or anything similar.

I tried adding my root user to group "mysql",
but can't login with it.

What should I do?
UbuntiX
 
Posts: 9
Joined: 2006-07-11 23:01
Location: Dublin lol

Postby Penguin Skinner » 2006-07-15 18:37

My bad ... /etc/X11/xorg.conf (original post now corrected.)
Penguin Skinner
 
Posts: 709
Joined: 2005-09-15 20:37
Location: North by Northwest

Postby UbuntiX » 2006-07-15 19:02

That file doesn't seem to exist either...But could I get some help with MySQL?
UbuntiX
 
Posts: 9
Joined: 2006-07-11 23:01
Location: Dublin lol

Postby StarMonkey » 2006-07-15 20:22

I usually do one of the following to give the root mysql user a password...

mysqladmin -u root password yourrootpassword

or from the mysql prompt (just type mysql then hit enter)
grant all privileges on *.* to 'root'@'%' identified by 'password' with grant option;

The second one seems to have much better results for me :)
StarMonkey
 
Posts: 117
Joined: 2006-04-30 20:07

Postby UbuntiX » 2006-07-15 21:15

Neither of them worked :(
UbuntiX
 
Posts: 9
Joined: 2006-07-11 23:01
Location: Dublin lol

Postby StarMonkey » 2006-07-15 21:24

did you do the second one from the mysql prompt (it will be 'mysql>')?

you could try this to flush everything

mysqladmin -uroot -pyourpassword flush-privileges
mysqladmin -uroot -pyourpassword flush-hosts

Then a restart of the service just to be sure..

/etc/init.d/mysql restart

I've only ever done it straight after a clean install, so it may be easier to just apt-get remove the mysql-server package, then reinstall it.

Here's what I usually do to get a mysql server up quickly...

# apt-get install mysql-server-5.0 (you can use 4.1 if you want)
when that's done
# mysql
mysql> grant all privileges on *.* to 'root'@'%' identified by 'password' with grant option;

you'll get a message saying something like '0 rows affected', which is good.
StarMonkey
 
Posts: 117
Joined: 2006-04-30 20:07

Postby zwerg » 2006-07-17 06:25

Forgive me if I missed something here, but... do we know what kernel is involved?? Did anybody ask what flavor of Debian we are talking about?

Could it be that the query comes from somone who is not using Xorg for the GUI?

My (pure) Sarge setup uses kernel 2.6.8, and I sure don't have Xorg. Everything in my Toontown is handled by /etc/X11/XF86Config-4.

Yeah, I suppose that will provoke a few sneers from the wing-walkers, but that antique just might be involved in this case, too. Maybe check it out??
zwerg
 
Posts: 117
Joined: 2006-02-17 12:16
Location: Bangkok, Thailand


Return to General Questions

Who is online

Users browsing this forum: No registered users and 15 guests

fashionable