X Is Broken Because USB Mouse

If none of the more specific forums is the right place to ask

X Is Broken Because USB Mouse

Postby Carlosinfl » 2006-07-24 14:17

OK - I have seen this problem with Debian before. I installed Etch on a system and then I loaded the 2.6.16-2-686 kernel however X fails because Debian can not find a module for my USB optical mouse there for it fails to load X. I know that if I add the module for the mouse, the issue will be resolved however I have not done this personally. I really don't know where to begin. When I view my /etc/modules file, I see the following:

Code: Select all
# /etc/modules: kernel modules to load at boot time.
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.


I tried even adding "usbmouse" in there and restarting with still no success. Anyone care to help me get this working... :cry:
Posts: 889
Joined: 2005-02-05 06:11
Location: Orlando, FL

Postby Red » 2006-07-24 16:03

try dpkg-reconfigure xserver-xorg or dpkg-reconfigure xserver-xfree86 and choose different port for the mouse.

Good luck
User avatar
Posts: 69
Joined: 2006-04-20 12:36

Postby Carlosinfl » 2006-07-24 16:54

Yup tried that.

Odlly and maybe someone can answer this for me but when I edit the /etc/modules file and add "mousedev" to the end of it, save it, it then works when I reboot the box or just even restart X.
Posts: 889
Joined: 2005-02-05 06:11
Location: Orlando, FL

Return to General Questions

Who is online

Users browsing this forum: No registered users and 7 guests