Page 1 of 1

500 Internal Server Error trying to attach pictures to post

PostPosted: 2020-06-05 18:08
by EoflaOE
For some reason, everytime I try to attach pictures to my post, instead of attaching it, I get an error that says:

Code: Select all
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, forum-admin@forums.debian.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Apache Server at forums.debian.net Port 80


When I go back and try to save the draft, I see that exact same error message, so I have to go back, copy all the text that are in the post, go back to the forum, and try to post. The pictures are never attached however.

This is serious for me, as putting the Imgur URLs to any post that have pictures as attachments is an ugly workaround for me. Can this be fixed?

Re: 500 Internal Server Error trying to attach pictures to p

PostPosted: 2020-06-05 19:22
by cuckooflew
No, that will not be changed, there is not enough storage space on the forums server, you need to use a storage site, and post a link to the image, it really is not that complicated :EG:
Image

This is serious for me, as putting the Imgur URLs to any post that have pictures as attachments is an ugly workaround for me.

There are other storage sites besides Imgur if that is a problem for you and you find it ugly.

Re: 500 Internal Server Error trying to attach pictures to p

PostPosted: 2020-06-06 11:21
by EoflaOE
Thanks for the answer. From now on, I have to use the workaround until it is fixed.

Re: 500 Internal Server Error trying to attach pictures to p

PostPosted: 2020-06-06 11:28
by sunrat
EoflaOE wrote: From now on, I have to use the workaround until it is fixed.


It's a feature, not a bug. :wink:

Re: 500 Internal Server Error trying to attach pictures to p

PostPosted: 2020-06-25 23:22
by efdevse
I've used https://postimages.org a few times. Seems better than imgur (imo). On the picture page, you get a few pre formatted link alternatives to use… like “Thumbnail for forums” (BBCode).

Would be great if the Upload attachment tab could be removed, since it doesn't work anyway.