Nvidia driver - Debian way, custom (or not) kernel.

Share your own howto's etc. Not for support questions!

Postby Jackiebrown » 2008-10-18 01:12

run startx and report the problem - that should give you some error output

- if not, check your xorg error logs and see what they say (/var/logs)

- best to open a thread for your problem, though
User avatar
Jackiebrown
 
Posts: 1275
Joined: 2007-01-02 04:46
Location: San Antonio, TX

Postby estus » 2008-10-18 16:13

i cant use terminal and ctrl+alt+f2 dont work
estus
 
Posts: 3
Joined: 2008-10-04 15:54

Postby mzilikazi » 2008-10-19 00:09

estus wrote:i cant use terminal and ctrl+alt+f2 dont work

Reboot.
At the boot prompt add this to the end:
Code: Select all
single

When asked for the root password, provide it.
Code: Select all
update-rc.d -f gdm remove

Now GDM will not start
Code: Select all
nano /etc/X11/xorg.conf

Change your driver from nvidia to nv or vesa
Code: Select all
init 5

Log in as user
Code: Select all
startx


Then we need to see if you have built nvidia and installed all components.
Code: Select all
dpkg -l|grep nvidia

You can also try to reconfigure xorg.
Code: Select all
apt-get install nvidia-xconfig
nvidia-xconfig
Debian Sid Laptops:
AMD Athlon(tm) 64 X2 Dual-Core Processor TK-55 / 1.5G
Intel(R) Pentium(R) Dual CPU T2390 @ 1.86GHz / 3G
User avatar
mzilikazi
Forum Ninja
 
Posts: 3321
Joined: 2004-09-16 02:14
Location: Colorado Springs, CO

Postby tommcd » 2008-10-27 11:53

I just installed Lenny from the Lenny beta 2 install CD. I followed the tutorial from the Debian wiki:
http://wiki.debian.org/NvidiaGraphicsDrivers
Code: Select all
# apt-get install module-assistant gcc nvidia-kernel-common
# m-a update
# m-a prepare
# m-a auto-install nvidia

I also had to install nvidia-xconfig, mesa-utils, and nvidia-settings. I then ran "nvidia-xconfig".

I also apparently ran into this bug mentioned in the Debian wiki article:
BUG: There is a bug when you 'apt-get install nvidia-kernel-common' you are asked to insall 40+ packages. (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=303521)

Well, I did not read that far in the wiki untill I had already installed the driver. Fortunately, it all went well. The driver runs well.
Code: Select all
tom@debian:/data/sauerbraten$ cd /data/
tom@debian:/data$ glxinfo | grep -i direct
direct rendering: Yes
tom@debian:/data$

This has been a very informative thread. I learned a lot.
tommcd
 
Posts: 33
Joined: 2006-07-14 10:47
Location: Philadelphia, USA

Doing this HowTo in fresh Lenny install...

Postby mdevour » 2008-12-08 04:27

I'm following the HowTo in hopes of enabling 3d acceleration on my fresh Lenny net install from the current weekly build image.

The first hitch I ran into was that, by default, only the main repositories are included in sources.list. mzilikazi, you might want to mention that contrib and/or non-free need to be added before you can install the nvidia kernel source and other pakages, for the benefit of others working on a fresh install?

The next hitch is that, with the newfangled stripped down version of xorg.conf, there is no 'nv' or 'vesa' driver line to change to 'nvidia.' So I'm off to find a representative xorg.conf "Device" entry...

In the Debian Wiki, nVidia Graphics Drivers page,the section on how to configure X to use the nvidia driver the manual way says:

Edit /etc/X11/xorg.conf:

* If it contains a "Module" section, be sure that it contains a line:

Code: Select all
Load "glx"

... and remove or comment out (prepend with a #) any lines that refer to the "dri" or "GLCore" modules.

* In the "Device" section for your video card, change the driver (normally nv or vesa) to nvidia. If the driver is not defined, add the line

Code: Select all
Driver "nvidia"


Well, I don't have a "Module" section, but I added the Driver line so my Device section now looks like:

Code: Select all
Section "Device"
   Identifier   "Configured Video Device"
   Driver   "nvidia"
EndSection


Adding a little more detail to this part of the HowTo would be helpful, I think.

Now to save, then restart gnome... It says there's a display manager running on display 0 and do I want to go ahead anyway... yes... some flickering and transient blackness, a grey screen with the "X" in the middle, and another dialog warning that this session was started on display 1...

Finally, I've managed to log into a new session which seems to be functional.

Lets try:
Code: Select all
# glxinfo|grep rendering
bash: glxinfo: command not found


Okay, Debian's package database tells me that glxinfo is in package mesa-utils... Load Synaptic and install it.

Is this another thing to add to the HowTo?

Try again:

Code: Select all
# glxinfo|grep rendering
direct rendering: Yes


Wahoo! YES! :mrgreen:

Allright, now to try nvidia-settings... Opens a very pretty looking GUI configuration window showing all sorts of stuff. It seems to have identified my GeForce 8600 GT; the thermal monitor is even working. This is good.

Okay, now it's off to see if I can break it on something that uses 3d... Hmmm... Synaptic... Neverball...

Lordy, it works!!! I've never seen how the game's supposed to behave before! :lol:

Okay then, the upgrade to Lenny is paying off!

Thanks to mzilikazi for maintaining this HowTo, and anarchyinc666 for his index of HowTo's.

Now to bring over some more of my configuration stuff and data!! Oh, and maybe install a few more 3d games! 8)

Mike D.
mdevour
 
Posts: 342
Joined: 2006-03-05 17:55

Postby mzilikazi » 2008-12-08 14:12

Thanks for the suggestions mdevour. Good ideas! Glad I thought of them. ;) I kid I kid....

It's been updated.
Debian Sid Laptops:
AMD Athlon(tm) 64 X2 Dual-Core Processor TK-55 / 1.5G
Intel(R) Pentium(R) Dual CPU T2390 @ 1.86GHz / 3G
User avatar
mzilikazi
Forum Ninja
 
Posts: 3321
Joined: 2004-09-16 02:14
Location: Colorado Springs, CO

Postby mdevour » 2008-12-08 21:13

mzilikazi wrote:Thanks for the suggestions mdevour. Good ideas! Glad I thought of them. ;) I kid I kid....

It's been updated.


Great! It's nice to actually contribute something to the community that's helped me so much.

Mike D.
mdevour
 
Posts: 342
Joined: 2006-03-05 17:55

Postby frenchn00b » 2008-12-29 23:38

Hello,

I just installed a kernel 2.6.27.8 #1 SMP Mon Dec 29 15:13:50 CET 2008 i686 GNU/Linux
method debian & method lavene, it's working so great :) !

So the nvidia isnt working :( :( via the debian way.

Code: Select all
     aptitude install module assistant build-essential
        m-a update
        m-a prepare
        m-a auto-install nvidia -f
        modprobe nvidia


I get those error messages :
:/var/cache/modass$ for each in nvid* ; do echo "$each" >> /tmp/nvidialog ; echo "------------" >> /tmp/nvidialog ; cat "$each" >> /tmp/nvidialog ; done ; gedit /tmp/nvidialog

http://pastebin.com/f23dfe3ab
Code: Select all
nvidia-kernel-legacy-source.avail_version
------------
1.0.7184-3nvidia-kernel-source.avail_version
------------
1.0.8776-4nvidia-kernel-source.buildlog.2.6.27.8.1230590616
------------
/usr/bin/make  -f debian/rules clean
make[1]: Entering directory `/usr/src/modules/nvidia-kernel'
# select which makefile to use.
rm -f /usr/src/modules/nvidia-kernel/nv/Makefile || true
if [ 6 = 6  ]; then \
        cd /usr/src/modules/nvidia-kernel/nv ; \
        ln -s Makefile.kbuild Makefile ; \
        cd .. ; \
        if [ 0  = 1 ] ; then \
           dpatch apply 04_minion ; \
        fi ; \
        if [ 0 = 1 ]; then \
           dpatch apply 01_sysfs ; \
      dpatch status 01_sysfs >patch-stamp ; \
      dpatch apply 02_pcialias ; \
                  dpatch status 02_pcialias >>patch-stamp ; \
        fi ; \
   fi....


bla bla

...

inter type
make[4]: *** [/usr/src/modules/nvidia-kernel/nv/nv.o] Error 1
make[3]: *** [_module_/usr/src/modules/nvidia-kernel/nv] Error 2
make[3]: Leaving directory `/usr/src/linux-2.6.27.8'
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[2]: *** [mdl] Error 1
make[2]: Leaving directory `/usr/src/modules/nvidia-kernel/nv'
make[1]: *** [build-stamp] Error 2
make[1]: Leaving directory `/usr/src/modules/nvidia-kernel'
make: *** [kdist_image] Error 2
nvidia-kernel-source.cur_version
------------
1.0.8776-4



EDIT UPDATE, some success in some way :

Hi !

Succcess.

I just installed thislinux-image-2.6.26-bpo.1-686 from the backport:
Code: Select all
i  libsilc-1.1-2                        1.1.7-1~bpo40+1                          SILC library (silc-toolkit)
ii  linux-headers-2.6.26-bpo.1-686       2.6.26-12~bpo40+1                        Header files for Linux 2.6.26-bpo.1-686
ii  linux-headers-2.6.26-bpo.1-common    2.6.26-12~bpo40+1                        Common header files for Linux 2.6.26-bpo.1
ii  linux-image-2.6.26-bpo.1-686         2.6.26-12~bpo40+1                        Linux 2.6.26 image on PPro/Celeron/PII/PIII/
ii 


and m-a a-i gspca failed but :
http://mxhaard.free.fr/spca50x/Download ... 224.tar.gz
succeeded !

It seems that the method to compile kernel we did (lavene method) is far different to the kernel in the backport (made by linux professionals)

So, what is it ?
The deb is here :
http://www.backports.org/debian/pool/main/l/linux-2.6/
those bpo kernels


How to compile kernel well, like very debian way/professionals ?

at least for the webcam running lol
frenchn00b
 
Posts: 47
Joined: 2007-09-01 22:02

Re: Nvidia driver - Debian way, custom (or not) kernel.

Postby Bro.Tiag » 2009-02-13 20:37

Fibonacci wrote:
mzilikazi wrote:
Standard method

Add contrib and non-free to /etc/apt/sources.list.d/sources.list
Code: Select all
deb ftp://ftp.us.debian.org/debian/ sid main contrib non-free
deb ftp://ftp.us.debian.org/debian/ testing main contrib non-free
deb ftp://ftp.us.debian.org/debian/ stable main contrib non-free


Well first problem.. I am logged in as a root, but I can not add the source.list. And there seems to be no list atm. I just installed Debian, quite new to Linux, first time on Debian.. Maybe I am doing something wrong. Please try to explain me.. :)

Here is screenshot

So I logged in as a root, wrote in editor the above quite from the creator of this thread so that I can actually get smth but it won't allow me to add this list of sources.


Edit: Link

I believe that that is a folder you are trying to write to. Your source list is in /etc/apt/sources.list

Cheers
User avatar
Bro.Tiag
 
Posts: 1937
Joined: 2007-06-02 19:14

Postby Fibonacci » 2009-02-14 06:59

You are very fast Bro.Tiag :)

As I managed to delete that post, but you were already into replay to it. I have solved that issue but thanks a lot anyways. I was mixing folders, you were right :)

But here is the thing, I managed to install Nvidia drivers, properly or so I think, because I got Nvidia splash screen. Is that enough to prove installation went well? :)

What I would like to point out is the following. Maybe for begginers like me, there should be a line saying that when we change xorg.conf the PC Bus, we should check ourselves before for our specific graphic card. Because what happened is I used the one supplied in this topic. And it didn't work, the X wouldn't start.. went on internet through phone and found PCI Bus ID for my graphic card, edited xorg.conf and it seems that it worked out.

Eitherway, the last thing.. I suppose this line is supposed to check if installation went well..
Code: Select all
glxinfo|grep rendering


But all I get as an answer is..
Code: Select all
bash: glxinfo: command not found

or logged as root
Code: Select all
-su: glxinfo: command not found



Hence, my question is, beside Nvidia splash screen while booting, how else to check 3D works, as I havn't noticed any difference from what my desktop looked like before?
Fibonacci
 
Posts: 12
Joined: 2009-02-12 14:54

Postby Telemachus » 2009-02-14 11:32

Fibonacci wrote:Either way, the last thing.. I suppose this line is supposed to check if installation went well..
Code: Select all
glxinfo|grep rendering


But all I get as an answer is..
Code: Select all
bash: glxinfo: command not found

or logged as root
Code: Select all
-su: glxinfo: command not found

You have to install a package called mesa-utils in order to have glxinfo.
"We have not been faced with the need to satisfy someone else's requirements, and for this freedom we are grateful."
Dennis Ritchie and Ken Thompson, The UNIX Time-Sharing System
User avatar
Telemachus
 
Posts: 4677
Joined: 2006-12-25 15:53

Postby Bro.Tiag » 2009-02-15 23:58

Telemachus wrote:
Fibonacci wrote:Either way, the last thing.. I suppose this line is supposed to check if installation went well..
Code: Select all
glxinfo|grep rendering


But all I get as an answer is..
Code: Select all
bash: glxinfo: command not found

or logged as root
Code: Select all
-su: glxinfo: command not found

You have to install a package called mesa-utils in order to have glxinfo.

Not to be a pain in the arse, and maybe I missed it in the OP, but installing mesa-utils is not included there, yet it is suggest to do the the following.
mzilikazi wrote:
After you've gotten the driver to build and Xwindows working you can do a quick test for Direct Rendering:
Code: Select all
glxinfo|grep rendering

Also of interest is nvidia-settings


Cheers
User avatar
Bro.Tiag
 
Posts: 1937
Joined: 2007-06-02 19:14

Postby GNU.Wasabi » 2009-02-22 09:57

Actually mesa-utils isn't needed. nvidia-settings --glxinfo
Cheers, GNU.Wasabi
GNU.Wasabi
 
Posts: 349
Joined: 2008-03-31 15:55
Location: Still trying to figure out for what this field is...

Postby mzilikazi » 2009-03-01 16:35

Thanks Bro.Tiag & GNU.Wasabi - made a small edit to include this info.
Debian Sid Laptops:
AMD Athlon(tm) 64 X2 Dual-Core Processor TK-55 / 1.5G
Intel(R) Pentium(R) Dual CPU T2390 @ 1.86GHz / 3G
User avatar
mzilikazi
Forum Ninja
 
Posts: 3321
Joined: 2004-09-16 02:14
Location: Colorado Springs, CO

Postby monacelli » 2009-03-02 01:22

A simple "apt-get install nvidia-glx" worked for me on a fresh testing install with non-free and contrib added to the sources.list. After install nvidia-glx all I had to do was add the appropriate driver line to xorg.conf and restart x. Maybe I'm missing something but it seems like you guys are making the process harder than it really is.
Image
monacelli
 
Posts: 9
Joined: 2007-12-20 12:38
Location: Jericho, KS

PreviousNext

Return to Docs, Howtos, Tips & Tricks

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable