modprobe: module dm-raid45 not found in modules.dep

Share your own howto's etc. Not for support questions!

modprobe: module dm-raid45 not found in modules.dep

Postby Linadian » 2014-04-19 09:34

Edit: This 'error' is reminiscent of that annoying autoexec.bat nonsense (a line in the file that points to nothing) during DOS loading before the GUI in Windows 98, I hated it back then and I still hate it, lol. :wink: :? :evil:

I run Wheezy Xfce 7.x on my Intel (ICH10R) SATA Raid 0 (fake, hardware, whatever you want to call it, it's not LVM), but was getting this error right after the grub screen:
Code: Select all
modprobe: module dm-raid45 not found in modules.dep

After doing some research and tweaking a few fixes I found, this worked for me (DISCLAIMER: my Raid level is 0, I'm not sure if this may effect your setup, it worked in mine):

You've probably heard/read this a thousand times but...back up your stuff first!
I use gedit because it can create backup copies (it's in gedit's settings), then rename the backup <filename>.original~ (that's a squiggly dash, not a normal dash, squiggly=backup file)

Remove (or comment out) if the line exists from /etc/initramfs-tools/modules
Code: Select all

As root run:
Code: Select all
update-initramfs -u

REMOVE (NO commenting out) this line from (be careful in this file, remove the newly created empty space, maintain the proper left-to-right spacing structure) /usr/share/initramfs-tools/hooks/dmraid
Code: Select all
force_load dm-raid45

Reboot and watch a proper INIT :wink: :D

Again, this works on MY system, please do not come back to this thread to yell at me if the fix or you bork your system.

Edited for minor corrections, spelling and grammar.
AMD FX-8350, Gigabyte GA-990FXA-UD3 (rev 4.0), 2 Intel 520 Series 120GB SSDs, 2 Seagate storage HDDs, 16GB Kingston HyperX Fury DDR3, Asus Radeon R7 250, Thermaltake V3 Black AMD Edition case, 750W Tt Toughpower Gold PSU...running no systemd PCLinuxOS
User avatar
Posts: 435
Joined: 2013-12-20 15:25
Location: In a diff non-virusd forum

Return to Docs, Howtos, Tips & Tricks

Who is online

Users browsing this forum: No registered users and 4 guests