Suspend/Hibernate with nvidia [m/b] chipsets in Jessie

Share your own howto's etc. Not for support questions!

Suspend/Hibernate with nvidia [m/b] chipsets in Jessie

Postby PeterB » 2015-05-02 14:31

.
The change of kernel from Wheezy to Jessie introduces this WILL_NOT_FIX {sic} kernel regression, that for users of some nvidia chipset motherboards can break suspend & hibernate. Please note, this has nothing to do with nvidia graphics cards!
https://bugzilla.kernel.org/show_bug.cgi?id=48951

Its claimed to be an nvidia bug, but kernels prior to 3.3 were unaffected. Happily comment 20 in the thread contains a simple workaround.
https://bugzilla.kernel.org/show_bug.cgi?id=48951#c20

If the command
Code: Select all
lspci | grep MCP5

returns some output then you may well be affected. Aaron's fix is as follows;-

Create a file (name is unimportant I think, I called mine 50-async.rules), and place it in /etc/udev/rules.d/
The contents should be-

Code: Select all
ACTION=="add", SUBSYSTEM=="scsi", ENV{DEVTYPE}=="scsi_target", ATTR{power/async}="disabled"

A blank line at the end of the file is probably a good idea.



Resuming from a suspend/hibernate with USB devices attached may also fail with these motherboards. Possible fix is this udev rule;-
Code: Select all
ACTION=="add", SUBSYSTEM=="usb", TEST=="power/control", ATTR{power/control}="on"

Apply as the async rule above. I called mine 55-usbcore.rules

Hope this helps someone, it took me many hours of searching to find these fixes.


PB.
PeterB
 
Posts: 104
Joined: 2010-10-03 16:53

Return to Docs, Howtos, Tips & Tricks

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable