HOWTO: Realtime 2.6.20 kernel!

Share your own howto's etc. Not for support questions!

Postby thamarok » 2007-04-29 16:56

You do have an X Server open, do you? Now this is a mystery that is probably very hard to solve...

Try with make gconfig.. If that didn't work I think your best bet would be menuconfig :(
thamarok
 
Posts: 1798
Joined: 2006-10-12 16:36

Postby fvs » 2007-05-01 11:28

Tried
debian:/usr/src/linux-2.6.20.3# make gconfig
*
* Unable to find the GTK+ installation. Please make sure that
* the GTK+ 2.0 development package is correctly installed...
* You need gtk+-2.0, glib-2.0 and libglade-2.0.
*
make[1]: *** No rule to make target `scripts/kconfig/.tmp_gtkcheck', needed by `scripts/kconfig/gconf.o'. Stop.
make: *** [gconfig] Error 2
If that didn't work I think your best bet would be menuconfig
_________________

Don't know right answers once I use menuconfig?
each time I select It wont do anything, need some more direction.When I get to the window that asks what to enter,
".config" I don't know what to enter? I have entered "2.6.20.3"
and it says it don't exist?
fvs
 
Posts: 139
Joined: 2006-06-16 22:33

Postby Lost Dog » 2007-05-01 13:17

fvs wrote:Tried
debian:/usr/src/linux-2.6.20.3# make gconfig
*
* Unable to find the GTK+ installation. Please make sure that
* the GTK+ 2.0 development package is correctly installed...
* You need gtk+-2.0, glib-2.0 and libglade-2.0.
*
make[1]: *** No rule to make target `scripts/kconfig/.tmp_gtkcheck', needed by `scripts/kconfig/gconf.o'. Stop.
make: *** [gconfig] Error 2
If that didn't work I think your best bet would be menuconfig
_________________

Don't know right answers once I use menuconfig?
each time I select It wont do anything, need some more direction.When I get to the window that asks what to enter,
".config" I don't know what to enter? I have entered "2.6.20.3"
and it says it don't exist?


This is telling you that you need gtk+-2.0, glib-2.0 and libglade-2.0.

You'll need to apt-get (or synaptic) libgtk2.0-common (maybe -dev as well), libglib2.0 (-dev) and libglade2-0 (-dev).

Sorry if I missed it earlier but what about "make xconfig"?
User avatar
Lost Dog
 
Posts: 250
Joined: 2006-08-11 21:54
Location: North of the Columbia River

Postby fvs » 2007-05-01 14:50

debian:/usr/src/linux-2.6.20.3# make xconfig
HOSTCXX scripts/kconfig/qconf.o
/bin/sh: g++: command not found
make[1]: *** [scripts/kconfig/qconf.o] Error 127
make: *** [xconfig] Error 2
debian:/usr/src/linux-2.6.20.3#

debian:/usr/src/linux-2.6.20.3# apt-get install gtk+-2.0
Reading package lists... Done
Building dependency tree... Done
E: Couldn't find package gtk+-2.0
debian:/usr/src/linux-2.6.20.3# apt-get install glib-2.0
Reading package lists... Done
Building dependency tree... Done
E: Couldn't find package glib-2.0
debian:/usr/src/linux-2.6.20.3# apt-get install libglade-2.0
Reading package lists... Done
Building dependency tree... Done
E: Couldn't find package libglade-2.0
fvs
 
Posts: 139
Joined: 2006-06-16 22:33

Postby Lost Dog » 2007-05-01 16:27

fvs wrote:debian:/usr/src/linux-2.6.20.3# make xconfig
HOSTCXX scripts/kconfig/qconf.o
/bin/sh: g++: command not found
make[1]: *** [scripts/kconfig/qconf.o] Error 127
make: *** [xconfig] Error 2
debian:/usr/src/linux-2.6.20.3#

debian:/usr/src/linux-2.6.20.3# apt-get install gtk+-2.0
Reading package lists... Done
Building dependency tree... Done
E: Couldn't find package gtk+-2.0
debian:/usr/src/linux-2.6.20.3# apt-get install glib-2.0
Reading package lists... Done
Building dependency tree... Done
E: Couldn't find package glib-2.0
debian:/usr/src/linux-2.6.20.3# apt-get install libglade-2.0
Reading package lists... Done
Building dependency tree... Done
E: Couldn't find package libglade-2.0


Try it through synaptic. I may not have had the names of the file exactly as apt wants them. Also, I don't believe "gtk+-2.0", "glib-2.0" and "libglade-2.0" are the names of the packages.

Also, do you have g++? Make sure you have gcc, g++, etc.

You need may need (some of these may be redundant and some may depend on others but this is just what I tracked down):

libglib2.0-0
libglib2.0-dev
libgtk2.0-common
libgtk2.0-dev
libgtk2.0-0
libglade2-0
libglade2-dev
libglade-gnome0
libglade-gnome0-dev
User avatar
Lost Dog
 
Posts: 250
Joined: 2006-08-11 21:54
Location: North of the Columbia River

Postby fvs » 2007-05-01 18:16

After doing all of the above I tried to install, But got this,
LD .tmp_vmlinux1
kernel/built-in.o: In function `clocksource_watchdog':
clocksource.c:(.text+0x15541): undefined reference to `tick_clock_notify'
make[1]: *** [.tmp_vmlinux1] Error 1
make[1]: Leaving directory `/usr/src/linux-2.6.20.3'
make: *** [debian/stamp-build-kernel] Error 2
debian:/usr/src/linux-2.6.20.3# dpkg -i *.deb
dpkg: error processing *.deb (--install):
cannot access archive: No such file or directory
Errors were encountered while processing:
fvs
 
Posts: 139
Joined: 2006-06-16 22:33

Postby Lost Dog » 2007-05-01 18:52

fvs wrote:After doing all of the above I tried to install, But got this,
LD .tmp_vmlinux1
kernel/built-in.o: In function `clocksource_watchdog':
clocksource.c:(.text+0x15541): undefined reference to `tick_clock_notify'
make[1]: *** [.tmp_vmlinux1] Error 1
make[1]: Leaving directory `/usr/src/linux-2.6.20.3'
make: *** [debian/stamp-build-kernel] Error 2
debian:/usr/src/linux-2.6.20.3# dpkg -i *.deb
dpkg: error processing *.deb (--install):
cannot access archive: No such file or directory
Errors were encountered while processing:


At what point is this happening? Did you get xconfig or gconfig working?

Personally, I'd recommend:

make-kpkg clean
make oldconfig
make xconfig (or gconfig)
(as root) make-kpkg --initrd --revision=(whatever you want here) kernel_image

Looking a bit closer it looks like the kernel didn't compile then you're trying to install a non-existent .deb file.
User avatar
Lost Dog
 
Posts: 250
Joined: 2006-08-11 21:54
Location: North of the Columbia River

Postby fvs » 2007-05-01 19:19

"At what point is this happening? Did you get xconfig or gconfig working? "

I did get xconfig to work, Not knowing what to select and what to put into it. Need some help to configure in the file. Tried once more,

ernel/built-in.o: In function `clocksource_watchdog':
clocksource.c:(.text+0x15541): undefined reference to `tick_clock_notify'
make[1]: *** [.tmp_vmlinux1] Error 1
make[1]: Leaving directory `/usr/src/linux-2.6.20.3'
make: *** [debian/stamp-build-kernel] Error 2
debian:/usr/src/linux-2.6.20.3#

Maybe I should start from scratch, Just don't know what to enter in "xconfig"

This is what I have in my directories,
debian:/usr/src# ls
linux-2.6.20.3 linux-2.6.20.3.tar.bz2 patch-2.6.20-rt8

debian:/usr/src/linux-2.6.20.3# cd ..
debian:/usr/src# ls
linux-2.6.20.3 linux-2.6.20.3.tar.bz2 patch-2.6.20-rt8
debian:/usr/src# cd linux-2.6.20.3
debian:/usr/src/linux-2.6.20.3# ls
arch drivers MAINTAINERS sound
block fs Makefile stamp-arch-conf
conf.vars include mm stamp-configure
COPYING init net stamp-configure-arch
CREDITS ipc README stamp-configure-indep
crypto Kbuild REPORTING-BUGS stamp-debian
debian kernel scripts stamp-indep-conf
Documentation lib security usr
fvs
 
Posts: 139
Joined: 2006-06-16 22:33

Postby Kateikyoushi » 2007-05-08 00:43

This is your problem.

Code: Select all
 CC      kernel/time/clocksource.o
kernel/time/clocksource.c: In function ‘clocksource_watchdog’:
kernel/time/clocksource.c:118: warning: implicit declaration of function ‘tick_clock_notify’


I do not know why does it happen but without the patch it compiles.
Try another newer version of the kernel.


Now to my problem.
I managed to compile it but when I try to install I get the following.

Code: Select all
Found kernel: /boot/vmlinuz-2.6.20.3
Found kernel: /boot/vmlinuz-2.6.18-4-686
Updating /boot/grub/menu.lst ... done

Preparing to replace madwifi-modules-2.6.18-4-686 1:0.9.2+r1842.20061207-2+2.6.18.dfsg.1-12etch1 (using madwifi-modules-2.6.18-4-686_0.9.2+r1842.20061207-2+2.6.18.dfsg.1-12etch1_i386.deb) ...
Unpacking replacement madwifi-modules-2.6.18-4-686 ...
Setting up linux-headers-2.6.20.3 (2.6.20.3-10.00.Custom) ...

Setting up linux-image-2.6.20.3 (2.6.20.3-10.00.Custom) ...
Running depmod.
Finding valid ramdisk creators.
Failed to find suitable ramdisk generation tool for kernel version
2.6.20.3 on running kernel 2.6.18-4-686 in /usr/sbin/yaird
dpkg: error processing linux-image-2.6.20.3 (--install):
 subprocess post-installation script returned error exit status 9
Setting up madwifi-modules-2.6.18-4-686 (0.9.2+r1842.20061207-2+2.6.18.dfsg.1-12etch1) ...

Errors were encountered while processing:
 linux-image-2.6.20.3


I do not understand now, what is the problem, the no suitable ramdisk ? Or the madwifi ?

Any ideas ? Thanks in advance.
Kateikyoushi
 
Posts: 30
Joined: 2007-05-08 00:35

Postby Kateikyoushi » 2007-05-08 06:48

Okay I solved it. Removed the ramdisk = /usr/sbin/yaird line from /etc/kernel-img.conf then it falls back to mkinitramfs.

If only I would know why does it work for the others.
Kateikyoushi
 
Posts: 30
Joined: 2007-05-08 00:35

Postby Kateikyoushi » 2007-05-08 07:51

Well it is not over yet. :?

Although the kernel was built it won't boot, waiting for root filesystem, seems it tries to mount my atadrive as SCSI.

I get the latest kernel that might work, or not compile any scsi modules.
Kateikyoushi
 
Posts: 30
Joined: 2007-05-08 00:35

Postby Kateikyoushi » 2007-05-08 18:19

Solved, most likely it was the kernel configuration what was wrong, even thought I used the debian one.

Anyway I decided to patch the debian kernel instead of the vanilla and it all went through. :)
Kateikyoushi
 
Posts: 30
Joined: 2007-05-08 00:35

Postby jongi » 2007-05-11 15:26



Can I use this when compiling 2.6.21.1?
jongi
 
Posts: 477
Joined: 2007-04-15 02:41

Postby thamarok » 2007-05-11 16:56

jongi wrote:


Can I use this when compiling 2.6.21.1?
Haven't tried yet. Try your luck and see what happens.
thamarok
 
Posts: 1798
Joined: 2006-10-12 16:36

Postby jongi » 2007-05-11 17:06

After I ran update-grub, I notice that there is no line referencing initrd, ie something similar to this

Code: Select all
initrd          /boot/initrd.img-2.6.18-4-686


Currently the grub entry looks like this
Code: Select all
title           Debian GNU/Linux, kernel 2.6.21jongi1
root            (hd2,6)
kernel          /boot/vmlinuz-2.6.21jongi1 vga=791 root=/dev/sda7 ro
savedefault
jongi
 
Posts: 477
Joined: 2007-04-15 02:41

PreviousNext

Return to Docs, Howtos, Tips & Tricks

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable