Stretch on Thinkpad T60 with SSD crashes [solved]

Share your own howto's etc. Not for support questions!

Stretch on Thinkpad T60 with SSD crashes [solved]

Postby IlikeBörek » 2017-09-29 21:01

Hi there,

I just installed Debian Stretch (Kernel 4.12.0-0.bpo.1-amd64) on my old Thinkpad T60 with an OCZ Octane SSD. Unfortunately after reboot, if started to behave strange: The system froze on nine out of ten tries to boot it. When it booted successfully, the SSD went to Read-Only after heavy load.

After I added
Code: Select all
libata.force=noncq

to the kernel command-line it worked.
I can't recall where I found this hint, so I thought posting it here would be good in case there are others out there with that problem.
IlikeBörek
 
Posts: 6
Joined: 2017-09-29 20:42

Re: Stretch on Thinkpad T60 with SSD crashes [solved]

Postby stevepusser » 2017-09-29 21:49

Was it also crashing with the normal 4.9 kernel?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Krita 3.3.2.1, Pale Moon 27.6.0, Audacity 2.2.0, mpv 0.27.0, Corebird 1.7.1, Firefox 57.0, SMPlayer 17.11.2
User avatar
stevepusser
 
Posts: 8905
Joined: 2009-10-06 05:53

Re: Stretch on Thinkpad T60 with SSD crashes [solved]

Postby IlikeBörek » 2017-10-13 11:41

stevepusser wrote:Was it also crashing with the normal 4.9 kernel?

no!
IlikeBörek
 
Posts: 6
Joined: 2017-09-29 20:42

Re: Stretch on Thinkpad T60 with SSD crashes [solved]

Postby pylkko » 2017-10-13 17:32

So, how is this post a "Doc, Howto, Tips and Tricks"?
User avatar
pylkko
 
Posts: 1180
Joined: 2014-11-06 19:02

Re: Stretch on Thinkpad T60 with SSD crashes [solved]

Postby debiman » 2017-10-13 18:42

in other words: why do you need the newest backported kernel on a piece of pretty old hardware?
answer: you don't. it isn't even a good idea.
User avatar
debiman
 
Posts: 1545
Joined: 2013-03-12 07:18

Re: Stretch on Thinkpad T60 with SSD crashes [solved]

Postby IlikeBörek » 2017-10-23 10:32

pylkko wrote:So, how is this post a "Doc, Howto, Tips and Tricks"?

I don't know. I put it in "System Configuration" and someone moved it here :)

IlikeBörek wrote:
stevepusser wrote:Was it also crashing with the normal 4.9 kernel?

no!

Sorry, I was wrong here! It was crashing with the 4.9 kernel. Then I started a repair system, chrooted into the running system, installed the new kernel and it kept on crashing. Then I spend a night with forums and kernel-parameters and forgot that I installed the backport-kernel. I'll try later if libata.force=noncq also resolves the issue on 4.9.
IlikeBörek
 
Posts: 6
Joined: 2017-09-29 20:42


Return to Docs, Howtos, Tips & Tricks

Who is online

Users browsing this forum: No registered users and 2 guests

fashionable