HOWTO: Debian Lenny and Virtualbox (Non-OSE) USB

Share your own howto's etc. Not for support questions!

HOWTO: Debian Lenny and Virtualbox (Non-OSE) USB

Postby plb » 2008-12-13 17:37

This is pretty simple, but a lot of people seem to have questions on how to achieve it. For Debian Lenny I found the following method the easiest. Just open your /etc/fstab and add the following entry and be sure to change devgid to the group number listed in your /etc/group file for vboxusers:

none /proc/bus/usb usbfs rw,user,devgid=111,devmode=0666 0 0
plb
 
Posts: 472
Joined: 2007-04-22 14:24
Location: NYC

Re: HOWTO: Debian Lenny and Virtualbox (Non-OSE) USB

Postby Agent-X » 2009-10-02 22:35

^^^ :x

Was able to get Sony Voice Recorder and software working under virtual win 2000 pro, which was under lenny linux.

tasks I did:
I installed the non-ose version

- go to virtualbox website

I added things to fstab

### USB FOR VIRTUALBOX
none /proc/bus/usb usbfs rw,user,devgid=(insertyourgroup),devmode= 0 0

insertyourgroup = vboxusers or usbusers
i can't remember

I added a usbusers

I added things to the 91 permissions

Something was telling me to go to 40-permissions.rules, but it seems that the only thing similar was in 91. and there was a couple of USB lines that looked different but similar. It took a moment of thinking, but I placed the usbusers comment around in that area.

I played with the settings in virtualbox for the virtual OS.
I altered the USB settings
I added my USB devices (not simply adding blank usb devices to be detected)

And, I did this:
mkdir -p /dev/bus/usb/.usbfs
domount usbfs "" /dev/bus/usb/.usbfs -obusmode=0700,devmode=0600,listmode=0644
ln -s .usbfs/devices /dev/bus/usb/devices
mount --rbind /dev/bus/usb /proc/bus/usb


example:
# mount devpts if it is compiled in (older devfs didn't require it
# to be compiled in at all).
#

mkdir -p /dev/bus/usb/.usbfs
domount usbfs "" /dev/bus/usb/.usbfs -obusmode=0700,devmode=0600,listmode=0644
ln -s .usbfs/devices /dev/bus/usb/devices
mount --rbind /dev/bus/usb /proc/bus/usb

if [ "$KERNEL" = Linux ]
then
#
# Since kernel 2.5.something,


websites i visited until the issue was solved (in order; i also used this website):
http://www.davidgrant.ca/virtualbox_usb ... untu_hardy
http://www.virtualbox.org/wiki/USB_on_Fedora_6
http://www.google.com/#hl=en&source=hp& ... fp=1&cad=b
http://www.google.com/#hl=en&q=virtualb ... 2e99206b9c
http://www.google.com/#hl=en&source=hp& ... 2e99206b9c
http://forums.virtualbox.org/viewtopic.php?f=7&t=22174
http://forums.virtualbox.org/viewtopic. ... 669#p33944
http://www.google.com/#hl=en&source=hp& ... 2e99206b9c
http://opensourceexperiments.wordpress. ... dows-host/
http://www.google.com/#hl=en&q=virtualb ... 2e99206b9c
http://www.davidgrant.ca/virtualbox_usb ... untu_hardy
https://help.ubuntu.com/community/VirtualBox#USB
https://help.ubuntu.com/community/VirtualBox/USB
Agent-X
 
Posts: 6
Joined: 2007-12-02 04:36


Return to Docs, Howtos, Tips & Tricks

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable