Make A Choppy Desktop Feel Smooooth

Share your own howto's etc. Not for support questions!

Re: Make A Choppy Desktop Feel Smooooth

Postby Penguin Skinner » 2009-07-14 14:57

dbbolton wrote:Has anyone dared to try anything lower than -1 ?

Yeah ... since moving to KDE4, I've found a nice value of -8 makes a noticeable improvement in gui desktop performance. This is on a single core P4, 3.4Ghz. With compositing turned off, or running a lighter desktop like openbox, I can't say I notice much difference from the default nice value of 0.
Penguin Skinner
 
Posts: 709
Joined: 2005-09-15 20:37
Location: North by Northwest

Re: Make A Choppy Desktop Feel Smooooth

Postby ghostdawg » 2009-07-19 13:42

I'll have to try this on my G3 iMac. When scrolling with Iceweasel, it have that choppy feeling, which I hate.
Tower | Debian Testing & Mageia 1 | HP DX5150 AMD64 | 512gb | 40gb
AAO | Mandriva 2010.2 | Intel Atom | 1gb | 160gb
Mini Mac G4 | Debian & OSX | 1gb | 60gb
User avatar
ghostdawg
 
Posts: 1094
Joined: 2006-08-29 03:39
Location: STLMO

Re: Make A Choppy Desktop Feel Smooooth

Postby F37U5G0D » 2009-08-01 05:49

I switched to opera because of that choppy scrolling feel in iceweasel.
F37U5G0D
 
Posts: 102
Joined: 2008-07-27 01:30
Location: Monmouth, Il

Re: Make A Choppy Desktop Feel Smooooth

Postby gnudude » 2009-08-01 15:06

about:config >> smoothscroll
gnudude
 
Posts: 1712
Joined: 2009-04-05 17:30
Location: gone....

Re: Make A Choppy Desktop Feel Smooooth

Postby Mr B » 2009-08-01 19:22

Hmmm - interesting..... Works better for me (i.e. smoother) with "smoothscroll" set to false. If set "true", there seems to be a bit of lag which gives a kind of motion sickness feeling.
Mr B
 
Posts: 184
Joined: 2008-07-26 15:30

Re: Make A Choppy Desktop Feel Smooooth

Postby dbbolton » 2009-09-27 20:43

Did anyone figure out a solution to the nice value not showing up in dpkg-reconfigure x11-common or the config file? It showed up in one of me testing systems but in another one it didn't.

According to the man page, the only available option is "allowed_users".
GitHub | zsh docs in Letter PDF

Telemachus wrote:Put down the CGI.
User avatar
dbbolton
 
Posts: 2133
Joined: 2007-06-20 08:17
Location: Iapetus

Re: Make A Choppy Desktop Feel Smooooth

Postby Jackiebrown » 2009-09-27 21:21

craigevil wrote:Ok so is it "nice_value = -1" or without the quotes?

I don;t get it either And dpkg-reconfigure -plow x11-common removes it if it is there
User avatar
Jackiebrown
 
Posts: 1276
Joined: 2007-01-02 04:46
Location: San Antonio, TX

Re: Make A Choppy Desktop Feel Smooooth

Postby damentz » 2009-09-27 23:41

I don't think that setting is used anymore the last time I tried. In compensation for that, I have a patch (modification from Con Kolivas) to reduce the nice of X included in the Liquorix kernel.
damentz
 
Posts: 43
Joined: 2009-09-14 03:01

Re: Make A Choppy Desktop Feel Smooooth

Postby register88 » 2009-10-02 04:29

damentz wrote:I don't think that setting is used anymore the last time I tried. In compensation for that, I have a patch (modification from Con Kolivas) to reduce the nice of X included in the Liquorix kernel.


So, where is the patch?
register88
 
Posts: 17
Joined: 2009-09-27 01:22

Re: Make A Choppy Desktop Feel Smooooth

Postby bugsbunny » 2009-10-29 04:11

User avatar
bugsbunny
 
Posts: 5355
Joined: 2008-07-06 17:04

Re: Make A Choppy Desktop Feel Smooooth

Postby El1iP3S01D » 2010-05-06 18:41

folks i hav da valu at 7 and my screen luks awesome...I love Debian Linux...u rok Debian...
By the way, Ryoko my Turtle and Saleen s7 TT rule my world...:-p
User avatar
El1iP3S01D
 
Posts: 210
Joined: 2008-04-03 06:49
Location: Bklyn, NY

Re: Make A Choppy Desktop Feel Smooooth

Postby dbbolton » 2010-05-06 22:09

I think it says:
El1iP3S01D wrote:Folks, I have the value at "7" and my screen looks awesome. I love Debian GNU/Linux. You rock, Debian.
GitHub | zsh docs in Letter PDF

Telemachus wrote:Put down the CGI.
User avatar
dbbolton
 
Posts: 2133
Joined: 2007-06-20 08:17
Location: Iapetus

Re: Make A Choppy Desktop Feel Smooooth

Postby AMLJ » 2010-05-23 07:45

craigevil wrote:# Xwrapper.config (Debian X Window System server wrapper configuration file)
#
# This file was generated by the post-installation script of the x11-common
# package using values from the debconf database.
#
# See the Xwrapper.config(5) manual page for more information.
#
# This file is automatically updated on upgrades of the x11-common package
# *only* if it has not been modified since the last upgrade of that package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command as root:
# dpkg-reconfigure x11-common
allowed_users=console

The line "nice_value = 0" is not there.

I have the same problem, and none of the solutions you guys suggested solves the problem, can anyone help me?
AMLJ**0-1-47
User avatar
AMLJ
 
Posts: 973
Joined: 2009-03-18 07:40
Location: Mierlo, Netherlands

Re: Make A Choppy Desktop Feel Smooooth

Postby erron1 » 2015-11-08 20:52

Bumping an old topic, since i cant seem to find an answer to this. Adjusting the
nice value of Xorg eliminates mouse jitter for me in wine and games, when using
a high polling rate. However i can only do this manually with renice and would
also like to know how to set this automatically. None of the suggestions in this
old thread seem to work anymore.
erron1
 
Posts: 5
Joined: 2015-10-30 15:13

Previous

Return to Docs, Howtos, Tips & Tricks

Who is online

Users browsing this forum: No registered users and 2 guests

fashionable