pidgn 2.6.x on lenny

Share your own howto's etc. Not for support questions!

pidgn 2.6.x on lenny

Postby plugwash » 2009-08-19 23:48

Here is a recipie to build a set of 2.6.1 packages for debian lenny based on the packaging ari has done for sid (but not uploaded yet hence the download from svn.debian.org).

wget http://sourceforge.net/projects/pidgin/files/Pidgin/pidgin-2.6.1.tar.bz2 [sourceforge.net]
bunzip2 pidgin-2.6.1.tar.bz2
tar -xf pidgin-2.6.1.tar
gzip pidgin-2.6.1.tar
mv pidgin-2.6.1.tar.gz pidgin_2.6.1.orig.tar.gz
cd pidgin-2.6.1
svn export -r 14052 svn://svn.debian.org/svn/collab-maint/deb-maint/pidgin/trunk/debian
sed -i s/tcl8.6-dev/tcl8.5-dev/ debian/control
sed -i s/tk8.6-dev/tk8.5-dev/ debian/control
sed -i 's/libgstfarsight0.10-dev (>= 0.0.9),//' debian/control
sed -i 's/(>= 0.4.53)//' debian/control
sed -i 's/(>= 1.1.1)//' debian/control
sed -i 's/--enable-vv/--disable-vv/' debian/rules
dpkg-buildpackage

if it complains about missing build-depends install them and run dpkg-buildpackage again

note: I had to disable video/voice because libgstfarsight is not available in lenny.
Last edited by plugwash on 2009-10-02 18:57, edited 2 times in total.
plugwash
 
Posts: 2508
Joined: 2006-09-17 01:10

Re: pidgn 2.6.1 on lenny

Postby Qew » 2009-08-21 16:24

Pidgin 2.6.1 is now in Experimental.

There are a few other changes to what you've mentioned, too. It now depends on tcl-dev and tk-dev, which are dependency packages for tcl8.4-dev and tk8.4-dev. You could always ignore them, because Pidgin will still compile against tcl8.4-dev and tk8.4-dev, but if you want to stop the nagging and don't want to add the -d option to dpkg-buildpackage, then install the new "build dependencies". I also disabled farsight in the debian/rules file as well as vv, and if you don't care about Network Manager, then you can also disable that there (and remove its build depends from the control file). After all that, I have Pidgin 2.6.1 in Lenny, working fine... without video and voice, though, but meh.

Just thought I'd mention the above, in case of issues.
User avatar
Qew
 
Posts: 261
Joined: 2007-04-26 14:45

Re: pidgn 2.6.1 on lenny

Postby plugwash » 2009-09-10 18:42

here is a new recipie for 2.6.2

dget http://ftp.de.debian.org/debian/pool/main/p/pidgin/pidgin_2.6.2-1.dsc
dpkg-source -x pidgin_2.6.2-1.dsc
cd pidgin-2.6.2
sed -i s/tcl-dev/tcl8.5-dev/ debian/control
sed -i s/tk-dev/tk8.5-dev/ debian/control
sed -i 's/libgstfarsight0.10-dev (>= 0.0.9),//' debian/control
sed -i 's/(>= 0.4.53)//' debian/control
sed -i 's/(>= 1.1.1)//' debian/control
sed -i 's/--enable-vv/--disable-vv/' debian/rules
dpkg-buildpackage

edit: added a missing cd command and disabled url parsing by the forum so the commands could be read correctly
plugwash
 
Posts: 2508
Joined: 2006-09-17 01:10

Re: pidgn 2.6.x on lenny

Postby plugwash » 2009-12-04 14:08

and here is one for 2.6.4

dget http://ftp.de.debian.org/debian/pool/ma ... .6.4-1.dsc
cd pidgin-2.6.4/
sed -i s/tcl-dev/tcl8.5-dev/ debian/control
sed -i s/tk-dev/tk8.5-dev/ debian/control
sed -i 's/libgstfarsight0.10-dev (>= 0.0.9),//' debian/control
sed -i 's/(>= 0.4.53)//' debian/control
sed -i 's/(>= 1.1.1)//' debian/control
dpkg-buildpackage

if it complains about missing build-depends install them and run dpkg-buildpackage again
plugwash
 
Posts: 2508
Joined: 2006-09-17 01:10


Return to Docs, Howtos, Tips & Tricks

Who is online

Users browsing this forum: No registered users and 1 guest

fashionable