Trouble shooting ALSA

Share your own howto's etc. Not for support questions!

Trouble shooting ALSA

Postby craigevil » 2010-07-17 06:08

First go through the ALSA checklist:
1) add yourself to the 'audio' group (log out and log in again)
Code: Select all
useradd -G audio username

2) use alsamixer and unmute channels and raise levels (also try muting some channels & toggle jack sense)
3) arts or esound stopped?
4) OSS modules unloaded?
5) speakers on?
6) As root
Code: Select all
modprobe snd-pcm-oss

7) Test your sound with aplay and a wav so codec issues don't confuse the situation. does this work for root:
Code: Select all
aplay  /usr/share/sounds/alsa/Noise.wav

8) Check what soundcards are detected by your system
Code: Select all
cat /proc/asound/cards

9) List the sound module in use
Code: Select all
cat /proc/asound/modules

10) List the sound playback devices on your system
Code: Select all
aplay -l

11) One way to check what ALSA driver you have is
Code: Select all
cat /proc/asound/version

12) Do you have alsa-utils installed? One way to check is to see if you have /etc/init.d/alsa-utils If not found install it by doing
Code: Select all
apt-get update && apt-get install alsa-utils


This script will give a detailed output of the current alsa setup on your system.
Download this script alsa-info.sh save it as alsa-info.sh
To run and create the info file
Code: Select all
bash ./alsa-info.sh --no-upload <-- without this option it will upload to alsa-project.org


To view the created file
Code: Select all
 less /tmp/alsa-info.txt


Or to paste it to pastebin.ca
Code: Select all
bash ./alsa-info.sh --pastebin


You can also use the HDA Analyzer
The HDA analyzer tool provides a graphical interface to access the raw HD-audio control, based on pyGTK2 binding. The program gives you an easy-to-use GUI stuff for showing the widget information and adjusting the amp values, as well as the proc-compatible output.
This tool can parse also proc files (/proc/asound/card#/codec*) and output from alsa-info.sh script and monitor mode (check --help option).


If none of that works then you need to find the specific audio chipset to add to your /etc/modprobe.d/alsa-base.conf file.

Each combination of audio codec, audio mixer and audio device name requires a very specific configuration in the alsa-base.conf file.

The following string needs to be added to the /etc/modprobe.d/alsa-base.conf file

options snd-hda-intel model=YOUR_MODEL

You can find your codec chip name using this command

Code: Select all
cat /proc/asound/card*/codec* | grep Codec


Then look at https://wiki.ubuntu.com/Gutsy_Intel_HD_Audio_Controller
find your codecs and model and add the appropriiate line to /etc/modprobe.d/alsa-base.conf

Valid model names (that replace YOUR_MODEL) depending on the codec chip, can be found here and here.

Also check to see if there is more than one alsactl executable in your path and remove the wrong/oldest one.
Code: Select all
sudo which alsactl
or su if you do not have sudo setup. It should return something like this:
Code: Select all
# which alsactl
/usr/sbin/alsactl


Having more than one alsactl can cause your sound settings to be muted during every boot.

For release Squeeze or any later release, alsaconf is no longer available in package alsa-utils. So try to configure alsa by running the command 'alsactl init' as root. Just ignore the error message like 'Unknown hardware' (this issue said to be fixed in alsa-utils .20), then reboot and try to test your sound. For more details please see viewtopic.php?f=6&t=39116

For more info see:
http://wiki.debian.org/ALSA
SoundTroubleshooting - - https://help.ubuntu.com/community/SoundTroubleshooting
HdaIntelSoundHowto - https://help.ubuntu.com/community/HdaIntelSoundHowto
http://alsa.opensrc.org/index.php/.asoundrc
MORE NOTES ON HD-AUDIO DRIVER - http://www.kernel.org/pub/linux/kernel/ ... Audio.html
How can I change the default ALSA device http://alsa.opensrc.org/FAQ026
Alsa-sound-mini-HOWTO http://www.alsa-project.org/~valentyn/#toc5
ALSA Multi-channel Audio mini-HOWTO http://www.cse.ohio-state.edu/~bondhugu/alsamch.shtml

If none of these steps work, either take your computer back to where you bought it or get used to not having sound. Sound is overrated anyway. :)
Debian Sid KDE Kernel 3.17 Thinkpad R40 Intel M 1.3 CPU 2GB RAM Radeon Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Debian upgrade script smxi | sysinfo script inxi
User avatar
craigevil
 
Posts: 5192
Joined: 2006-09-17 03:17
Location: Oz

Re: Trouble shooting ALSA

Postby rayburn » 2010-07-19 21:23

Thanks for posting this, I don't need it now, but surely will at some time. It is great to have a thread with all those possible solutions all together in one place.
rayburn
 
Posts: 24
Joined: 2008-05-29 18:56
Location: UK

Re: Trouble shooting ALSA

Postby Lou » 2010-09-23 19:23

Good job craigevil, been boxing with an old Compaq, my neighbor wanted Squeeze, this did the trick:

Code: Select all
For release Squeeze or any later release, alsaconf is no longer available in package alsa-utils. So try to configure alsa by running the command 'alsactl init' as root. Just ignore the error message like 'Unknown hardware' (this issue said to be fixed in alsa-utils .20), then reboot and try to test your sound. For more details please see viewtopic.php?f=6&t=39116
Devuan Jessie - IceWM - vimperator - no DM
KISS - Keep It Simple, Stupid
Lou
 
Posts: 1775
Joined: 2006-05-08 02:15

Re: Trouble shooting ALSA

Postby rogon3 » 2010-11-27 13:26

Thankyou, big help for me.
rogon3
 
Posts: 35
Joined: 2010-11-02 11:46

Re: Trouble shooting ALSA

Postby lbm » 2011-01-20 14:44

Thanks man, this worked for me.
craigevil wrote:For release Squeeze or any later release, alsaconf is no longer available in package alsa-utils. So try to configure alsa by running the command 'alsactl init' as root
User avatar
lbm
 
Posts: 476
Joined: 2009-05-16 09:24
Location: Denmark

Re: Trouble shooting ALSA

Postby Llewton » 2011-01-25 17:09

craigevil wrote:options snd-hda-intel model=YOUR_MODEL


This mutes my notebook's internal speakers when I plugin external ones or headphones, but: when I put just "model" (fujitsu in my case), it didn't work. I had to google and find I should put fujitsu-pi2515. And that's not the exact model I've got, not even close.

What I'm saying is, if someone tries this workaround and it fails, they should perhaps search for alternatives to just adding "model" of their computer to that line.
User avatar
Llewton
 
Posts: 155
Joined: 2010-08-11 13:14

Re: Trouble shooting ALSA

Postby sej7278 » 2011-09-01 10:04

this link doesn't exist (anymore?): https://wiki.ubuntu.com/Gutsy_Intel_HD_Audio_Controller

also, does anyone know why there seems to be no info regarding the Realtek ALC892 chipset which must be the most common audio chipset on any motherboard made in the last year or more lol!

my Gigabyte GA-P55-USB3 (rev 2.0) has developed terrible static/whitenoise on the mic input recently, its not pulseaudio or kernel, its alsa it seems.
sej7278
 
Posts: 221
Joined: 2011-06-11 17:03

Re: Trouble shooting ALSA

Postby dtl131 » 2011-09-01 17:49

Yeah, it should really point to the git list http://git.alsa-project.org/?p=alsa-ker ... xt;hb=HEAD
dtl131
 
Posts: 449
Joined: 2011-07-11 19:56

Re: Trouble shooting ALSA

Postby rulet » 2012-03-09 20:39

How to save alsa volume configuration on reboot? It's always muted, nothing works.
Any ideas?
Debian 9, 64 bit, Gnome 3.22.2, gnome-shell, Intel Core i3-6100 CPU 3.70GHz, GT440, 8GB RAM.
rulet
 
Posts: 49
Joined: 2011-11-25 18:54

Re: Trouble shooting ALSA

Postby MountainRider » 2012-11-25 16:55

rulet wrote:How to save alsa volume configuration on reboot? It's always muted, nothing works.
Any ideas?

Have you tried "sudo alsactl save"?
MountainRider
 
Posts: 2
Joined: 2012-11-25 16:39

Re: Trouble shooting ALSA

Postby rulet » 2013-03-13 19:00

Yes, I've tried, but it was on Debian squeeze.
Debian 9, 64 bit, Gnome 3.22.2, gnome-shell, Intel Core i3-6100 CPU 3.70GHz, GT440, 8GB RAM.
rulet
 
Posts: 49
Joined: 2011-11-25 18:54

Re: Trouble shooting ALSA

Postby Lou » 2013-03-14 11:43

I think it is 'alsa store' as root and reboot.
Devuan Jessie - IceWM - vimperator - no DM
KISS - Keep It Simple, Stupid
Lou
 
Posts: 1775
Joined: 2006-05-08 02:15

Re: Trouble shooting ALSA

Postby Lou » 2013-03-15 22:29

My bad.

I man alsactl and the correct command is:

Code: Select all
alsactl store
Devuan Jessie - IceWM - vimperator - no DM
KISS - Keep It Simple, Stupid
Lou
 
Posts: 1775
Joined: 2006-05-08 02:15

Re: Trouble shooting ALSA

Postby rulet » 2013-03-16 08:09

Yes, I've did it from root. Doesn't helped.
Debian 9, 64 bit, Gnome 3.22.2, gnome-shell, Intel Core i3-6100 CPU 3.70GHz, GT440, 8GB RAM.
rulet
 
Posts: 49
Joined: 2011-11-25 18:54

Re: Trouble shooting ALSA

Postby llivv » 2013-03-16 13:31

Please start your own thread in the Desktop and Multimedia section.
rulet wrote:Yes, I've did it from root. Doesn't helped.

Post.
what commands you are using and any error messages from those commands

also post which mixer[s] you've tried

and if those mixers settings have changed after rebooting.
in the kitchen with Julia ....
[...]
Get on the D bus to B Can ....
[...]
User avatar
llivv
 
Posts: 5586
Joined: 2007-02-14 18:10
Location: willo the tree

Next

Return to Docs, Howtos, Tips & Tricks

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable