Trouble shooting ALSA

Share your own howto's etc. Not for support questions!

Re: Trouble shooting ALSA

Postby sterconero » 2013-06-05 07:42

craigevil wrote:This script will give a detailed output of the current alsa setup on your system.
Download this script save it as
To run and create the info file
Code: Select all
bash ./ --no-upload <-- without this option it will upload to is no longer there.

I get 404 - Cannot find file

Can you please reupload it?
Posts: 1
Joined: 2013-06-05 07:35

Re: Trouble shooting ALSA

Postby llivv » 2013-06-06 02:15

In memory of Ian Ashley Murdock (1973 - 2015) founder of the Debian project.
User avatar
Posts: 5484
Joined: 2007-02-14 18:10
Location: cold storage

Re: Trouble shooting ALSA

Postby stevesr0 » 2013-09-02 21:28

Have tried to get the internal microphone working on my Fujitsu T4220 convertible laptop since I purchased it three or four years ago. Running Debian Linux the past 2-3 years.

Have fussed with ALSA and read numerous webpages about configuring ALSA to do so.

(Have also heard that internal laptop microphones are problematic.)

The sound card is an Intel 9 series card.

Today, I took another look and saw this thread. Noticed the comment about configuring using the alsactl init command, and one respondent saying that it worked.

Tried it just now and for the first time, with no other adjustments, the internal microphone works.

I launched alsamixer and noted that it seemed to have fewer settings than before I issued the command. (On boot today, I realized that there is a long string of alsactl error messages about not finding files; not sure if that is part of the problem, or that my previous manipulations caused problems or that alsa can't find the files until after the system is fully booted up.)

Anyhow, thanks much craig(-notso-)evil, for the HOWTO.

I will see if the microphone works after rebooting and if not, if repeating the alsactl init command restores it to working order and if my memory allows, I will report back.
Posts: 156
Joined: 2012-05-05 03:32

Re: Trouble shooting ALSA

Postby stevesr0 » 2013-09-02 21:34


I am running Debian Wheezy (3.2-4 kernel) with ALSA 1.025.
Posts: 156
Joined: 2012-05-05 03:32

Re: Trouble shooting ALSA

Postby Juniore45 » 2013-09-03 08:49

Thanks for your tips. They are very useful for me.
Posts: 2
Joined: 2013-09-03 08:40

Re: Trouble shooting ALSA

Postby konfiguros » 2013-12-10 13:39

that worked for me too, thx
Posts: 119
Joined: 2008-11-08 19:49

Re: Trouble shooting ALSA

Postby patrick013 » 2014-04-04 21:24

Debian User Forums • View topic - alsaplayer has no stream

The terminal says all modules are loaded but no joy.

Something to do with the playlist or stream file sent and the
characters within it ?

I've had alsaplayer work in the past but not today.
Posts: 84
Joined: 2013-02-07 19:08


Return to Docs, Howtos, Tips & Tricks

Who is online

Users browsing this forum: No registered users and 8 guests