How to install ATI fglrx legacy with kernel 3.7x and 3.8x

Share your own howto's etc. Not for support questions!

Re: How to install ATI fglrx legacy with kernel 3.7x and 3.8

Postby jay_e » 2013-03-03 07:59

Hi there,

OK.
I'll probably start from scratch so I can get a cogent build log - that won't be too long
and have too many dead-ends.
It will take a while.
T H A N K S!
Jay
jay_e
 
Posts: 36
Joined: 2009-06-04 20:03
Location: Orlando, Florida

Re: How to install ATI fglrx legacy with kernel 3.7x and 3.8

Postby archer66 » 2013-03-28 21:31

Thank you for the good guide. I used your patched file on kernel 3.2 and installed without any issues. However I am not experienced user and the only way I could test was to run Doom3 :roll: . Before installing the driver the game was lacking graphics :lol: in high resolution, and now its perfect.
Could anyone tell me how to better test the driver, or what lines to look for in Xorg.0.log and xorg.conf?
archer66
 
Posts: 4
Joined: 2013-03-21 18:55

Re: How to install ATI fglrx legacy with kernel 3.7x and 3.8

Postby dencrypt » 2013-03-29 09:55

The one that seems most recommended is Phoronix (available in repos) or maybe try http://unigine.com/products/heaven/ which seems more in the variety of 3Dmark/FutureMark if you're from a Windows system.
dencrypt
 
Posts: 15
Joined: 2012-11-01 12:59

Re: How to install ATI fglrx legacy with kernel 3.7x and 3.8

Postby gsnoorky » 2013-05-31 07:23

I must be missing some packages or something. Another site indicates that Wheezy is impossible at stock--you need to deprecate a certain file. I'm thinking about putting a 5450 in for my 4670. The 4670 is a better card, though--it's not that fanless, 64-bit, short-lived BS that every HTPC hound craves--it really is no good despite what they believe. 5450 is a dumbed-down chip that AMD wants everyone to like. I'll try to find the site again. I should just give up on gnome3....
gsnoorky
 
Posts: 17
Joined: 2013-05-30 14:01

Re: How to install ATI fglrx legacy with kernel 3.7x and 3.8

Postby freddo63 » 2013-06-29 19:38

woah man where'd you guys post the patched files?! I can't seem to keep a stable connection with the server, and it'll dl for a couple of secs at 150kb and then pause and then continue! The torrent isn't active either... I would have patched them myself, but the patcher keeps asking me what file I want to patch, and as far as I can tell you haven't given clear enough instructions to that end... =/
freddo63
 
Posts: 152
Joined: 2013-06-22 18:42

Re: How to install ATI fglrx legacy with kernel 3.7x and 3.8

Postby Condenado » 2013-07-03 06:31

Could you do the same to this driver too, please? :)

http://support.amd.com/us/gpudownload/l ... ng=English

Thank you!
Condenado
 
Posts: 7
Joined: 2013-04-02 06:38

Re: How to install ATI fglrx legacy with kernel 3.7x and 3.8

Postby dencrypt » 2013-10-28 20:24

Anyone got this to work for 3.10? I get DKMS-errors when kompiling. (First I got an error that there was no headers but I solved that by symbolic link the version file which was missing in the jessie for some reason)
dencrypt
 
Posts: 15
Joined: 2012-11-01 12:59

Re: How to install ATI fglrx legacy with kernel 3.7x and 3.8

Postby cherry316316 » 2013-11-15 04:02

in your command,

~$ sudo ./ati-installer.sh 8.97.100.7 --install

what is 8.97.100.7 stands for?
i am trying to install the new 13.4 and i need to follow the same steps, but dont know what is that number for :(
thanks
cherry316316
 
Posts: 7
Joined: 2007-11-07 09:42

Re: How to install ATI fglrx legacy with kernel 3.7x and 3.8

Postby kdd » 2013-12-31 18:38

patch -p0 < ./arch-fglrx-3.7.patch
patch -p0 < ./arch-fglrx-3.8.patch
patch -p0 < ./3.5-do_mmap.patch
patch -p0 < ./makefile_compat.patch
patch -p0 < ./arch-fglrx-authatieventsd.patch

when i followed the directions to apply the patch i was hit with "which file do you want to patch" and the files listed were not the name of the patch file. what am i missing? what do i do? i'm still new to all of this.

i am trying to install for 2 cards on 2 laptops: ati radeon 9600 and ati radeon hd4200
kdd
 
Posts: 1
Joined: 2013-12-31 18:28

Re: How to install ATI fglrx legacy with kernel 3.7x and 3.8

Postby rheandros » 2014-05-11 21:27

Please Please Please reseed or give the the patched driver back to the world. I don't get it to work. Thanks.
rheandros
 
Posts: 1
Joined: 2014-05-11 21:23

Re: How to install ATI fglrx legacy with kernel 3.7x and 3.8

Postby Thaiawe » 2014-05-29 23:05

The torrent file is online but noone is seeding. Somebody please seed. I had to reinstall Debian three times in two days because of video river conflicts.
Thaiawe
 
Posts: 4
Joined: 2014-05-29 22:59

Previous

Return to Docs, Howtos, Tips & Tricks

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable