Install not detecting Mac SSD

Help with issues regarding installation of Debian

Install not detecting Mac SSD

Postby hwhea » 2017-05-19 12:54

Hello all,

I'm attempting to dual boot Debian 8.8 alongside Mac OSX Sierra on an early 2015 Macbook Air.

Whenever I get to the partitioning section of the install, only the USB with which I am installing is found - the mac SSD isn't. I'm using a full install DVD and not a netinst. Additionally, for some reason, rEFIt doesn't see the install USB but mac's boot manager does (holding alt). Not sure if these symptoms are related or not. When I boot the installer from mac's boot manager it seems to work fine up until not finding the drive.

Any ideas?
Thanks in advance.
hwhea
 
Posts: 4
Joined: 2017-05-19 12:36

Re: Install not detecting Mac SSD

Postby milomak » 2017-05-19 20:17

is it a fusion drive?
iMac - MacOS and Windows 10 (Bootcamp)/ Debian Sid (External SSD)
Laptop (64-bit) - Debian Sid, Win10,
Kodi Box - Debian Sid
milomak
 
Posts: 1678
Joined: 2009-06-09 22:20

Re: Install not detecting Mac SSD

Postby hwhea » 2017-05-20 18:54

Thanks for the reply! Still no luck here, tried all sorts.

I don't think i have fusion drive. The disk is named Macintosh SSD or something along those lines, with two partitions (Mac & Debian - both created in Disk Utility). I get through the installer but when I get to disk partitioning, the SSD simply is not listed at all.

Baffling me, doesn't seem to be a common problem either if Google searches are anything to go by.
hwhea
 
Posts: 4
Joined: 2017-05-19 12:36

Re: Install not detecting Mac SSD

Postby Head_on_a_Stick » 2017-05-20 18:57

"Are you quite sure that all those bells and whistles, all those wonderful facilities of your so called powerful programming languages, belong to the solution set rather than the problem set?" — Edsger W. Dijkstra
User avatar
Head_on_a_Stick
 
Posts: 6603
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Install not detecting Mac SSD

Postby hwhea » 2017-05-20 20:54

Just had a look, seems to be an NVMe device. I'll look into a solution for mac users and if I see results, I'll post again. Thanks for the heads up.
hwhea
 
Posts: 4
Joined: 2017-05-19 12:36

Re: Install not detecting Mac SSD

Postby hwhea » 2017-05-20 22:13

If anybody has any ideas, feel free to post them. I'm getting nowhere with this. Now on a fresh install of OS X, still no change (not that I expected any - but was worth a try).
hwhea
 
Posts: 4
Joined: 2017-05-19 12:36

Re: Install not detecting Mac SSD

Postby stevepusser » 2017-05-21 00:35

What went wrong with the jessie-backports in the installer workaround? Is the installer able to make a Net connection?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: AzPainter 2.1.0, Pale Moon 27.5.0, Liquorix kernel 4.12-10, mpv 0.27.0, Kodi 17.3, 0ad 0.0.22, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 8815
Joined: 2009-10-06 05:53


Return to Installation

Who is online

Users browsing this forum: NewHere and 6 guests

fashionable