[SOLVED] Can't boot fresh install of Stretch on ancient IBM

Help with issues regarding installation of Debian

[SOLVED] Can't boot fresh install of Stretch on ancient IBM

Postby RogerRoger » 2018-07-13 01:56

So, I have this old IBM NetVista PC with 256MB of RAM and a 320GB hard disk drive.
I am trying to install Debian with the netinstall ISO image burned to a CD.
I'm looking to set up a CLI-based machine, with moderate hopes of possibly getting a light window manager running down the road.
The net installer works flawlessly, and sets up a fresh vanilla Debian on my hard drive, but when I try to boot into it, GRUB fails to load a boot screen, and I am met with this error:

error: attempt to read or write outside 'hd0'.
Entering rescue mode
grub rescue>

I used the guided auto partitioning tool during installation; Debian is the only OS on this machine.
Can anyone help me?
Last edited by RogerRoger on 2018-07-13 23:13, edited 1 time in total.
RogerRoger
 
Posts: 15
Joined: 2017-08-19 01:13

Re: Can't boot fresh install of Stretch on ancient IBM NetVi

Postby Head_on_a_Stick » 2018-07-13 04:25

RogerRoger wrote:
Code: Select all
error: attempt to read or write outside 'hd0'.

I entered this into a search engine and this was the second link:

https://lists.debian.org/debian-user/20 ... 00253.html

Does that help?

See also viewtopic.php?f=30&t=47078
Charlie don't hack
User avatar
Head_on_a_Stick
 
Posts: 7639
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Can't boot fresh install of Stretch on ancient IBM NetVi

Postby pcalvert » 2018-07-13 04:55

I've dealt with this kind of problem before; for years I used Debian on a laptop that was made in 1998.

I believe that both (either) of these options are likely to solve your problem:

1. Switch to LILO.
2. Reinstall Debian, using a small (e.g., 300 MB) dedicated boot partition. Be sure to use a suitably-sized swap partition as well.


Phil
“Property is the fruit of labor; property is desirable; it is a positive good
in the world. That some should be rich shows that others may become
rich, and hence is just encouragement to industry and enterprise.”
— Abraham Lincoln
pcalvert
 
Posts: 1783
Joined: 2006-04-21 11:19
Location: Sol Sector

Re: Can't boot fresh install of Stretch on ancient IBM NetVi

Postby RogerRoger » 2018-07-13 12:53

I followed Phil's advice (creating a separate /boot partition and installing LILO), and the system is now up and running. I have installed htop, and confirmed that the system idles right around 20MB of RAM.
Thank you for the help! :D
RogerRoger
 
Posts: 15
Joined: 2017-08-19 01:13

Re: Can't boot fresh install of Stretch on ancient IBM NetVi

Postby arzgi » 2018-07-13 13:07

That's great!

Can you please mark the thread as solved. Edit the header of your first post of the thread, and add [SOLVED] to front of it.
arzgi
 
Posts: 175
Joined: 2008-02-21 17:03
Location: Finland


Return to Installation

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable