Problem with Buster + Nvidia

Help with issues regarding installation of Debian

Problem with Buster + Nvidia

Postby Thomas123 » 2018-11-17 10:28

Hello folks,

I did a fresh install of Buster and since the nouveau-driver causes many problems I wanted to install the non-free Nvidia-driver.

I followed the steps in the wiki.
I have: NVIDIA Corporation C68 [GeForce 7050 PV / nForce 630a]

And nvidia-detect tells me, that I need driver version 304.xxx but that it is only supported till Debian Stretch.

What can I do?
Thomas123
 
Posts: 14
Joined: 2018-10-29 09:18

Re: Problem with Buster + Nvidia

Postby milomak » 2018-11-17 13:42

# apt-cache policy nvidia-legacy-304xx-driver
Code: Select all
nvidia-legacy-304xx-driver:
  Installed: (none)
  Candidate: 304.137-5
  Version table:
     304.137-5 500
        500 http://debian.mirror.ac.za/debian sid/non-free amd64 Packages
        500 http://ftp.is.co.za/debian sid/non-free amd64 Packages
        500 http://debian.saix.net sid/non-free amd64 Packages
        500 http://ftp.uk.debian.org/debian sid/non-free amd64 Packages
     304.137-5~deb9u1 500
        500 http://debian.mirror.ac.za/debian stable/non-free amd64 Packages
        500 http://ftp.is.co.za/debian stable/non-free amd64 Packages
        500 http://debian.saix.net stable/non-free amd64 Packages
        500 http://ftp.uk.debian.org/debian stable/non-free amd64 Packages
Desktop: iMac Late-2015 27" 5K Retina (17,1 - 3.3GHz) - MacOS and Windows 10 (Bootcamp)/ Debian Sid (External SSD)
Laptop: Lenovo ideapad Y700 [nVidia Optimus] (64-bit) - Debian Sid, Win10,
Kodi Box: AMD Athlon 5150 APU w/Radeon HD 8400 - Debian Sid
milomak
 
Posts: 1855
Joined: 2009-06-09 22:20

Re: Problem with Buster + Nvidia

Postby Thomas123 » 2018-11-18 09:46

Thank you milomak,

so I changed in /etc/apt/sources.list to the sid repositories instead of the buster one's.

Then I tried the suggested steps from the wiki:

First:
Code: Select all
apt install linux-headers-$(uname -r|sed 's/[^-]*-[^-]*-//') nvidia-legacy-304xx-driver


That didn't work but suggested the installation of nvidia-settings-legacy-304xx.
So I did:

Code: Select all
apt install nvidia-settings-legacy-304xx


This ran through smoothly.

So I tried again:
Code: Select all
apt install linux-headers-$(uname -r|sed 's/[^-]*-[^-]*-//') nvidia-legacy-304xx-driver


It replied the linux-headers-amd64 were already the newest.
But the nvidia-legacy-304xx-driver depedended on: xserver-xorg-video-nvidia-legacy-304xx. ... So it tried to install the latter but that didn't work and instead it told me to install nvidia-legacy-304xx-driver. So this was a circle.

So I just tried and installed and ran nvidia-xconfig and rebooted.
Now it doesn't boot to the desktop anymore and stops with a console.

Do you have some advice?
Thomas123
 
Posts: 14
Joined: 2018-10-29 09:18

Re: Problem with Buster + Nvidia

Postby milomak » 2018-11-18 17:20

i would have gone with the stable repo myself and the below should pick up the necessary required files
Code: Select all
apt install nvidia-legacy-304xx-driver nvidia-legacy-304xx-kernel-dkms xserver-xorg-video-nvidia-legacy-304xx nvidia-legacy-304xx-alternative


i will assume you have done the necessary to disable nouveau
Desktop: iMac Late-2015 27" 5K Retina (17,1 - 3.3GHz) - MacOS and Windows 10 (Bootcamp)/ Debian Sid (External SSD)
Laptop: Lenovo ideapad Y700 [nVidia Optimus] (64-bit) - Debian Sid, Win10,
Kodi Box: AMD Athlon 5150 APU w/Radeon HD 8400 - Debian Sid
milomak
 
Posts: 1855
Joined: 2009-06-09 22:20

Re: Problem with Buster + Nvidia

Postby sunrat » 2018-11-19 01:40

Thomas123 wrote:And nvidia-detect tells me, that I need driver version 304.xxx but that it is only supported till Debian Stretch.

I see it listed in Sid. Maybe just a matter of time before it hits Buster.

What can I do?

Get a new graphics card? :wink: That one must be over 10 years old. I gave away my 7600GT years ago and replaced with a GTX560 Ti which has been replaced with a GTX970 over 2 years ago.
You'll probably find even the cheapest GTX1030 will work way better.
Testing never guarantees any package will be available at any particular time but it may arrive later. In the meantime you could try doing a full system backup and install it from another release, maybe Stretch as suggested above or Sid if you're brave. Personally I would try the Sid one as it would match the rest of the system more closely, but only after a full backup in case it hoses the system completely.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 2495
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: Problem with Buster + Nvidia

Postby Head_on_a_Stick » 2018-11-19 06:11

sunrat wrote:I would try the Sid one as it would match the rest of the system more closely

+1

This link explains how to pin sid to make it behave like backports when running testing:

https://www.debian.org/doc/manuals/debi ... le_literal
dbruce wrote:Ubuntu forums try to be like a coffee shop in Seattle. Debian forums strive for the charm and ambience of a skinhead bar in Bacau. We intend to keep it that way.
User avatar
Head_on_a_Stick
 
Posts: 8322
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Problem with Buster + Nvidia

Postby Thomas123 » 2018-11-19 06:48

Hey guys, thank you for your help so far!

milomak wrote:i would have gone with the stable repo myself


Unfortunately I need Qt-Version 5.11. ... that is the only reason for me going for buster or sid.

milomak wrote:i will assume you have done the necessary to disable nouveau


Well I installed and ran nvidia-xconfig and rebooted. That should have done the trick, shouldn't it? And since it doesn't boot into the desktop any more ...

I tried your command by chrooting into the system, but it replied xserver-xorg-video-nvidia-legacy-304xx depends on xorg-video-abi which is not installable and on xserver-xorg-core (< 2:1.19.99) but 2:1.20.3-1 is scheduled for installation:

Code: Select all
root@Rechner:/# apt install nvidia-legacy-304xx-driver nvidia-legacy-304xx-kernel-dkms xserver-xorg-video-nvidia-legacy-304xx nvidia-legacy-304xx-alternative
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
nvidia-legacy-304xx-alternative ist schon die neueste Version (304.137-5).
nvidia-legacy-304xx-alternative wurde als manuell installiert festgelegt.
nvidia-legacy-304xx-kernel-dkms ist schon die neueste Version (304.137-5).
nvidia-legacy-304xx-kernel-dkms wurde als manuell installiert festgelegt.
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 xserver-xorg-video-nvidia-legacy-304xx : Hängt ab von: xorg-video-abi-23 oder
                                                         xorg-video-abi-20 ist aber nicht installierbar oder
                                                         xorg-video-abi-19 ist aber nicht installierbar oder
                                                         xorg-video-abi-18 ist aber nicht installierbar oder
                                                         xorg-video-abi-15 ist aber nicht installierbar oder
                                                         xorg-video-abi-14 ist aber nicht installierbar oder
                                                         xorg-video-abi-13 ist aber nicht installierbar oder
                                                         xorg-video-abi-12 ist aber nicht installierbar oder
                                                         xorg-video-abi-11 ist aber nicht installierbar oder
                                                         xorg-video-abi-10 ist aber nicht installierbar oder
                                                         xorg-video-abi-8 ist aber nicht installierbar oder
                                                         xorg-video-abi-6.0 ist aber nicht installierbar
                                          Hängt ab von: xserver-xorg-core (< 2:1.19.99) aber 2:1.20.3-1 soll installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.



sunrat wrote:Get a new graphics card? :wink:


Unfortunately this is not an option at the moment because of space issues in the way the motherboard is installed.

Head_on_a_Stick wrote: This link explains how to pin sid to make it behave like backports when running testing


Thank you, but my plan was to just temporarily change the /etc/apt/sources.list to sid and change it back after the nvidia-driver is installed. That should also work, shouldn't it?
Thomas123
 
Posts: 14
Joined: 2018-10-29 09:18

Re: Problem with Buster + Nvidia

Postby sunrat » 2018-11-19 12:35

As this is a new install you have nothing to lose by installing a full Sid system. Personally I think Sid is a safer option than testing. (sunrat ducks flying rocks from testing aficionados) I recommend siduction which is Sid with an optimised kernel and a few custom utilities - https://forum.siduction.org/ (ducks more rocks from Debian purists)
You can run it live with CD or USB drive from the installation image.
Same caveats apply as testing - be careful with upgrades and cancel if it proposes lots of removals. There is an Upgrade Warnings section in their forum which is very useful. It's in German too. :wink:
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 2495
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: Problem with Buster + Nvidia

Postby Thomas123 » 2018-11-19 14:38

sunrat wrote:Personally I think Sid is a safer option than testing.


Sunrat, you know, I am not very experienced in this stuff.
Actually I only wanted Debian Stetch. It's just because of a stupid Qt-bug, that I need to go to Buster. And soon Buster will become Stable, so that's what I am aiming for.
I am very afraid, that I won't be able to handle the challenges associated with Sid.
Thomas123
 
Posts: 14
Joined: 2018-10-29 09:18

Re: Problem with Buster + Nvidia

Postby Head_on_a_Stick » 2018-11-19 19:23

Thomas123 wrote:my plan was to just temporarily change the /etc/apt/sources.list to sid and change it back after the nvidia-driver is installed. That should also work, shouldn't it?

Yes, just check very carefully exactly what the package manager wants to pull from sid before accepting the installation.
dbruce wrote:Ubuntu forums try to be like a coffee shop in Seattle. Debian forums strive for the charm and ambience of a skinhead bar in Bacau. We intend to keep it that way.
User avatar
Head_on_a_Stick
 
Posts: 8322
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Problem with Buster + Nvidia

Postby Thomas123 » 2018-11-23 06:25

Hey milomak,

do you have a further advice for me?

milomak wrote:i will assume you have done the necessary to disable nouveau


I installed and ran nvidia-xconfig and rebooted. That should have done the trick, shouldn't it? And since it doesn't boot into the desktop any more ...

I tried your command by chrooting into the system, but it replied xserver-xorg-video-nvidia-legacy-304xx depends on xorg-video-abi which is not installable and on xserver-xorg-core (< 2:1.19.99) but 2:1.20.3-1 is scheduled for installation:

Code: Select all
root@Rechner:/# apt install nvidia-legacy-304xx-driver nvidia-legacy-304xx-kernel-dkms xserver-xorg-video-nvidia-legacy-304xx nvidia-legacy-304xx-alternative
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
nvidia-legacy-304xx-alternative ist schon die neueste Version (304.137-5).
nvidia-legacy-304xx-alternative wurde als manuell installiert festgelegt.
nvidia-legacy-304xx-kernel-dkms ist schon die neueste Version (304.137-5).
nvidia-legacy-304xx-kernel-dkms wurde als manuell installiert festgelegt.
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 xserver-xorg-video-nvidia-legacy-304xx : Hängt ab von: xorg-video-abi-23 oder
                                                         xorg-video-abi-20 ist aber nicht installierbar oder
                                                         xorg-video-abi-19 ist aber nicht installierbar oder
                                                         xorg-video-abi-18 ist aber nicht installierbar oder
                                                         xorg-video-abi-15 ist aber nicht installierbar oder
                                                         xorg-video-abi-14 ist aber nicht installierbar oder
                                                         xorg-video-abi-13 ist aber nicht installierbar oder
                                                         xorg-video-abi-12 ist aber nicht installierbar oder
                                                         xorg-video-abi-11 ist aber nicht installierbar oder
                                                         xorg-video-abi-10 ist aber nicht installierbar oder
                                                         xorg-video-abi-8 ist aber nicht installierbar oder
                                                         xorg-video-abi-6.0 ist aber nicht installierbar
                                          Hängt ab von: xserver-xorg-core (< 2:1.19.99) aber 2:1.20.3-1 soll installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
Thomas123
 
Posts: 14
Joined: 2018-10-29 09:18

Re: Problem with Buster + Nvidia

Postby milomak » 2018-11-23 19:47

the only thing i can think of is to download the source for xserver-xorg-video-nvidia-legacy-304xx and rebuild it without xorg-video-abi-23 as a dependency
Desktop: iMac Late-2015 27" 5K Retina (17,1 - 3.3GHz) - MacOS and Windows 10 (Bootcamp)/ Debian Sid (External SSD)
Laptop: Lenovo ideapad Y700 [nVidia Optimus] (64-bit) - Debian Sid, Win10,
Kodi Box: AMD Athlon 5150 APU w/Radeon HD 8400 - Debian Sid
milomak
 
Posts: 1855
Joined: 2009-06-09 22:20

Re: Problem with Buster + Nvidia

Postby Thomas123 » 2018-11-25 10:12

Thank you milomak and the other guys,

I'm afraid, this whole thing is beyond my technical abilities.

I guess, I just have to wait until the Nvidia-driver gets into the Buster-repositories.
I hope this will happen very soon.

Thanks again!
Thomas123
 
Posts: 14
Joined: 2018-10-29 09:18


Return to Installation

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable