buster xfce fails

Help with issues regarding installation of Debian

buster xfce fails

Postby pepere1 » 2019-07-11 13:35

I just installed debian 10 xfce amd64 nonfree on
a rather old PC (acer travelmate 5720).
At the first reboot, I found impossible to have
the proper bar giving easy access to the different
workspaces. The recommended procedure in debian 9
which is "Parameters -> Workspaces" can be called
BUT has *no effect*.
I tried 4 times the installation.
Then, to estimate a possible personal error or a material
problem, I installed in the same partition debian 10
kde amd64 nonfree. It works perfectly but is, im my opinion,
less easy to handle.
For the moment, I do not install debian 10 on my two other
computers which are under debian 9.9 and are used
intensively.
I am, of course, not sure that it is a bug, so
I send this message in *this* forum with the two
questions:
- question 1: am I the only one with this problem?
- question 2: is there anybody understanding the origin
of the problem?
Thank you from France (with probable broken English, sorry).
pepere1
 
Posts: 5
Joined: 2019-07-11 13:31


Re: buster xfce fails

Postby ruwolf » 2019-07-11 20:13

How is your problem manifested exactly?
Do you not see any panel of XFCE? Panels are bars (usually on bottom or/and top of screen) where are usually buttons for main menu, time, work-space switcher, mini-bars of running programs, etc...
https://docs.xfce.org/xfce/xfce4-panel/
User avatar
ruwolf
 
Posts: 392
Joined: 2008-02-18 05:04
Location: Slovakia, Banovce nad Bebravou, Matice slovenskej 1260/4-7

Re: buster xfce fails

Postby pepere1 » 2019-07-12 06:46

nswer to arochester : of course i know the French debian
sites. By the way, I sent roughly the same message 3 days ago...
and had no answer!
pepere1
 
Posts: 5
Joined: 2019-07-11 13:31

Re: buster xfce fails

Postby pepere1 » 2019-07-12 06:52

Answer to ruwolf
The problem is not visible the first time I install
but when rebooting.
When rebooting, I do not see any panel.
I would be very interested in seeing messages of people
having this problem (or having no problem).
pepere1
 
Posts: 5
Joined: 2019-07-11 13:31

Re: buster xfce fails

Postby Dai_trying » 2019-07-12 21:45

I have done a few installs of the new stable (Buster) but I used the netinstall image and have had no problems, one thing to note though is that the first boot after installation does take some time and then you should be asked if you want to create default panels, if you answer no you will not get them (I haven't tried this myself so do not know exactly what you would be given), it could just be you need to allow more time for the first boot to finish what needs doing, especially if it is an old system.
Of course it could also be something else,
Dai_trying
 
Posts: 754
Joined: 2016-01-07 12:25

Re: buster xfce fails

Postby GarryRicketson » 2019-07-12 22:10

I have NOT had anything like this happen on mine either. Even after several reboots.
Image
But I prefer the tint2 panel I use on top,...guess that is another topic.
Code: Select all
$ lsb_release -a
No LSB modules are available.
Distributor ID:   Debian
Description:   Debian GNU/Linux 10 (buster)
Release:   10
Codename:   buster
$
 
User avatar
GarryRicketson
 
Posts: 5877
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: buster xfce fails

Postby arzgi » 2019-07-13 11:35

Same experience here as Garry had, not any problems so far with xfce since upgrading to buster.
arzgi
 
Posts: 461
Joined: 2008-02-21 17:03
Location: Finland

Re: buster xfce fails

Postby pepere1 » 2019-07-13 11:59

Thanks to Dai_trying and GarryRicketson for their
contribution.

Following their ideas, I tried a 5th intallation
of debian 10 xfce.

But, when reading my first post, I see that I was not
precise enough, so I'll say everything right now.

During the *first* reboot following the installation
of debian 10 xfce amd64 nonfree, I was asked to choose
between
- default parameters (perhaps "default panel" in the
English version)
- a void panel (in French: "un tableau de bord vide"
so perhaps the question in English is "a void workspace")

I choosed default parameters, in order to have the panel
with easy access to the different workspaces, that is
the different windows.
Worked perfectly. I had in particular 4 workspaces, and
I changed to 8 since I need 8 workspaces for different
reasons. Worked perfectly too.

Then I rebooted at 10:15 and waited till 10:45. This
computer is a bit old (2008) but not so slow.

And I got a *void panel*.
I ran "parameters -> workspaces configuration"
but nothing was visible : void panel.

Of course, it is possible to *use* this configuration
of debian 10: I can have the 8 workspaces by
middle clicking the mouse and choosing the workspace.
In my opinion, it is less easy than the other way.

In *my* opinion, if this is not a bug, it is very
well imitated ;-)

Best regards.
pepere1
 
Posts: 5
Joined: 2019-07-11 13:31

Re: buster xfce fails

Postby pepere1 » 2019-07-18 15:24

After working 11 days, and 8 installations of debian,
I found a workaround at the address
http://mynixworld.info/2015/04/22/no-ru ... een-found/
The probleme is not a bug from debian but from
xfce4.
It may be interesting to read the site, but I used
a quicker method, in my opinion.
Boot on a "LIVE" dvd like knoppix 8.2 or debian live.
Mount the partition where lives your debian:
su
fdisk -l
mount /dev/sda2 /media/sda2 (for example)
then go to
/media/sda2/home/your_id/.cache/sessions
and then remove any file in it.
Reboot under your debian: you have the good panel!

Best regards
pepere1
 
Posts: 5
Joined: 2019-07-11 13:31


Return to Installation

Who is online

Users browsing this forum: No registered users and 12 guests

fashionable