Debian Buster desktop no loading after installation

Help with issues regarding installation of Debian

Debian Buster desktop no loading after installation

Postby brolly » 2019-07-12 09:15

Hello good people. I wonder if you can help. I have attempted installing buster using the standard installer with a firmware usb. I have also tried the non-free XFCE live ISO. The issue i face is the installation process both for the standard ISO and Non free ISO complete successfully. When i boot the system after using the standard ISO the desktop doesn't load. I am greeted with a black screen with a cursor flashing on the top left of the screen. The live ISO installation boots into a black screen with white panels but no items on the panels. I have tried using a number of boot parameters including going into advanced options, adding non-free repositories and installing AMD drivers from there. I have resorted to using Antix 19 beta which seems to be very stable. I am keen to migrate to Debian but the installation issue is what is holding me back. My system model and specs are as follows:

HP 15-bw036na 15.6" Multimedia Laptop AMD A12, 12GB RAM,
2TB HDD. AMD A12-9720P / 2.7 GHz Max Turbo Speed 3.6 GHz Quad Core Processor
12GB RAM, 2TB HDD
15.6 HD Display (1366 x 768) Resolution
Integrated AMD Radeon R7 Graphics

Thank you in advance
User avatar
brolly
 
Posts: 7
Joined: 2019-07-12 09:00

Re: Debian Buster desktop no loading after installation

Postby arochester » 2019-07-12 09:32

This has been asked and answered many times on this forum. You could have started with the search box at the top left. Something like: black screen AMD Radeon

It's a graphics problem. Look here: https://mike42.me/blog/2018-01-how-to-u ... n-debian-9
arochester
 
Posts: 1496
Joined: 2010-12-07 19:55

Re: Debian Buster desktop no loading after installation

Postby brolly » 2019-07-12 09:54

arochester wrote:This has been asked and answered many times on this forum. You could have started with the search box at the top left. Something like: black screen AMD Radeon

It's a graphics problem. Look here: https://mike42.me/blog/2018-01-how-to-u ... n-debian-9


Ive tried that method in the advanced options section in the bootloader and it didn't work. That's why i posted on this forum
User avatar
brolly
 
Posts: 7
Joined: 2019-07-12 09:00

Re: Debian Buster desktop no loading after installation

Postby nyu-98 » 2019-07-12 13:30

I have a similar problem with the mate desktop, i tried those parameters and none works.
So i installed the kernel 4.9 from stretch and works. the problem is the kernel 4.19.
nyu-98
 
Posts: 4
Joined: 2019-03-26 00:35

Re: Debian Buster desktop no loading after installation

Postby brolly » 2019-07-12 14:45

nyu-98 wrote:I have a similar problem with the mate desktop, i tried those parameters and none works.
So i installed the kernel 4.9 from stretch and works. the problem is the kernel 4.19.


Good point but what's interesting is Antix uses the same kernel and it works flawlessly. MX gave me headaches with a frozen desktop on bootup using kernel 4.19. I hope this bug is squashed soon
User avatar
brolly
 
Posts: 7
Joined: 2019-07-12 09:00

Re: Debian Buster desktop no loading after installation

Postby Head_on_a_Stick » 2019-07-13 08:15

brolly wrote:I have tried using a number of boot parameters including going into advanced options, adding non-free repositories and installing AMD drivers from there.

The non-free component of the repositories doesn't contain any AMD drivers, please post exactly what you have installed and also list the exact boot parameters you have tried (along with the output of cat /proc/cmdline to confirm they were applied).
User avatar
Head_on_a_Stick
 
Posts: 10056
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to Installation

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable