steam - Debian Testing Repository

Help with issues regarding installation of Debian

steam - Debian Testing Repository

Postby Link99 » 2013-06-10 18:17

I've been able to install this Steam package from the official Debian testing repo:

http://packages.qa.debian.org/s/steam.html

But when I try to run the program, the following error message appears:

Couldn't start bootstrap and couldn't reinstall from /usr/lib/steam/bootstraplinux_ubuntu12_32.tar.xz.
Please contact technical support.


Terminal output:

Code: Select all
steam
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
[2013-06-10 19:53:18] Startup - updater built Apr 30 2013 10:04:24
[2013-06-10 19:53:18] Verifying installation...
[2013-06-10 19:53:18] Unable to read and verify install manifest /home/link/.steam/package/steam_client_ubuntu12.installed
[2013-06-10 19:53:18] Verification complete
[2013-06-10 19:53:18] Downloading Update...
[2013-06-10 19:53:18] Checking for available update...
[2013-06-10 19:53:19] Package file strings_all.zip.4086154aa9aa5b04afb8f7965d620c3dd6700633 missing or incorrect size
[2013-06-10 19:53:19] Package file resources_all.zip.8fc7dfde9b7d6880b3f806c388d1f4bb7bd91bb8 missing or incorrect size
[2013-06-10 19:53:19] Package file tenfoot_all.zip.d49d502bbcba3e5d16a31e786ec5e6220ac732da missing or incorrect size
[2013-06-10 19:53:19] Package file tenfoot_fonts_all.zip.06551e23c14845665e7671feb9453b3ca1052939 missing or incorrect size
[2013-06-10 19:53:19] Package file tenfoot_ambientsounds_all.zip.ac31503c42f094976f64844d8ff54705cadc7dd3 missing or incorrect size
[2013-06-10 19:53:19] Package file tenfoot_sounds_all.zip.2c2fba7870954a966c5f9dbc4febd3ebbb869910 missing or incorrect size
[2013-06-10 19:53:19] Package file tenfoot_images_all.zip.a9b4105879d2118b1781eba85dc002e9ea8d5953 missing or incorrect size
[2013-06-10 19:53:19] Package file public_all.zip.6f45d8c6fc559117a18218455112edf530704888 missing or incorrect size
[2013-06-10 19:53:19] Package file bins_ubuntu12.zip.ece237aa8d1d5721d6559abcd5ea71e6301c34e2 missing or incorrect size
[2013-06-10 19:53:19] Package file webkit_ubuntu12.zip.381e75bfc3340cf5eae9d265abb6de501f393f18 missing or incorrect size
[2013-06-10 19:53:19] Package file miles_ubuntu12.zip.9c547c676be26625a4cd64c2595821d10b8fc9ff missing or incorrect size
[2013-06-10 19:53:19] Package file sdl2_ubuntu12.zip.97d046f016544022c0d17314ab6a66a2bd8d526d missing or incorrect size
[2013-06-10 19:53:19] Package file steam_ubuntu12.zip.93d3e796c76dfd9d73fb9727438ff8fee274501f missing or incorrect size
[2013-06-10 19:53:19] Package file runtime_part0_ubuntu12.zip.79164bad727d6617de80b43c0a9e712400aabeb2 missing or incorrect size
[2013-06-10 19:53:19] Package file runtime_part1_ubuntu12.zip.73730ac3d55181d3a9e0a8d8ae6c5493103c08dd missing or incorrect size
[2013-06-10 19:53:19] Downloading update (0 of 153,067 KB)...
[2013-06-10 19:53:20] Downloading update (133 of 153,067 KB)...
[2013-06-10 19:53:20] Downloading update (307 of 153,067 KB)...
.
.
.
[2013-06-10 19:42:34] Downloading update (152,936 of 153,067 KB)...
[2013-06-10 19:42:35] Downloading update (153,008 of 153,067 KB)...
[2013-06-10 19:42:35] Downloading update (153,067 of 153,067 KB)...
[2013-06-10 19:42:36] Download Complete.
[2013-06-10 19:42:36] uninstalled manifest found in /home/link/.steam/package/steam_client_ubuntu12 (1).
[2013-06-10 19:42:36] Extracting package...
[2013-06-10 19:42:46] Installing update...
[2013-06-10 19:42:48] Cleaning up...
[2013-06-10 19:42:48] Update complete, launching...
[2013-06-10 19:42:48] Shutdown
rm: cannot remove `/home/link/.steam/steam': Is a directory
rm: cannot remove `/home/link/.steam/bin': Is a directory
Running Steam on debian 7.0 32-bit
STEAM_RUNTIME is enabled automatically
/home/link/.steam/ubuntu12_32/steamui.so: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.15' not found (required by /home/link/.steam/ubuntu12_32/libcef.so)
/home/link/.steam/ubuntu12_32/steamui.so: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.15' not found (required by /home/link/.steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libX11.so.6)
/home/link/.steam/ubuntu12_32/steamui.so: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.15' not found (required by /home/link/.steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libglib-2.0.so.0)
/home/link/.steam/ubuntu12_32/steamui.so: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.15' not found (required by /home/link/.steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libnspr4.so)
/home/link/.steam/ubuntu12_32/steamui.so: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.15' not found (required by /home/link/.steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcrypt.so.11)
/home/link/.steam/ubuntu12_32/steam: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.15' not found (required by /home/link/.steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libX11.so.6)
Error: Couldn't start bootstrap and couldn't reinstall from /usr/lib/steam/bootstraplinux_ubuntu12_32.tar.xz.  Please contact technical support.
Link99
 
Posts: 1
Joined: 2013-06-10 18:09

Re: steam - Debian Testing Repository

Postby sunrat » 2013-06-11 01:03

You glibc is too old in Wheezy (2.13). There are workarounds such as this - http://www.yannbane.com/2013/02/how-to-steam-on-linux-debian-70.html or you can do it on testing or sid which have glibc 2.17.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 3125
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: steam - Debian Testing Repository

Postby dilberts_left_nut » 2013-06-11 01:34

Packages in the 'testing' repo are NOT meant for installation on stable.
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 5060
Joined: 2009-10-05 07:54
Location: enzed

Re: steam - Debian Testing Repository

Postby sunrat » 2013-06-11 03:28

If you run jessie or sid, Steam packages are now in non-free repos so hopefully a simple apt install from the repos would get you up an running. The package for testing will not work in stable with glibc-2.13.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 3125
Joined: 2006-08-29 09:12
Location: Melbourne, Australia


Return to Installation

Who is online

Users browsing this forum: No registered users and 13 guests

fashionable