Missing firmware b43/ucode5.fw b43-open/ucode5.fw

Help with issues regarding installation of Debian

Missing firmware b43/ucode5.fw b43-open/ucode5.fw

Postby Scarecrow2000 » 2015-05-22 02:46

I am installing debian 8 using,
debian-live-8.0.0-i386-xfce-desktop+nonfree.iso on a usb flash drive.
Installer reports,

Some of your hardware requires non free firmware to operate.
The firmware can be loaded from removable media such as a USB stick or floppy.
The missing firmware files are;
b43/ucode5.fw
b43/ucode5.fw
b43-open/ucode5.fw
b43-open/ucode5.fw
If you have such media available now insert it now and continue.


I dont know why it says the same .fw twice but that is exaclty as it appears on the screen.
As I created the bootable usb stick using the .iso which is supposed to contain the non-free firmware I hit continue, assuming it would find it on the usb stick but it just goes back to the same screen with the above message without giving me any option to browse to it.
I believe this is firmware related to the wireless lan adapter on that laptop.
I had previously tried to do as the installation guide suggested and put the non-free firmware onto the same bootable usb stick but every time I tried to create a second partition in the free space it errored so after wasting some hours tinkering with that I took advice on the forum and downloaded the unoffical .iso with fw included ....
This does not make any logical sense to me. The installer knows what is required, someone coded it to ask for those .fw files yet no one puts them in the .iso and on top of that the installer does not even let you browse to them even if you do have them. I mean really....
Scarecrow2000
 
Posts: 36
Joined: 2015-04-16 02:55

Re: Missing firmware b43/ucode5.fw b43-open/ucode5.fw

Postby v&n » 2015-05-22 04:50

I am not familiar with the unofficial ISOs, so don't know whether it comes with broadcom firmware files or not. But if not, it could be due to Broadcom's very restrictive licencing policy, that does not allow redistribution of their firmware, although individuals can download it for their personal use.

While the firmware or the packages required to extract/install the firmware could be available on the ISO, since I have absolutely no idea what it has and what it doesn't, I would skip to two straight answers -

1) If you can get a temporary internet connection on the target laptop somehow (Ethernet, USB modem etc.), please follow these instructions to install it - https://wiki.debian.org/bcm43xx#b43-b43legacy

2) If you have no way to connect to internet, and are clueless about the presence of broadcom related packages on the ISO, you may follow this (non-standard-method) post to download and manually copy the firmware files to correct location - http://ubuntuforums.org/showpost.php?p=13119224 (I could have provided the firmware archive right here, but not sure whether this forum would approve it, licencing & legal issues...).

Since you haven't told anything about your card, I am assuming it is BCM4318 that you mentioned in this post today - viewtopic.php?p=578686#p578686
I tested the one with the 4318 adapter with Debian 8 i386 xfce live+non-free.iso The wifi did not work on it running as live and ifconfig did not show a wireless adapter.

..If not, please show us the output of -
Code: Select all
lspci -nnk | grep -iA2 net
v&n
 
Posts: 624
Joined: 2015-02-04 02:57



Return to Installation

Who is online

Users browsing this forum: No registered users and 24 guests

fashionable