USB Not Bootable

Help with issues regarding installation of Debian

USB Not Bootable

Postby broadsworde » 2017-03-01 14:01

I have downloaded and written latest ISO image of Debian as instructed on this FAQ page... I've tried both cp and dd methods, I've also tried the Ubuntu (current OS in use) Disks, Restore Disk Image process... in all cases the ISO is copied to the USB, but when booting and selecting F10 to show bootable devices, the USB is not shown on the list. I know my EFI BIOS is configured correctly as I am able to see a Ubuntu ISO on the boot list on a different USB drive.
I have also tried writing the debian image to the USB drive that I know works for Ubuntu just to rule out any issues or differences between the USB drives, and it still doesn't show on boot menu.
Any assistance or ideas would be greatly appreciated.
Thank you.
Posts: 1
Joined: 2017-03-01 13:50

Re: USB Not Bootable

Postby Segfault » 2017-03-01 17:16

Plug you drive in and run
Code: Select all
file -s /dev/sdX
Posts: 406
Joined: 2005-09-24 12:24

Re: USB Not Bootable

Postby GarryRicketson » 2017-03-01 17:36

The OP might not understand , where it says,
'sdx", could be 'sdb', I tried this using sdx, and got not found.
Using 'sdb' worked.

Code: Select all
 $ file -s /dev/sdx
/dev/sdx: ERROR: cannot open `/dev/sdx' (No such file or directory)
garry@debian:~$ file -s /dev/sdb
/dev/sdb: sticky DOS floppy 1440k, x86 hard disk boot sector

Using 'lsblk' can help determine if it should be sdx,sdc,sdb , etc.
Interesting command, though, thanks.
User avatar
Posts: 3658
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: USB Not Bootable

Postby Segfault » 2017-03-01 19:56

You are welcome! :)

I have a strange habit reading man pages when I have nothing better to do, there is lots of power in those little utils that live in /bin/ (and /sbin/).
Posts: 406
Joined: 2005-09-24 12:24

Re: USB Not Bootable

Postby EnigmaOne » 2017-03-20 20:48

The problem that I have had with a lot of motherboards is the lack of firmware support for USB3.0 ports at POST; which means that you generally cannot boot from USB ports other than the USB2.0 ports. This may be the case in the OP's scenario.
Posts: 2
Joined: 2017-03-20 03:27

Return to Installation

Who is online

Users browsing this forum: NHOJ and 6 guests