AMD Radeon R9 280x error

Help with issues regarding installation of Debian

AMD Radeon R9 280x error

Postby oldboy » 2017-03-08 18:23

So, I installed stretch, and got this error message after booting.
Code: Select all
[drm:si_dpm_set_power_state [radeon]] *ERROR* si_restrict_performance_levels_before_switch failed


It does not affect the use of the system, but it cannot wake from screensaver. Here are more details from dmesg:

Code: Select all
4.329920] [drm] Radeon Display Connectors
[    4.329920] [drm] Connector 0:
[    4.329921] [drm]   DP-1
[    4.329921] [drm]   HPD5
[    4.329922] [drm]   DDC: 0x6530 0x6530 0x6534 0x6534 0x6538 0x6538 0x653c 0x653c
[    4.329922] [drm]   Encoders:
[    4.329923] [drm]     DFP1: INTERNAL_UNIPHY2
[    4.329923] [drm] Connector 1:
[    4.329924] [drm]   DP-2
[    4.329924] [drm]   HPD4
[    4.329925] [drm]   DDC: 0x6540 0x6540 0x6544 0x6544 0x6548 0x6548 0x654c 0x654c
[    4.329925] [drm]   Encoders:
[    4.329926] [drm]     DFP2: INTERNAL_UNIPHY2
[    4.329926] [drm] Connector 2:
[    4.329926] [drm]   HDMI-A-1
[    4.329927] [drm]   HPD1
[    4.329927] [drm]   DDC: 0x6550 0x6550 0x6554 0x6554 0x6558 0x6558 0x655c 0x655c
[    4.329928] [drm]   Encoders:
[    4.329928] [drm]     DFP3: INTERNAL_UNIPHY1
[    4.329928] [drm] Connector 3:
[    4.329929] [drm]   DVI-I-1
[    4.329929] [drm]   HPD3
[    4.329930] [drm]   DDC: 0x6580 0x6580 0x6584 0x6584 0x6588 0x6588 0x658c 0x658c
[    4.329930] [drm]   Encoders:
[    4.329931] [drm]     DFP4: INTERNAL_UNIPHY
[    4.329931] [drm]     CRT1: INTERNAL_KLDSCP_DAC1
[    4.432629] [drm] fb mappable at 0xC05D8000
[    4.432629] [drm] vram apper at 0xC0000000
[    4.432630] [drm] size 33177600
[    4.432630] [drm] fb depth is 24
[    4.432630] [drm]    pitch is 15360
[    4.432713] fbcon: radeondrmfb (fb0) is primary device
[    4.604820] [drm:si_dpm_set_power_state [radeon]] *ERROR* si_restrict_performance_levels_before_switch failed
[    4.674022] Console: switching to colour frame buffer device 480x135
[    4.688964] radeon 0000:01:00.0: fb0: radeondrmfb frame buffer device
[    4.701430] [drm] Initialized radeon 2.48.0 20080528 for 0000:01:00.0 on minor 0
[    4.710984] PM: Starting manual resume from disk
[    4.710986] PM: Hibernation image partition 8:23 present
[    4.710987] PM: Looking for hibernation image.
[    4.711150] PM: Image not found (code -22)
[    4.711151] PM: Hibernation image not present or could not be loaded.
[    4.790904] EXT4-fs (sda2): mounted filesystem with ordered data mode. Opts: (null)


Also this I/O address error:
Code: Select all
sp5100_tco: SP5100/SB800 TCO WatchDog Timer Driver v0.05
[    5.079398] sp5100_tco: PCI Vendor ID: 0x1002, Device ID: 0x4385, Revision ID: 0x42
[    5.079401] sp5100_tco: I/O address 0x0cd6 already in use


These packages are installed
firmware-amd-graphics, firware-linux-free and nonfree

I read the debian wiki, and it did not recommend installing AMD proprietary driver. Any advice welcome. TIA.
This oldboy has a lot of time in his hands
Linux slows down my Alzheimer and dementia
oldboy
 
Posts: 684
Joined: 2007-08-09 12:45

Re: AMD Radeon R9 280x error

Postby bw123 » 2017-03-10 00:11

There are several threads about R9 but they may be hard to find. Also plenty of threads about fail to resume from standby or suspend, could be related to screensaver?

Maybe you should post some more info, people might recognize a common issue? There are some systemd settings for standby/resume also, but that's beyond me at the moment.

Code: Select all
$ lspci -vk | grep  -e radeon -e VGA
$ fgrep EE /var/log/X*
jessie/KDE4.14.2 plasma netbook, 3.16.39-1+deb8u2 (2017-03-07) x86_64 GNU/Linux
User avatar
bw123
 
Posts: 2378
Joined: 2011-05-09 06:02
Location: TN_USA

Re: AMD Radeon R9 280x error

Postby oldboy » 2017-03-10 01:26

Thanks. Here are the details:
(I subsituted R9 280x with R9 7950. They are virtually the same card)
Code: Select all
/home/shum# lspci -vk | grep  -e radeon -e VGA
   Flags: bus master, VGA palette snoop, 66MHz, medium devsel, latency 64, NUMA node 0
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti PRO [Radeon HD 7950/8950 OEM / R9 280] (prog-if 00 [VGA controller])
   Kernel driver in use: radeon
   Kernel modules: radeon

Code: Select all
fgrep EE /var/log/X*
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     3.911] (EE) open /dev/dri/card0: No such file or directory
[     3.911] (EE) open /dev/dri/card0: No such file or directory
[     3.912] (EE) open /dev/fb0: No such file or directory
[     3.912] (EE) open /dev/fb0: No such file or directory
[     3.912] (EE) Screen 0 deleted because of no matching config section.
[     3.912] (EE) Screen 0 deleted because of no matching config section.
[     3.912] (EE) Screen 0 deleted because of no matching config section.
[     4.167] (EE) AIGLX: reverting to software rendering
[  2696.544] (EE) Server terminated successfully (0). Closing log file.
This oldboy has a lot of time in his hands
Linux slows down my Alzheimer and dementia
oldboy
 
Posts: 684
Joined: 2007-08-09 12:45


Return to Installation

Who is online

Users browsing this forum: No registered users and 2 guests

fashionable