No more Debian's Jessie/stable's Firefox? :(

Help with issues regarding installation of Debian

No more Debian's Jessie/stable's Firefox? :(

Postby ant » 2017-03-09 09:47

I just ran apt-get update and saw: "W: Failed to fetch http://mozilla.debian.net/dists/jessie- ... ts/Release Unable to find expected entry 'firefox-release/binary-amd64/Packages' in Release file (Wrong sources.list entry or malformed file)"

According to http://mozilla.debian.net/, it says "Sorry, this version is not available." What happened? I am using "deb http://mozilla.debian.net/ jessie-backports firefox-release" line in my 64-bit Debian stable/Jessie's /etc/apt/sources.list file.

Same for beta and aurora which I care not for though.

Thank you in advance. :)
Last edited by ant on 2017-03-09 18:04, edited 1 time in total.
ant
 
Posts: 282
Joined: 2011-11-09 00:15

Re: No more Debian's Jessie/stable's Firefox? :(

Postby arochester » 2017-03-09 09:55

Iceweasel has now become Firefox. You shouldn't need to backport.

https://wiki.debian.org/Iceweasel
arochester
 
Posts: 827
Joined: 2010-12-07 19:55

Re: No more Debian's Jessie/stable's Firefox? :(

Postby ant » 2017-03-09 10:01

arochester wrote:Iceweasel has now become Firefox. You shouldn't need to backport.

https://wiki.debian.org/Iceweasel
But I am using Firefox:

$ apt-cache show firefox
Package: firefox
Version: 51.0.1-3~bpo80+1
Architecture: amd64
Maintainer: Maintainers of Mozilla-related packages <pkg-mozilla-maintainers@lists.alioth.debian.org>
Installed-Size: 105075
Depends: libasound2 (>= 1.0.16), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.17), libcairo-gobject2 (>= 1.10.0), libcairo2 (>= 1.10.0), libdbus-1-3 (>= 1.0.2), libdbus-glib-1-2 (>= 0.78), libevent-2.0-5 (>= 2.0.10-stable), libffi6 (>= 3.0.4), libfontconfig1 (>= 2.11), libfreetype6 (>= 2.2.1), libgcc1 (>= 1:4.1.1), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.31.8), libgtk-3-0 (>= 3.0.0), libgtk2.0-0 (>= 2.10), libhunspell-1.3-0 (>= 1.3.3), libpango-1.0-0 (>= 1.14.0), libstartup-notification0 (>= 0.8), libstdc++6 (>= 4.9), libx11-6, libx11-xcb1, libxcb-shm0, libxcb1, libxcomposite1 (>= 1:0.3-1), libxdamage1 (>= 1:1.1), libxext6, libxfixes3, libxrender1, libxt6, zlib1g (>= 1:1.2.0), fontconfig, procps, debianutils (>= 1.16), libsqlite3-0 (>= 3.7.12-1~)
Suggests: fonts-stix | otf-stix, fonts-lmodern, mozplugger, libgssapi-krb5-2 | libkrb53, libcanberra0
Conflicts: j2re1.4, pango-graphite (<< 0.9.3)
Breaks: xul-ext-torbutton
Provides: gnome-www-browser, www-browser
Priority: optional
Section: web
Filename: pool/firefox-release/f/firefox/firefox_51.0.1-3~bpo80+1_amd64.deb
Size: 46416606
SHA256: 6cca7702ed773a5677683f036deee0829172bb389744d88f2df937912dee2881
SHA1: 5059d40e36c833a80639c9c24e8e7ef95735cdf8
MD5sum: 81833a350520146b143a595cce9b9199
Description: Mozilla Firefox web browser
Firefox is a powerful, extensible web browser with support for modern
web application technologies.
Description-md5: db906cb3e7e2e51d91545c75d7ce940a
Last edited by ant on 2017-03-09 18:04, edited 1 time in total.
ant
 
Posts: 282
Joined: 2011-11-09 00:15

Re: No more Debian's Jessie/stable's Firefox? :(

Postby Ardouos » 2017-03-09 11:26

https://mozilla.debian.net/
Sorry, this version is not available.

Doesnt look like they are supporting the "current" versions of Firefox on stable anymore. I am not sure about the future when Stretch is released though...

It seems you have three options:
*Install Firefox-ESR from Debian's repo - currently 45
*Install the latest Firefox-ESR from mozilla.debian.net - currently 52
*Backport testing's/ unstable's version of Firefox from mozilla.debian.net, Stevepusser has released some good guides on backports. 8)
*Install Firefox from Mozilla's website.

Edit: Typo
Last edited by Ardouos on 2017-03-09 22:04, edited 1 time in total.
User avatar
Ardouos
 
Posts: 851
Joined: 2013-11-03 00:30
Location: Elicoor II

Re: No more Debian's Jessie/stable's Firefox? :(

Postby No_windows » 2017-03-09 17:48

Ardouos wrote:*Install the latest Firefox-ESR from mozilla.debian.net - currently 52


Isn't esr52 new? I don't recall two esr versions before this point.
No_windows
 
Posts: 350
Joined: 2015-08-05 03:03

Re: No more Debian's Jessie/stable's Firefox? :(

Postby ant » 2017-03-09 17:53

Ardouos wrote:https://mozilla.debian.net/
Sorry, this version is not available.

Doesnt look like they are supporting the "current" versions of Firefox on stable anymore. I am not sure about the future when Stretch is released though...

It seems you have three options:
*Install Firefox-ESR from Debian's repo - currently 45
*Install the latest Firefox-ESR from mozilla.debian.net - currently 52
*Backport testing's/ unstable's version of Firefox from mozzila.debian.net, Stevepusser has released some good guides on backports. 8)
*Install Firefox from Mozilla's website.
I wonder why no more frequent updates. :(

Anyways, I replaced the outdated "deb http://mozilla.debian.net/ jessie-backports firefox-release" line with "deb http://mozilla.debian.net/ jessie-backports firefox-esr", uninstalled firefox package, and then installed firefox-esr package. Firefox seems to be updated and working so far.
ant
 
Posts: 282
Joined: 2011-11-09 00:15

Re: No more Debian's Jessie/stable's Firefox? :(

Postby stevepusser » 2017-03-09 21:09

You installed the older firefox-esr 45.7 from Jessie, I believe. Currently, the mozilla.debian.net jessie repository looks empty.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Inkscape 0.92.1, Pale Moon 27.2.0, Liquorix kernel 4.9-18, mpv 0.24, Kodi 17.0, Shotwell 24.5, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 7950
Joined: 2009-10-06 05:53

Re: No more Debian's Jessie/stable's Firefox? :(

Postby ant » 2017-03-09 21:23

stevepusser wrote:You installed the older firefox-esr 45.7 from Jessie, I believe. Currently, the mozilla.debian.net jessie repository looks empty.
I checked my Firefox and it was at v52. Also:

$ firefox --v
Mozilla Firefox 52.0

$ apt-cache show firefox-esr
Package: firefox-esr
Version: 52.0esr-1~bpo80+1
Architecture: amd64
Maintainer: Maintainers of Mozilla-related packages <pkg-mozilla-maintainers@lists.alioth.debian.org>
Installed-Size: 105424
Depends: libatk1.0-0 (>= 1.12.4), libc6 (>= 2.17), libcairo-gobject2 (>= 1.10.0), libcairo2 (>= 1.10.0), libdbus-1-3 (>= 1.0.2), libdbus-glib-1-2 (>= 0.78), libevent-2.0-5 (>= 2.0.10-stable), libffi6 (>= 3.0.4), libfontconfig1 (>= 2.11), libfreetype6 (>= 2.2.1), libgcc1 (>= 1:4.1.1), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.31.8), libgtk-3-0 (>= 3.0.0), libgtk2.0-0 (>= 2.10), libhunspell-1.3-0 (>= 1.3.3), libjsoncpp0, libpango-1.0-0 (>= 1.14.0), libstartup-notification0 (>= 0.8), libstdc++6 (>= 4.9), libx11-6, libx11-xcb1, libxcb-shm0, libxcb1, libxcomposite1 (>= 1:0.3-1), libxdamage1 (>= 1:1.1), libxext6, libxfixes3, libxrender1, libxt6, zlib1g (>= 1:1.2.3.4), fontconfig, procps, debianutils (>= 1.16), libsqlite3-0 (>= 3.7.12-1~)
Suggests: fonts-stix | otf-stix, fonts-lmodern, mozplugger, libgssapi-krb5-2 | libkrb53, libcanberra0
Conflicts: iceweasel (<< 45), j2re1.4, pango-graphite (<< 0.9.3)
Breaks: xul-ext-torbutton
Provides: gnome-www-browser, www-browser
Priority: optional
Section: web
Filename: pool/firefox-esr/f/firefox-esr/firefox-esr_52.0esr-1~bpo80+1_amd64.deb
Size: 46877682
SHA256: a75f04e66290d1a2f6f4a15f5e9639a7ab4e31728ccf7a83bf43ba4eec255d28
SHA1: 0290461119491ce0680b525bbed1a80d26f238cd
MD5sum: 689321d7319f7d2770f4de64ebfde881
Description-en: Mozilla Firefox web browser - Extended Support Release (ESR)
Firefox ESR is a powerful, extensible web browser with support for modern
web application technologies.
Description-md5: 88ee196fd829d9218a763b4d498a6f6a

Package: firefox-esr
Version: 45.7.0esr-1~deb8u1
Installed-Size: 98116
Maintainer: Maintainers of Mozilla-related packages <pkg-mozilla-maintainers@lists.alioth.debian.org>
Architecture: amd64
Provides: gnome-www-browser, www-browser
Depends: libasound2 (>= 1.0.16), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.17), libcairo2 (>= 1.2.4), libdbus-1-3 (>= 1.0.2), libdbus-glib-1-2 (>= 0.78), libevent-2.0-5 (>= 2.0.10-stable), libffi6 (>= 3.0.4), libfontconfig1 (>= 2.11), libfreetype6 (>= 2.2.1), libgcc1 (>= 1:4.1.1), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.31.8), libgtk2.0-0 (>= 2.24.0), libhunspell-1.3-0 (>= 1.3.3), libpango-1.0-0 (>= 1.14.0), libstartup-notification0 (>= 0.8), libstdc++6 (>= 4.9), libx11-6, libxcomposite1 (>= 1:0.3-1), libxdamage1 (>= 1:1.1), libxext6, libxfixes3, libxrender1, libxt6, zlib1g (>= 1:1.2.0), fontconfig, procps, debianutils (>= 1.16), libsqlite3-0 (>= 3.7.12-1~)
Suggests: fonts-stix | otf-stix, fonts-lmodern, mozplugger, libgssapi-krb5-2 | libkrb53, libgnomeui-0, libcanberra0
Conflicts: iceweasel (<< 45), j2re1.4, pango-graphite (<< 0.9.3)
Breaks: xul-ext-torbutton
Description-en: Mozilla Firefox web browser - Extended Support Release (ESR)
Firefox ESR is a powerful, extensible web browser with support for modern
web application technologies.
Description-md5: 88ee196fd829d9218a763b4d498a6f6a
Recommends: gstreamer1.0-libav, gstreamer1.0-plugins-good
Section: web
Priority: optional
Filename: pool/updates/main/f/firefox-esr/firefox-esr_45.7.0esr-1~deb8u1_amd64.deb
Size: 43662292
MD5sum: c5d44dfa410b0a10605dc69cb44b0e18
SHA1: 22ce7f644cd3b29300620b1f6f92c8eb206d358e
SHA256: 10a48e07fbbfd02ac170563e6246f71dd92adbe3feaf3e80f1116a35f3269acc

Package: firefox-esr
Version: 45.6.0esr-1~deb8u1
Installed-Size: 98105
Maintainer: Maintainers of Mozilla-related packages <pkg-mozilla-maintainers@lists.alioth.debian.org>
Architecture: amd64
Provides: gnome-www-browser, www-browser
Depends: libasound2 (>= 1.0.16), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.17), libcairo2 (>= 1.2.4), libdbus-1-3 (>= 1.0.2), libdbus-glib-1-2 (>= 0.78), libevent-2.0-5 (>= 2.0.10-stable), libffi6 (>= 3.0.4), libfontconfig1 (>= 2.11), libfreetype6 (>= 2.2.1), libgcc1 (>= 1:4.1.1), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.31.8), libgtk2.0-0 (>= 2.24.0), libhunspell-1.3-0 (>= 1.3.3), libpango-1.0-0 (>= 1.14.0), libstartup-notification0 (>= 0.8), libstdc++6 (>= 4.9), libx11-6, libxcomposite1 (>= 1:0.3-1), libxdamage1 (>= 1:1.1), libxext6, libxfixes3, libxrender1, libxt6, zlib1g (>= 1:1.2.0), fontconfig, procps, debianutils (>= 1.16), libsqlite3-0 (>= 3.7.12-1~)
Recommends: gstreamer1.0-libav, gstreamer1.0-plugins-good
Suggests: fonts-stix | otf-stix, fonts-lmodern, mozplugger, libgssapi-krb5-2 | libkrb53, libgnomeui-0, libcanberra0
Conflicts: iceweasel (<< 45), j2re1.4, pango-graphite (<< 0.9.3)
Breaks: xul-ext-torbutton
Description-en: Mozilla Firefox web browser - Extended Support Release (ESR)
Firefox ESR is a powerful, extensible web browser with support for modern
web application technologies.
Description-md5: 88ee196fd829d9218a763b4d498a6f6a
Section: web
Priority: optional
Filename: pool/main/f/firefox-esr/firefox-esr_45.6.0esr-1~deb8u1_amd64.deb
Size: 43659918
MD5sum: 8929dcfd64c4e9d358a927d43f32b63f
SHA1: c99abd8edb3b485d73775c20c358922ee53a0fb8
SHA256: f0d9e5bc12fd6bb7950f2095bc3b5259516529b8e969a257d7600e61ad2ba1b5
ant
 
Posts: 282
Joined: 2011-11-09 00:15

Re: No more Debian's Jessie/stable's Firefox? :(

Postby stevepusser » 2017-03-09 23:02

Hmm--I tried changing that repo address, and don't see anything from it at all. I updated from it with apt-get update without any issues--let me check the address again.

Edit: I believe you, but I checked the address and updated, and this is all I get

Code: Select all
$ apt-cache policy firefox-esr
firefox-esr:
  Installed: (none)
  Candidate: 45.8.0esr-1~deb8u1
  Version table:
     45.8.0esr-1~deb8u1 0
        500 http://security.debian.org/ jessie/updates/main amd64 Packages
     45.6.0esr-1~deb8u1 0
        500 http://ftp.us.debian.org/debian/ jessie/main amd64 Packages


Looks like we've got a groovy mystery here, Scooby!

I went ahead and added a Jessie backports repo of my own on the openSUSE build service for the Firefox 52 from Sid, but tried a change they had done with the Arch rebuild so that theirs also had support for the alsa sound backend instead of requiring that everyone have pulseaudio. I don't know if that'll be the result, however. Right now it has got past the RAM-hungry compilation and is deep into the much more time-consuming self-testing stage.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Inkscape 0.92.1, Pale Moon 27.2.0, Liquorix kernel 4.9-18, mpv 0.24, Kodi 17.0, Shotwell 24.5, Mesa 13.0.6
User avatar
stevepusser
 
Posts: 7950
Joined: 2009-10-06 05:53

Re: No more Debian's Jessie/stable's Firefox? :(

Postby No_windows » 2017-03-10 06:29

I noticed that when I updated using Synaptic, only a few language paks for Firefox and Iceweasel were listed as new. If I did a search for "esr", I'd get the main package......which I then installed. This was right after changing my sources.list.
No_windows
 
Posts: 350
Joined: 2015-08-05 03:03

Re: No more Debian's Jessie/stable's Firefox? :(

Postby Ardouos » 2017-03-10 07:49

Looks like we've got a groovy mystery here, Scooby!

Rikes Raggy! We cannot solve this mystery on an empty stomach. :lol:

stevepusser wrote:Hmm--I tried changing that repo address, and don't see anything from it at all. I updated from it with apt-get update without any issues--let me check the address again.

Edit: I believe you, but I checked the address and updated, and this is all I get


Thats weird, here are my sources for FF52 if it helps.

Code: Select all
deb http://mozilla.debian.net/ jessie-backports firefox-esr


Code: Select all
# apt-get update
--snipped for convenience--
Ign http://mozilla.debian.net jessie-backports InRelease
Hit http://mozilla.debian.net jessie-backports Release.gpg
Hit http://mozilla.debian.net jessie-backports Release
Hit http://mozilla.debian.net jessie-backports/firefox-esr amd64 Packages
Ign http://mozilla.debian.net jessie-backports/firefox-esr Translation-en_GB
Ign http://mozilla.debian.net jessie-backports/firefox-esr Translation-en
Reading package lists... Done


Code: Select all
$ apt-cache policy firefox-esr
firefox-esr:
  Installed: 52.0esr-1~bpo80+1
  Candidate: 52.0esr-1~bpo80+1
  Version table:
 *** 52.0esr-1~bpo80+1 0
        500 http://mozilla.debian.net/ jessie-backports/firefox-esr amd64 Packages
        100 /var/lib/dpkg/status
     45.8.0esr-1~deb8u1 0
        500 http://security.debian.org/ jessie/updates/main amd64 Packages
     45.6.0esr-1~deb8u1 0
        500 http://ftp.uk.debian.org/debian/ jessie/main amd64 Packages


Code: Select all
$ firefox -v
Mozilla Firefox 52.0
User avatar
Ardouos
 
Posts: 851
Joined: 2013-11-03 00:30
Location: Elicoor II

Re: No more Debian's Jessie/stable's Firefox? :(

Postby ant » 2017-03-11 04:09

FYI:

Subject: Re: No more Debian's Jessie/stable's Firefox? :(
Date: Sat, 11 Mar 2017 13:45:07 +0900
From: Mike Hommey...
...
Sorry for the inconvenience coming from a partially implemented plan.

Rust will be required to build Firefox starting from version 54. The
rust compiler is not available in Jessie.

It would be problematic to let people upgrade through 52 and 53 and not
be able to upgrade to newer versions, so backports of Firefox release,
beta and aurora are simply not built anymore.

What was missing were the transition pieces.

People with the firefox-release apt source will now be upgraded to
firefox-esr 52 instead.

Sorry again for the inconvenience.

Mike

--

Subject: Re: firefox-release vanished, breaks apt-get update
Date: Sat, 11 Mar 2017 09:15:58 +0100
From: Carsten Schoenert <c.schoenert@t-online.de>
...

there are no recent firefox-release versions available for Jessie on
mozilla.debian.net for at least one reason.

All versions >52 are requiring now rustc [1] that isn't available for
Testing, Jessie or also Jessie Backports. I don't know if the
requirements for the rustc package could be ever solved for Jessie
(Backports). So it's right now unlikely that firefox-release will ever
be possible for Jessie in one or another form.

[1] https://packages.debian.org/source/testing/rustc

BTW: If mozilla.debian.net is not showing a valid entry for
firefox-release then there is obviously no chance to get such packages
for the desired distribution. And mozilla.debian.net is not part of the
official Debian universe, it's maintained on a free base by Mike Homey.
Based on free time and package evolving effort by Mike updates for the
firefox packages are available on mozilla.debian.net.

If there are errors while running apt-update please check first if the
source for installations is valid and available. If not there are no
installable packages for some reason.

--
Regards
Carsten Schoenert
Last edited by ant on 2017-03-11 16:24, edited 1 time in total.
ant
 
Posts: 282
Joined: 2011-11-09 00:15

Re: No more Debian's Jessie/stable's Firefox? :(

Postby Ardouos » 2017-03-11 15:05

ant wrote:FYI:

---------------------

Rust will be required to build Firefox starting from version 54. The
rust compiler is not available in Jessie.

---------------------

People with the firefox-release apt source will now be upgraded to
firefox-esr 52 instead.

Sorry again for the inconvenience.

Mike


That answers the question, thanks for the info. Maybe the repo will be open again when Stretch is released.
User avatar
Ardouos
 
Posts: 851
Joined: 2013-11-03 00:30
Location: Elicoor II


Return to Installation

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable