Wireless Killer ac 1535 doesn't work

Help with issues regarding installation of Debian

Wireless Killer ac 1535 doesn't work

Postby lurinoju » 2017-03-16 23:38


I have bought a new notebook and he have the Killer wireless ac 1535 and I need to install the firmware of this network card in Debian Linux.

I have tried the firmware-atheros, ath10k, some backports and nothing has worked.

When I executed the "lspci" in debian terminal, he show me this:

00:00.0 Host bridge: Intel Corporation Device 5910 (rev 05)
00:01.0 PCI bridge: Intel Corporation Device 1901 (rev 05)
00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04)
00:14.0 USB controller: Intel Corporation Device a12f (rev 31)
00:16.0 Communication controller: Intel Corporation Device a13a (rev 31)
00:17.0 SATA controller: Intel Corporation Device a103 (rev 31)
00:1c.0 PCI bridge: Intel Corporation Device a110 (rev f1)
00:1c.4 PCI bridge: Intel Corporation Device a114 (rev f1)
00:1c.6 PCI bridge: Intel Corporation Device a116 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Device a152 (rev 31)
00:1f.2 Memory controller: Intel Corporation Device a121 (rev 31)
00:1f.3 Audio device: Intel Corporation Device a171 (rev 31)
00:1f.4 SMBus: Intel Corporation Device a123 (rev 31)
01:00.0 3D controller: NVIDIA Corporation Device 139a (rev a2)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5287 (rev 01)
03:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 12)
04:00.0 Network controller: Qualcomm Atheros Device 003e (rev 32)

In the beginning neither the symbol of wireless appeared in the settings. After I did this process of the link below and the symbol appear. But he doesn't detect any network.

Sorry for the mistakes in english, I am from Brazil and I need your help.

Can you help me?
Posts: 1
Joined: 2017-03-16 23:37

Re: Wireless Killer ac 1535 doesn't work

Postby stevepusser » 2017-03-17 00:24

The short answer is that there is no driver in the ageing 3.16 kernel that supports your wi-fi, you will need a newer kernel and firmware from jessie-backports.

"New notebook" and "Jessie" are increasingly not going to work well from a regular install. You can update packages from jessie-backports, but it will be much easier if you have a wired connection, even for a short time to upgrade the kernel and firmware to get the wi-fi working.


You also have an Optimus setup in your laptop, which is an Intel integrated GPU and a discrete Nvidia GPU.. Most people use Bumblebee to only switch on the Nvidia card for 3D rendering for demanding programs such as games. Check the Debian wiki for Bumblebee, and you should use jessie-backports for the packages in that procedure.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: GIMP 2.10.2, Pale Moon 27.9.3, wine-staging 3.10, QuiteRSS 0.18.11, Linux kernel 4.17, Krita 4.0.4
User avatar
Posts: 9637
Joined: 2009-10-06 05:53

Return to Installation

Who is online

Users browsing this forum: No registered users and 3 guests