Activating The Root Account (I Want To Use Su Not Sudo)

Help with issues regarding installation of Debian

Re: Activating The Root Account (I Want To Use Su Not Sudo)

Postby luvr » 2017-07-24 16:11

Caitlin wrote:but no success -- Synaptic refuses to accept the root password, but will accept my user account's password.

It looks to me like Synaptic is no longer using the “su”/“sudo” mechanism, but switched to “PolicyKit” instead.
PolicyKit is based on “actions” with which authorisation rules are associated.

I’m not particularly familiar with PolicyKit, so I will have to dig a little deeper into this issue.
For starters, when you start the Synaptic Package Manager, you should see an authentication window that asks you for a password.
Close to the bottom left of the window, you should see a “Details” entry. If you click on that, you will be shown the PolicyKit action that synaptic requests—it should be “com.ubuntu.pkexec.synaptic”. Since synaptic prompts you for your own password, instead of the “root” one, there must be some PolicyKit configuration file set up to that effect.

Could you run the following command, to see which PolicyKit configuration files set up the “com.ubuntu.pkexec.synaptic” action? Run this as “root”, since some of the directories will not be accessible otherwise:
Code: Select all
grep -r 'ubuntu' /etc/polkit-1 /var/lib/polkit-1 /usr/share/polkit-1
Please post the output from the command.
luvr
 
Posts: 74
Joined: 2016-07-21 19:39
Location: Boom - The Home Town of Tomorrowland, Belgium

Re: Activating The Root Account (I Want To Use Su Not Sudo)

Postby GarryRicketson » 2017-07-24 17:22

Yes, but this is Debian, NOT Ubuntu.
But to be honest, I don't know maybe it is another "new feature" added
to Debian as well, ????
User avatar
GarryRicketson
 
Posts: 4133
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: Activating The Root Account (I Want To Use Su Not Sudo)

Postby luvr » 2017-07-24 18:41

GarryRicketson wrote:Yes, but this is Debian, NOT Ubuntu.

Even so, the PolicyKit action really is “com.ubuntu.pkexec.synaptic”—so, yes, it must have been copied from Ubuntu.
luvr
 
Posts: 74
Joined: 2016-07-21 19:39
Location: Boom - The Home Town of Tomorrowland, Belgium

Re: Activating The Root Account (I Want To Use Su Not Sudo)

Postby Dai_trying » 2017-07-24 21:48

@Caitlin
Have you tried dpkg-reconfigure synaptic? it might give you the option again to use su instead of sudo although I haven't tested this.
Dai_trying
 
Posts: 297
Joined: 2016-01-07 12:25

Re: Activating The Root Account (I Want To Use Su Not Sudo)

Postby cfb » 2017-07-25 03:36

As far as I know, the selection between "su" and "sudo" mode for "gksu" can be made either for the system or for the individual user. How to do it for the system has been described earlier in this thread:
Code: Select all
# update-alternatives --config libgksu-gconf-defaults
# update-gconf-defaults
.
To make the selection for the current user, use this command:
Code: Select all
$ gksu-properties

Now, I am quite certain that in Jessie, the user default mode for "gksu" was to use "su" mode. In Stretch I believe this has been changed to use the "sudo" mode. It may be in the documentation somewhere but I have simply noticed it.
cfb
 
Posts: 17
Joined: 2017-01-08 16:39

Re: Activating The Root Account (I Want To Use Su Not Sudo)

Postby luvr » 2017-07-25 05:05

Dai_trying wrote:@Caitlin
Have you tried dpkg-reconfigure synaptic? it might give you the option again to use su instead of sudo although I haven't tested this.

That was one of the things that I thought of too, but it doesn’t do anything, apparently.
luvr
 
Posts: 74
Joined: 2016-07-21 19:39
Location: Boom - The Home Town of Tomorrowland, Belgium

Re: Activating The Root Account (I Want To Use Su Not Sudo)

Postby luvr » 2017-07-25 05:09

cfb wrote:To make the selection for the current user, use this command:
Code: Select all
$ gksu-properties

That must be it! It displays the “Privilege granting preferences” dialogue that Caitlin appeared to refer to earlier on.
luvr
 
Posts: 74
Joined: 2016-07-21 19:39
Location: Boom - The Home Town of Tomorrowland, Belgium

Re: Activating The Root Account (I Want To Use Su Not Sudo)

Postby Caitlin » 2017-07-25 18:46

Code: Select all
# gksu-properties

(gksu-properties:3744): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
GConf Error: No D-BUS daemon running


(gksu-properties:3744): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
GConf Error: No D-BUS daemon running


(gksu-properties:3744): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
GConf Error: No D-BUS daemon running


(gksu-properties:3744): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
GConf Error: No D-BUS daemon running

--------------------------------------------------------------------------------------------------------------------------

# dpkg-reconfigure synaptic

(no output from this command)

--------------------------------------------------------------------------------------------------------------------------

# grep -r 'ubuntu' /etc/polkit-1 /var/lib/polkit-1 /usr/share/polkit-1

/usr/share/polkit-1/actions/com.ubuntu.pkexec.synaptic.policy:  <action id="com.ubuntu.pkexec.synaptic">

In each case, I tried Synaptic again. No change.

Caitlin
Caitlin
 
Posts: 236
Joined: 2012-05-24 07:32

Re: Activating The Root Account (I Want To Use Su Not Sudo)

Postby cfb » 2017-07-25 19:15

You should run "gksu-properties" as your normal user, not as root.
cfb
 
Posts: 17
Joined: 2017-01-08 16:39

Previous

Return to Installation

Who is online

Users browsing this forum: sunrat and 6 guests

fashionable