[SOLVED] - Debian 9 not display destop icons after dist-u

Help with issues regarding installation of Debian

[SOLVED] - Debian 9 not display destop icons after dist-u

Postby darkpchan » 2017-07-15 21:35

:?: After running dist-upgrade (Jessie to Scretch) my icons are not displayed on the desktop.

My desktop screenshot

My Source-List (to upgrade)

Code: Select all
deb http://ftp.br.debian.org/debian/ stretch main non-free contrib

deb-src http://ftp.br.debian.org/debian/ stretch main non-free contrib

deb http://security.debian.org/ stretch/updates main contrib non-free

deb-src http://security.debian.org/ stretch/updates main contrib non-free

deb http://ftp.br.debian.org/debian/ stretch-updates main contrib non-free

deb-src http://ftp.br.debian.org/debian/ stretch-updates main contrib non-free

deb http://debug.mirrors.debian.org/debian-debug/ stretch-debug main



Someone let me help?

Thanks.
Last edited by darkpchan on 2017-09-10 19:26, edited 1 time in total.
User avatar
darkpchan
 
Posts: 4
Joined: 2016-07-11 01:21

Re: Debian 9 desktop does not display icons after dist-upgra

Postby HarborView » 2017-07-16 11:39

Icons in:

Xfce
KDE
Mate
Gnome
Cinnamon
LXDE

Which one? I looked at the screenshot and all I can tell is it's a UI I have not used. (Well, I can tell it''s not Xfce, anyway.)
HarborView
 
Posts: 38
Joined: 2014-02-01 02:21
Location: The Space Coast of the USA

Re: Debian 9 desktop does not display icons after dist-upgra

Postby Lysander » 2017-07-16 12:26

That's GNOME. The look of the top bar alone tells one that [and the OP has GNOME Tweak Tool open].
User avatar
Lysander
 
Posts: 317
Joined: 2017-02-23 10:07
Location: London

Re: Debian 9 desktop does not display icons after dist-upgra

Postby HarborView » 2017-07-17 12:17

Thank you, Lysander. Now we're closing in.

@OP: Use the command line and see if there are any files named with the .desktop extension.
Code: Select all
cd ~/Desktop
ls


I made an assumption that since this is a GTK based system that .desktop is the extension for a launcher, aka, link, aka, icon.
HarborView
 
Posts: 38
Joined: 2014-02-01 02:21
Location: The Space Coast of the USA

Re: Debian 9 desktop does not display icons after dist-upgra

Postby HarborView » 2017-07-18 10:32

Here we go. Gnome 3 has the icons turned off by default. There are lots of ways to fix it.

In a monitor (aka command line window):
Code: Select all
gsettings set org.gnome.desktop.background show-desktop-icons true


Code: Select all
# show files on desktop
gsettings set org.gnome.desktop.background show-desktop-icons true

# show shares on desktop
gsettings set org.gnome.nautilus.desktop volumes-visible true

# restart nautilus
nautilus -q
nautilus


Source: https://askubuntu.com/questions/43246/h ... on-desktop

----------------------------------------------

Change it with the menus of the dconf-editor :

Open the Application Finder window with Alt+F2 .
Enter deconf-editor .
Select org > gnome > desktop > background .
Check the check box for show-desktop-icons .

Source: Joe Steiger @ http://joesteiger.com/2011/07/02/enable ... ntu-11-04/


----------------------------------------------
The gnome-tweak-tool will also do it. You may have to download and install it first.
HarborView
 
Posts: 38
Joined: 2014-02-01 02:21
Location: The Space Coast of the USA

Re: Debian 9 desktop does not display icons after dist-upgra

Postby darkpchan » 2017-09-03 21:19

HarborView wrote:Here we go. Gnome 3 has the icons turned off by default. There are lots of ways to fix it.

In a monitor (aka command line window):
Code: Select all
gsettings set org.gnome.desktop.background show-desktop-icons true


Code: Select all
# show files on desktop
gsettings set org.gnome.desktop.background show-desktop-icons true

# show shares on desktop
gsettings set org.gnome.nautilus.desktop volumes-visible true

# restart nautilus
nautilus -q
nautilus


Source: https://askubuntu.com/questions/43246/h ... on-desktop

----------------------------------------------

Change it with the menus of the dconf-editor :

Open the Application Finder window with Alt+F2 .
Enter deconf-editor .
Select org > gnome > desktop > background .
Check the check box for show-desktop-icons .

Source: Joe Steiger @ http://joesteiger.com/2011/07/02/enable ... ntu-11-04/


----------------------------------------------
The gnome-tweak-tool will also do it. You may have to download and install it first.


Thanks, tks, thanks for reply. Thanks for all, but NOT WORK'S.
User avatar
darkpchan
 
Posts: 4
Joined: 2016-07-11 01:21

Re: Debian 9 desktop does not display icons after dist-upgra

Postby darkpchan » 2017-09-10 19:25

darkpchan wrote:[

Thanks, tks, thanks for reply. Thanks for all, but NOT WORK'S.


I recreated the user and it worked.
User avatar
darkpchan
 
Posts: 4
Joined: 2016-07-11 01:21


Return to Installation

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable