Diagonal Pixel Displacement in Installer

Help with issues regarding installation of Debian

Diagonal Pixel Displacement in Installer

Postby Siernan » 2017-08-08 15:09

To begin, there is a similar thread that *appears* the same to me (at least symptomatically). That said, it was requested that I make a new thread denoting any details particular to my case and any information that I have regarding it. Hopefully there is progress (and learning) to be had! (Other thread: viewtopic.php?f=17&t=132200)

I originally posted in that other thread, but will replicate that information here, in addition to going into more detail that maybe will provide more insight or help someone else diagnose this further.

To begin, here is the hardware that I am primarily working on:

HP EliteBook 840 G1 - System SKU: F1R92AW#ABA (the ProBook and EliteBook HP product lines would be considered "business-grade" laptops, EliteBook being typically a little sleeker/nicer/more compact)

What I have been attempting to do is configure dual/multi boot on this laptop. Its original and unfortunately primary OS is Windows 10 Enterprise, build 1703. The below information was acquired from that OS, via msinfo32.exe.

General System Info:
System Manufacturer Hewlett-Packard
System Model HP EliteBook 840 G1
System Type x64-based PC
System SKU F1R92AW#ABA
Processor Intel(R) Core(TM) i5-4300U CPU @ 1.90GHz, 2501 Mhz, 2 Core(s), 4 Logical Processor(s)
BIOS Version/Date Hewlett-Packard L71 Ver. 01.39, 9/26/2016
SMBIOS Version 2.7
Embedded Controller Version 21.89
BaseBoard Manufacturer Hewlett-Packard
Installed Physical Memory (RAM) 8.00 GB

Network Devices Info:
Product Type Intel(R) Ethernet Connection I218-LM
PNP Device ID PCI\VEN_8086&DEV_155A&SUBSYS_198F103C&REV_04\3&B1BFB68&0&C8

Product Type Intel(R) Dual Band Wireless-N 7260
PNP Device ID PCI\VEN_8086&DEV_08B1&SUBSYS_40608086&REV_73\D8FC93FFFFCACC2C00

Display (probably the truly important info):
Name Intel(R) HD Graphics Family
PNP Device ID PCI\VEN_8086&DEV_0A16&SUBSYS_198F103C&REV_0B\3&B1BFB68&0&10
Adapter Type Intel(R) HD Graphics Family, Intel Corporation compatible
Adapter Description Intel(R) HD Graphics Family
Adapter RAM 1.00 GB (1,073,741,824 bytes)
Color Table Entries 4294967296
Resolution 1366 x 768 x 59 hertz
Bits/Pixel 32

(not provided by msinfo32, but this adapter seems to be an Intel HD 4400 from a different location in Windows)

Audio Device (built in speakers):
Name High Definition Audio Device
Manufacturer Microsoft
PNP Device ID HDAUDIO\FUNC_01&VEN_111D&DEV_76E0&SUBSYS_103C211E&REV_1003\4&35E8259D&0&0001

Now onto the fun bits. I began with several distros that I wanted to try out and play around with. Kali, Parrot, Devuan, Debian, and Gentoo to name some. I began with Parrot/Kali (I haven't had a massive block of time yet to dedicate to the only non-Debian in that list, as obviously it requires a bit of an investment due to all of the selection/compiling). So I downloaded the relevant (full/live) .iso files. I used Rufus 2.16 in Windows to write them to an 8GB SanDisk USB drive, and when prompted I chose to write them in DD mode.

Additionally, prior to all of that, I took the time to configure rEFInd on the laptop. I had to recreate and fiddle around with a larger EFI partition first (Windows only created a 100MB partition for EFI), but now have an approximately 1GB (oversized I know) EFI partition with rEFInd set up and working.

So, I plugged in the flash drive, and booted the machine. rEFInd picked up the drive, and loaded into the installer GRUB menu (Parrot was the first one I did). The GRUB menu loads fine, but both the graphical and text installers display the issue once loaded (chose both expert/non-expert options for both graphical and textual). To rule out rEFInd causing any issues, I also booted straight to the USB drive from the HP BIOS, skipping rEFInd.

I was a bit confuzzled, so I moved onto Kali. Re-imaged the USB drive (same process, different ISO). This also displayed the same symptoms. So I resigned myself to attempting to troubleshoot. Inspecting the Kali GRUB parameters for both expert/non-expert, they have kernel boot parameters of (if I'm remembering correctly):

video=vesa:ywrap,mtrr vga=788 quiet

Since this seems to be some sort of display related issue, I tried to read up on those parameters and see if I could alter them to make them work. I tried a whole slew of things, some of which I'm not even sure if they're real parameters, others I acquired from the kernel documentation, but I'm not sure if they apply to the hardware. Examples below:

{no parameters}
nomodeset quiet
nomodeset i915.modeset=0 quiet
video=vesa:mode=1366x768-32@59 quiet
video=intelfb:mode=1366x768-32@59 quiet
video=inteldrmfb:mode=1366x768-32@59 quiet

I used the refresh of 59 Hz since that's what Windows listed above. I believe I tried 60 Hz a couple times as well but didn't clearly note that.

I also experienced this issue (the symptom anyway) on an HP ProBook 650 G1, but didn't do a detailed exploration, since both Parrot and Kali .iso's included a Live boot option. I booted into the Parrot Live environment (which, experienced the issue initially during boot, but then sorted itself out after approximately 4.55s into the boot sequence), and then ran the install to disk from within the Live environment. Similarly, Kali displays diagonally displaced gibberish until about 4s in, when (I'm guessing) it loads the appropriate driver or setting and sorts itself out.

To continue the shenanigans, it gets weirder (in my opinion). I figured I was already hip deep in experimentation, so for fun, I slapped the laptop onto its appropriate dock (which is plugged into power, ethernet, and a VGA monitor), shut it down, plugged the USB drive into the dock itself, closed the lid, and powered it up. rEFInd came up on the VGA monitor (as expected, typical behavior with the laptop dock and lid closed is that the dock monitor becomes primary), and it recognized the USB drive (as expected, all good and non-weird so far) so I chose the USB drive, it loaded GRUB, I chose Expert Graphical Install (this is still Kali btw, and I am choosing Expert because I'm not installing GRUB during the install, as I already have rEFInd), and miraculously it loaded clear as day. So I proceeded to go through the install.

That said, while there is a workaround, which, is odd to me because I feel that the dock setup is more complex and would have assumed that utilizing the dock and its ports properly would require more interesting settings and tweaking, I am extremely curious to see where this leads and if there is a solution in some sort of custom option or something (this is all a learning experience for me).

I would be happy to provide any additional information, via either Windows or Kali (since I managed to get that installed), but I can comfortably say that while I am vaguely competent as a person, my mastery and knowledge of Linux commands is rather minimal (but improving), so if there's some information that you'd like me to require, please let me know if you're looking for me to run a specific command with specific parameters.

Pictures of the text installer and graphical installer respectively are posted at the imgur link below. They are of the Debian 9.1.0 installer (I looked, it doesn't include a framebuffer kernel boot parameter). What is interesting to me, and maybe helps the diagnosis, I'm not sure, is that in the graphical installer, the highlight bar is rendered correctly, while the underlying text is all messed up.

Posts: 9
Joined: 2017-08-07 22:02

Re: Diagonal Pixel Displacement in Installer

Postby debiman » 2017-08-10 17:53

it would still be better to look at various outputs from an actually booted live environment, try the following, compare the docked situation to the undocked situation:
Code: Select all

...a lot to read & sift through, i know.

the following should be the same whether it's docked or not, but check for differences anyway (esp. "kernel driver in use"):
Code: Select all
lspci -k
User avatar
Posts: 3064
Joined: 2013-03-12 07:18

Re: Diagonal Pixel Displacement in Installer

Postby Siernan » 2017-08-10 20:09


I think in the other thread that could just have been an issue with his USB drive, but, as you said, we'll ignore that and focus on future efforts :).

I am fine doing a manual diff of the dmesg output haha, should be buckets of fun! I've got Kali/Parrot and Debian (Stretch) installed now (via the dock of course lol), so I'll boot into plain Debian and run those and have a looksie and report back.

Thanks for the commands!
Posts: 9
Joined: 2017-08-07 22:02

Re: Diagonal Pixel Displacement in Installer

Postby Siernan » 2017-08-14 23:28

Hokay, so, I'm slow, got caught up with ~life~ things.

However, here are the results.

dmesg_undocked_output: https://pastebin.com/W7ybwnsG
lspci_k_undocked_output: https://pastebin.com/GNiZEKDe

dmesg_docked_output: https://pastebin.com/Qdez0p9g
lspci_k_undocked_output: https://pastebin.com/RyNABx77

Now, I don't expect those here to do all the work for me, so, here is what I focused on while trolling through these outputs. If I'm wildly off base, please e-hit me in the head.

I saw no difference between the lspci -k output, and the below is what I think is relevant:
Code: Select all
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
   Subsystem: Hewlett-Packard Company Haswell-ULT Integrated Graphics Controller
   Kernel driver in use: i915
   Kernel modules: i915

What is interesting (to me) is that I would have imagined that maybe the undocked version would have loaded a different module/driver and that was causing the issue, but, alas, it is not that easy.

The dmesg output is obviously more complex, so, thinking it must be related to some sort of display or framebuffer driver/module/thingy, I focused my review on that. I looked for (and have included snippets of below) things relating to console/fb/framebuffer/VGA/display, keywords like that:

Undocked snippets:
Code: Select all
[    0.000000] Console: colour dummy device 80x25
[    0.000000] console [tty0] enabled
[    2.973625] efifb: probing for efifb
[    2.973639] efifb: framebuffer at 0xc0000000, using 4160k, total 4160k
[    2.973643] efifb: mode is 1366x768x32, linelength=5464, pages=1
[    2.973646] efifb: scrolling: redraw
[    2.973650] efifb: Truecolor: size=8:8:8:8, shift=24:16:8:0
[    2.976417] Console: switching to colour frame buffer device 170x48
[    2.979033] fb0: EFI VGA frame buffer device
[    3.335675] [drm] Memory usable by graphics device = 2048M
[    3.336277] fb: switching to inteldrmfb from EFI VGA
[    3.336867] Console: switching to colour dummy device 80x25
[    3.336915] [drm] Replacing VGA console driver
[    3.342393] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    3.342400] [drm] Driver supports precise vblank timestamp query.
[    3.366142] [drm] Initialized i915 1.6.0 20160919 for 0000:00:02.0 on minor 0
[    3.368569] fbcon: inteldrmfb (fb0) is primary device
[    4.452796] Console: switching to colour frame buffer device 170x48
[    4.493107] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device

Docked snippets:
Code: Select all
[    0.000000] Console: colour dummy device 80x25
[    0.000000] console [tty0] enabled
[    2.967752] efifb: probing for efifb
[    2.967766] efifb: framebuffer at 0xc0000000, using 5120k, total 5120k
[    2.967770] efifb: mode is 1280x1024x32, linelength=5120, pages=1
[    2.967773] efifb: scrolling: redraw
[    2.967777] efifb: Truecolor: size=8:8:8:8, shift=24:16:8:0
[    2.971088] Console: switching to colour frame buffer device 160x64
[    2.974293] fb0: EFI VGA frame buffer device
[    3.392479] [drm] Memory usable by graphics device = 2048M
[    3.393255] fb: switching to inteldrmfb from EFI VGA
[    3.394032] Console: switching to colour dummy device 80x25
[    3.394101] [drm] Replacing VGA console driver
[    3.400377] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    3.400385] [drm] Driver supports precise vblank timestamp query.
[    3.466749] [drm] Initialized i915 1.6.0 20160919 for 0000:00:02.0 on minor 0
[    3.472195] fbcon: inteldrmfb (fb0) is primary device
[    3.522473] Console: switching to colour frame buffer device 160x64
[    3.539890] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device

Disclaimer: I was planning on using pure Debian, but, ended up using Kali due to the easy availability of a Live bootable USB image. (Also I whoopsed and nuked the disk clean, so the Debian install went poof ;)
That said, this seems to affect Debian and any of the derivatives I've tried, so I figured it'd be fine.

The only differences I see in the above are the resolutions that the kernel decides to use, which makes perfect sense as the laptop screen is not the same resolution or physical size of the external monitor. Nearest that I can tell, when booting the live Kali disk, I start seeing boot logs right around/after 4s (meaning, the screen turns from gibberish into properly displayed startup sequence). So right now, my guess is that maybe the installer isn't loading the i915 module/driver maybe? So the follow up question would be how to politely ask it to load that from the beginning. I believe I attempted doing some i915 kernel boot options other than the nomodeset, but, not 100% on that so if that's something to try again I can definitely do it (and even document the results this time).
Posts: 9
Joined: 2017-08-07 22:02

Re: Diagonal Pixel Displacement in Installer

Postby Siernan » 2017-08-17 13:48

I have been trying to read up on the i915 driver? to see if there are parameters that I can tweak at boot to get things rolling properly. That said, I stumbled across just a way to view them on the booted system (probably should have done this earlier), but here's a pastebin of the settings dumped from the live booted Kali.


The command I ran is below:

Code: Select all
grep -H '' /sys/module/i915/parameters/* > ~/Desktop/i915_parameters.txt
Posts: 9
Joined: 2017-08-07 22:02

Re: Diagonal Pixel Displacement in Installer

Postby debiman » 2017-08-17 15:03

i think you should search the web for people having problems (and solutions) with linux on dockable/docked/undocked laptops.
User avatar
Posts: 3064
Joined: 2013-03-12 07:18

Re: Diagonal Pixel Displacement in Installer

Postby Siernan » 2017-08-17 18:26

Could you walk me through the chain of logic that lead to that comment?

Perhaps I am just being daft (extremely likely), but, no issue I have reported seems to be causally linked to docking. I happened to notice that the docked behavior was different, but, I can utterly remove the dock from the situation and still be left with a problem. Plug in the laptop with power, ethernet, and a bootable Debian installer, boot to Debian installer, see screwy screen regardless of installation option chosen.

If I do a quick search using keywords supplied by you, what comes up is pages and pages of issues that people have with Linux in situations where they are docking/undocking an already installed system, and experiencing problems with the graphics hardware/Linux auto-determining the appropriate output. This is not what I have issue with. My issue, to restate, is the garbled screen upon boot of an installer in native UEFI mode. [ Google search performed: linux dockable undockable laptops ]

For kicks I just tried a Debian 8.9.0 DVD installer via USB, same issue. What is interesting is that this bugreport exists but doesn't look like it went anywhere:


And this Debian wiki page for the laptop I'm using didn't seem to have issues installing Jessie (not stated what specific version):


Though, the above is a different sub-model than what I have.

All that said, searches do reveal others experiencing the issue, but I cannot find a solution:


So far the link is the graphics adapter from what I can see, the Intel HD 4400. I'm going to keep fiddling with kernel boot parameters and see if I can come up with any answers of my own. Any help is obviously appreciated :).
Posts: 9
Joined: 2017-08-07 22:02

Re: Diagonal Pixel Displacement in Installer

Postby mash » 2017-12-26 19:06


I have the same problem on HP ProBook and also found bugreport and threads you mention. I have finally managed to install Debian 9 based on method described here: https://unix.stackexchange.com/question ... -installer

My Quick-And-Dirty-Workaround was:
1. make bootable USB with FAT32 partition (efi and boot flags in gparted);
2. mount USB partition;
3. copy intrd.gz and vmlinuz from installation CD/DVD to USB partition (depends on installation media but these files should be in /install.amd/ or /d-i/ or similar directory;
4. make /EFI/ folder on USB's FAT32 partition;
5. install or copy rEFInd files to that folder;
6. rename /EFI/refind/ folder and refind_x64.efi file inside that folder to /EFI/boot/ and bootx64.efi;
7. boot your laptop from that USB and CD/DVD inside optical drive.
You should boot to text installer in American English and you can select you keyboard (slelecting language did not work). When you start installation the process is passed to CD/DVD.
After you boot into your new system get rid of grub and install rEFInd (explanation below but on your machine grub could work).

Of course you could tweak kernel options in rEFInd or try with syslinux or isolinux (or edit media in isomaster) so you do not need CD/DVD during installation, but I was in hurry and working from live system.

I see that this issue occurs mostly on HP laptops booting in "UEFI Native" mode (without CMS or Legacy mode enabled). Video card being irrelevant (mine is AMD APU integrated). I only know that my video card uses GOP only drivers and "Install with CMS enabled" workaround is not an option. I encounter that issue on every live system (not only Debian and derivatives) that use grub to load kernel. Chain of events is:
1. grub menu perfectly visible;
2. system loading with dots and glitches all over screen (here is where debian-installer stops);
3. working and visible live system.
My guess is that HP EFI implementation (which is not perfect...) does not work very well with grub way of passing kernel parameters or giving way to kernel video drivers. When I remove grub from chain of booting and start initrd (kernel EFI stub) directly or with rEFInd the issue does not appear.
So I think the problem was not resolved by docking laptop but by using rEFInd instead of grub.

Posts: 1
Joined: 2017-12-26 17:56

Re: Diagonal Pixel Displacement in Installer

Postby Strjuk » 2018-01-05 17:27

Hi, all
The "mash" is absolutely right.
The root cause of the problem is "UEFI Native" mode in HP laptops.
I have HP Probook 450 laptop and I had the same problem with the Debian based distributive installation.
I changed the laptop boot option from "UEFI Native" to "UEFI Hybrid", as a result, Diagonal Pixel Displacement was disappeared.
Installation was successful.
Posts: 1
Joined: 2018-01-05 17:07

Return to Installation

Who is online

Users browsing this forum: No registered users and 7 guests