Debian Jessie install error in Buffalo Linkstation LS-CHLv2

Help with issues regarding installation of Debian

Debian Jessie install error in Buffalo Linkstation LS-CHLv2

Postby bishop341b » 2017-08-26 22:04

Hi all,

I had success in the past with this procedure my LS-CHLv2, installing Jessie in my LS-CHLv2: http://buffalo.nas-central.org/wiki/Debian_Jessie_on_LS-CHLv2. Basically booting the Debian Jessie Installer from TFTP, triggering EM mode in Linkstation. I upgraded then to debian testing and updating, all working ok to about some weeks ago. After a update to kernel 4.10, endless rebooting. (later I realized that it can be related to this https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=870185

Anyway... in that moment I thinked that some in the update went wrong and tried to reinstall Jessie with same procedure. But this time, I can not complete the install: I can get access to the installer but now some strange thing happens. I can't assign use to the partitions: there are no ext filesystem options to assign use for a partition.


Code: Select all
│                                      │
│ How to use this partition:           │
│                                      │
│  swap area                           │
│  Reserved BIOS boot area             │
│  physical volume for encryption      │
│  physical volume for LVM             │
│  do not use the partition            │
│                                      │
│     <Go Back>



I had marked partman-ext3 in the modules to load page, but there is a problem with ext3(4) and the rest of filesystems.


Code: Select all
[  296.006680] ext4: Unknown symbol setattr_prepare (err 0)
[  296.025863] ext4: Unknown symbol posix_acl_update_mode (err 0)
[  296.038093] fat: Unknown symbol setattr_prepare (err 0)
[  296.151428] ext4: Unknown symbol setattr_prepare (err 0)
[  296.160030] ext4: Unknown symbol posix_acl_update_mode (err 0)
[  296.179776] ext4: Unknown symbol setattr_prepare (err 0)
[  296.188398] ext4: Unknown symbol posix_acl_update_mode (err 0)


If partman-auto module is selected, it can be used to configure (and format) correct partitions but then, installer says that the ext4 / partition can not be mounted, and you can not modify it also (you only are given with above options).

I tried to update firmware to the lastest (1.73) and modifiy enviroment of u-boot (original bootargs_root=root=/dev/sda2 rw initrd=0x00800040,12M panic=5 to bootargs_root=root=/dev/sda2 rw panic=5) with no progress.

I tried also Stretch and Buster versions of the installer, but same results.

Any ideas?

Complete dmesg:

Code: Select all
~ # dmesg
[    0.000000] Booting Linux on physical CPU 0x0
[    0.000000] Initializing cgroup subsys cpuset
[    0.000000] Initializing cgroup subsys cpu
[    0.000000] Initializing cgroup subsys cpuacct
[    0.000000] Linux version 3.16.0-4-kirkwood (debian-kernel@lists.debian.org) (gcc version 4.8.4 (Debian 4.8.4-1) ) #1 Debian 3.16.36-1+deb8u1 (2016-09-03)
[    0.000000] CPU: Feroceon 88FR131 [56251311] revision 1 (ARMv5TE), cr=0005397f
[    0.000000] CPU: VIVT data cache, VIVT instruction cache
[    0.000000] Machine model: Buffalo Linkstation LS-CHLv2
[    0.000000] Memory policy: Data cache writeback
[    0.000000] On node 0 totalpages: 16384
[    0.000000] free_area_init_node: node 0, pgdat c05d4db8, node_mem_map c3f79000
[    0.000000]   DMA zone: 128 pages used for memmap
[    0.000000]   DMA zone: 0 pages reserved
[    0.000000]   DMA zone: 16384 pages, LIFO batch:3
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256
[    0.000000] Kernel command line: console=ttyS0,115200 root=/dev/sda2 rw panic=5 BOOTVER=0.22 tftpboot=yes
[    0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Memory: 52644K/65536K available (3907K kernel code, 360K rwdata, 1440K rodata, 277K init, 288K bss, 12892K reserved, 0K highmem)
[    0.000000] Virtual kernel memory layout:
[    0.000000]     vector  : 0xffff0000 - 0xffff1000   (   4 kB)
[    0.000000]     fixmap  : 0xffc00000 - 0xffe00000   (2048 kB)
[    0.000000]     vmalloc : 0xc4800000 - 0xff000000   ( 936 MB)
[    0.000000]     lowmem  : 0xc0000000 - 0xc4000000   (  64 MB)
[    0.000000]     pkmap   : 0xbfe00000 - 0xc0000000   (   2 MB)
[    0.000000]     modules : 0xbf000000 - 0xbfe00000   (  14 MB)
[    0.000000]       .text : 0xc0008000 - 0xc05410d4   (5349 kB)
[    0.000000]       .init : 0xc0542000 - 0xc058774c   ( 278 kB)
[    0.000000]       .data : 0xc0588000 - 0xc05e2168   ( 361 kB)
[    0.000000]        .bss : 0xc05e2168 - 0xc062a54c   ( 289 kB)
[    0.000000] NR_IRQS:114
[    0.000023] sched_clock: 32 bits at 166MHz, resolution 6ns, wraps every 25769803770ns
[    0.000519] Console: colour dummy device 80x30
[    0.000557] Calibrating delay loop... 595.96 BogoMIPS (lpj=1191936)
[    0.028111] pid_max: default: 32768 minimum: 301
[    0.028285] Security Framework initialized
[    0.028359] Yama: disabled by default; enable with sysctl kernel.yama.*
[    0.028483] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.028513] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.029785] Initializing cgroup subsys memory
[    0.029846] Initializing cgroup subsys devices
[    0.029929] Initializing cgroup subsys freezer
[    0.029970] Initializing cgroup subsys net_cls
[    0.030038] Initializing cgroup subsys blkio
[    0.030092] Initializing cgroup subsys perf_event
[    0.030126] Initializing cgroup subsys net_prio
[    0.030261] CPU: Testing write buffer coherency: ok
[    0.030422] ftrace: allocating 16358 entries in 32 pages
[    0.076562] Setting up static identity map for 0x3b1e78 - 0x3b1ed0
[    0.082389] devtmpfs: initialized
[    0.085397] pinctrl core: initialized pinctrl subsystem
[    0.086160] regulator-dummy: no parameters
[    0.093551] NET: Registered protocol family 16
[    0.094165] DMA: preallocated 256 KiB pool for atomic coherent allocations
[    0.095676] cpuidle: using governor ladder
[    0.095716] cpuidle: using governor menu
[    0.096187] Feroceon L2: Enabling L2
[    0.096251] Feroceon L2: Cache support initialised.
[    0.096800] [Firmware Info]: /ocp@f1000000/ethernet-controller@72000/ethernet0-port@0: local-mac-address is not set
[    0.096892] [Firmware Info]: /ocp@f1000000/ethernet-controller@76000/ethernet1-port@0: local-mac-address is not set
[    0.105920] No ATAGs?
[    0.113139] platform regulators:regulator@1: Driver reg-fixed-voltage requests probe deferral
[    0.113257] platform regulators:regulator@2: Driver reg-fixed-voltage requests probe deferral
[    0.115282] Switched to clocksource orion_clocksource
[    0.154052] NET: Registered protocol family 2
[    0.155813] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.155861] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.155896] TCP: Hash tables configured (established 1024 bind 1024)
[    0.155987] TCP: reno registered
[    0.156010] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.156046] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.156344] NET: Registered protocol family 1
[    0.156443] PCI: CLS 0 bytes, default 32
[    0.156854] Unpacking initramfs...
[    1.130595] Freeing initrd memory: 5904K (c0801000 - c0dc5000)
[    1.133341] futex hash table entries: 256 (order: -1, 3072 bytes)
[    1.133470] audit: initializing netlink subsys (disabled)
[    1.133572] audit: type=2000 audit(1.120:1): initialized
[    1.134965] zbud: loaded
[    1.135462] VFS: Disk quotas dquot_6.5.2
[    1.135550] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[    1.135713] jffs2: version 2.2. (NAND) (SUMMARY)  © 2001-2006 Red Hat, Inc.
[    1.136100] msgmni has been set to 114
[    1.139322] alg: No test for stdrng (krng)
[    1.139501] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 252)
[    1.139837] io scheduler noop registered
[    1.140098] io scheduler cfq registered (default)
[    1.142209] kirkwood-pinctrl f1010000.pin-controller: registered pinctrl driver
[    1.144766] mv_xor f1060800.xor: Marvell shared XOR driver
[    1.163488] mv_xor f1060800.xor: Marvell XOR: ( xor cpy )
[    1.183482] mv_xor f1060800.xor: Marvell XOR: ( xor cpy )
[    1.183804] mv_xor f1060900.xor: Marvell shared XOR driver
[    1.203483] mv_xor f1060900.xor: Marvell XOR: ( xor cpy )
[    1.223481] mv_xor f1060900.xor: Marvell XOR: ( xor cpy )
[    1.224261] Serial: 8250/16550 driver, 2 ports, IRQ sharing disabled
[    1.226493] console [ttyS0] disabled
[    1.226578] f1012000.serial: ttyS0 at MMIO 0xf1012000 (irq = 33, base_baud = 10416666) is a 16550A
[    1.745054] console [ttyS0] enabled
[    1.759439] m25p80 spi0.0: m25p40 (512 Kbytes)
[    1.763938] 3 ofpart partitions found on MTD device spi0.0
[    1.769429] Creating 3 MTD partitions on "spi0.0":
[    1.774229] 0x000000000000-0x000000060000 : "uboot"
[    1.781261] 0x000000060000-0x000000070000 : "dtb"
[    1.788070] 0x000000070000-0x000000080000 : "uboot_env"
[    1.796260] mousedev: PS/2 mouse device common for all mice
[    1.802394] rtc-mv f1010300.rtc: retrieved alarm date/time is not valid.
[    1.809570] rtc-mv f1010300.rtc: rtc core: registered f1010300.rtc as rtc0
[    1.816653] i2c /dev entries driver
[    1.823092] ledtrig-cpu: registered to indicate activity on CPUs
[    1.829737] TCP: cubic registered
[    1.833092] NET: Registered protocol family 17
[    1.838762] registered taskstats version 1
[    1.844489] USB Power: 5000 mV
[    1.848242] HDD Power: 5000 mV
[    1.851977] rtc-mv f1010300.rtc: setting system clock to 2017-08-24 08:08:43 UTC (1503562123)
[    1.861833] PM: Hibernation image not present or could not be loaded.
[    1.863412] Freeing unused kernel memory: 276K (c0542000 - c0587000)
[    1.929910] systemd-udevd[39]: starting version 215
[    1.945962] random: systemd-udevd urandom read with 1 bits of entropy available
[    2.042213] input: gpio_keys as /devices/gpio_keys/input/input0
[    2.197168] libphy: orion_mdio_bus: probed
[    2.237765] usbcore: registered new interface driver usbfs
[    2.272293] mv643xx_eth: MV-643xx 10/100/1000 ethernet driver version 1.4
[    2.287591] SCSI subsystem initialized
[    2.291560] usbcore: registered new interface driver hub
[    2.307000] platform mv643xx_eth_port.0: Driver mv643xx_eth_port requests probe deferral
[    2.326273] usbcore: registered new device driver usb
[    2.364358] platform mv643xx_eth_port.0: Driver mv643xx_eth_port requests probe deferral
[    2.377956] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    2.405214] libata version 3.00 loaded.
[    2.420253] sata_mv f1080000.sata: version 1.28
[    2.420501] sata_mv f1080000.sata: slots 32 ports 1
[    2.436920] mv643xx_eth_port mv643xx_eth_port.1 eth0: port 0 with MAC address 00:24:a5:2d:41:fc
[    2.448231] ehci-orion: EHCI orion driver
[    2.491681] platform mv643xx_eth_port.0: Driver mv643xx_eth_port requests probe deferral
[    2.505798] scsi0 : sata_mv
[    2.518904] ata1: SATA max UDMA/133 irq 21
[    2.542171] platform mv643xx_eth_port.0: Driver mv643xx_eth_port requests probe deferral
[    2.550467] orion-ehci f1050000.ehci: EHCI Host Controller
[    2.564379] orion-ehci f1050000.ehci: new USB bus registered, assigned bus number 1
[    2.596319] orion-ehci f1050000.ehci: irq 19, io mem 0xf1050000
[    2.635391] orion-ehci f1050000.ehci: USB 2.0 started, EHCI 1.00
[    2.656892] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    2.663710] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    2.670935] usb usb1: Product: EHCI Host Controller
[    2.675825] usb usb1: Manufacturer: Linux 3.16.0-4-kirkwood ehci_hcd
[    2.682182] usb usb1: SerialNumber: f1050000.ehci
[    2.753581] hub 1-0:1.0: USB hub found
[    2.763510] hub 1-0:1.0: 1 port detected
[    2.770385] platform mv643xx_eth_port.0: Driver mv643xx_eth_port requests probe deferral
[    2.794604] platform mv643xx_eth_port.0: Driver mv643xx_eth_port requests probe deferral
[    5.355354] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl F300)
[    5.391383] ata1.00: ATA-8: WDC WD10EADS-00L5B1, 01.01A01, max UDMA/133
[    5.398007] ata1.00: 1953525168 sectors, multi 0: LBA48 NCQ (depth 31/32)
[    5.419396] ata1.00: configured for UDMA/133
[    5.424286] scsi 0:0:0:0: Direct-Access     ATA      WDC WD10EADS-00L 1A01 PQ: 0 ANSI: 5
[    5.509887] sd 0:0:0:0: [sda] 1953525168 512-byte logical blocks: (1.00 TB/931 GiB)
[    5.517865] platform mv643xx_eth_port.0: Driver mv643xx_eth_port requests probe deferral
[    5.527934] sd 0:0:0:0: [sda] Write Protect is off
[    5.532760] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[    5.532995] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    5.591021]  sda: sda1 sda2 sda3 sda4 sda5 sda6
[    5.602276] sd 0:0:0:0: [sda] Attached SCSI disk
[   19.689210] mv643xx_eth_port mv643xx_eth_port.1 eth0: link up, 1000 Mb/s, full duplex, flow control disabled
[   84.851103] random: nonblocking pool is initialized
[  296.006680] ext4: Unknown symbol setattr_prepare (err 0)
[  296.025863] ext4: Unknown symbol posix_acl_update_mode (err 0)
[  296.038093] fat: Unknown symbol setattr_prepare (err 0)
[  296.151428] ext4: Unknown symbol setattr_prepare (err 0)
[  296.160030] ext4: Unknown symbol posix_acl_update_mode (err 0)
[  296.179776] ext4: Unknown symbol setattr_prepare (err 0)
[  296.188398] ext4: Unknown symbol posix_acl_update_mode (err 0)
[  296.806755] device-mapper: uevent: version 1.0.3
[  296.810215] device-mapper: ioctl: 4.27.0-ioctl (2013-10-30) initialised: dm-devel@redhat.com


u-boot env:

Code: Select all
1: [baudrate=115200]
2: [loads_echo=0]
3: [ipaddr=192.168.11.150]
4: [serverip=192.168.11.1]
5: [rootpath=/mnt/ARM_FS/]
6: [netmask=255.255.255.0]
7: [eth1addr=00:24:A5:2D:41:FC]
8: [stdin=serial]
9: [stdout=serial]
10: [stderr=serial]
11: [console=console=ttyS0,115200]
12: [mainlineLinux=no]
13: [CASset=min]
14: [enaMonExt=no]
15: [enaCpuStream=no]
16: [enaWrAllo=no]
17: [pexMode=RC]
18: [disL2Cache=no]
19: [setL2CacheWT=yes]
20: [disL2Prefetch=yes]
21: [enaICPref=yes]
22: [enaDCPref=yes]
23: [sata_dma_mode=yes]
24: [MALLOC_len=1]
25: [bootargs_end=:::DB88FXX81:eth0:none]
26: [image_name=uImage]
27: [buffalo_ver=BOOTVER=0.22]
28: [kernel=uImage.buffalo]
29: [initrd=initrd.buffalo]
30: [bootcommon=setenv bootargs $console $bootargs_root $bootargs_func $buffalo_ver $mtdparts $tftpboot $nandboot; bootm 0x00100000 0x00800000]
31: [tftpbootcmd=tftp 0x00100000 $kernel; tftp 0x00800000 $initrd; setenv tftpboot tftpboot=yes; run bootcommon]
32: [idebootcmd=ext2load ide 0:1 0x00100000 /$kernel; ext2load ide 0:1 0x00800000 /$initrd; run bootcommon]
33: [bootorder=ide]
34: [bootcmd=for i in $bootorder; do run ${i}bootcmd; done]
35: [bootdelay=3]
36: [disaMvPnp=no]
37: [ethaddr=00:50:43:86:39:26]
38: [ethmtu=1500]
39: [eth1mtu=1500]
40: [mvNetConfig=mv_net_config=(00:11:88:0f:62:81,0:1:2:3),mtu=1500]
41: [usb0Mode=host]
42: [netretry=no]
43: [rcvrip=169.254.100.100]
44: [loadaddr=0x02000000]
45: [autoload=no]
46: [enaAutoRecovery=yes]
47: [bootargs_root=root=/dev/sda2 rw panic=5]
bishop341b
 
Posts: 1
Joined: 2017-08-26 21:34

Return to Installation

Who is online

Users browsing this forum: Kyras and 10 guests

fashionable