9.1 multi-boot how-to?

Help with issues regarding installation of Debian

9.1 multi-boot how-to?

Postby MrGlasspoole » 2017-08-31 15:38

I never tried to install multiple Debian on one machine.
Since hours I'm trying and cant figure it out.
Most tutorials deal with Windows and Linux, some say GRUB does recognize the other installation, some say you need to override the first GRUB in the MBR with the second installation and others say don't override :(

On the first Debian installation in made these partitions:
5 ext4 logical
6 ext4 logical
7 ext4 logical
8 swap

I did set "Mount point" to "/" on 5. And write GRUB to the MBR.

On the second Debian installation i did set "Mount point" to "/" on 6.
Then comes GRUB and i see one Debian 9 installation.
But no matter if i install GRUB again to the MBR or cancel the installation, something is always messed up and if i try to boot i get all kind of funny things (errors).
On the boot screen the first installation is doing something that needs 1.30 Minutes:
Code: Select all
A start job is running for dev-disk-by\some_letters_numbers.dev


Is there a step by step? I need 3 Debian (no GUI) installations on one machine, so i can switch for testing.
Why is it so hard to dual-boot Linux :(
MrGlasspoole
 
Posts: 13
Joined: 2012-12-22 21:34

Re: 9.1 multi-boot how-to?

Postby srq2625 » 2017-08-31 16:22

Most (all) Windows/Linux multi-boot tutorials suggest that Windows be installed first and the Linux be installed second.

In my experience, Linux/Linux multi-boot is much the same. I let each subsequent install write/update GRUB. This causes each Linux install to be included.

Anyway, the long and the short of it is to treat the first Linux install as one would the Windows install in those tutorials, placing GRUB on the first drive in the boot sequence.
srq2625
 
Posts: 41
Joined: 2016-02-26 11:01

Re: 9.1 multi-boot how-to?

Postby MrGlasspoole » 2017-08-31 16:42

As i wrote i tried that and get the:
Code: Select all
A start job is running for dev-disk-by\some_letters_numbers.dev

that takes 1 minute and 30 seconds if i boot my first installation.
MrGlasspoole
 
Posts: 13
Joined: 2012-12-22 21:34

Re: 9.1 multi-boot how-to?

Postby Dai_trying » 2017-08-31 19:46

This is most likely due to the swap partition being reformatted during your second installation, it is quite a common problem with multi-booting linux. To solve this you can change the entry in fstab which refers to the swap partition with the correct UUID (this gets changed when formatting it)

To get the UUID you can type

Code: Select all
sudo blkid | grep swap

this will give you the UUID which you must use, then go into fstab

Code: Select all
sudo nano /etc/fstab

and from there you can insert the correct UUID in place of the old one in the line that mounts swap which will look something like this

Code: Select all
UUID=ab123c45-de6f-7ghi-j890-1234klmno5p6       swap                    swap    sw                      0       0


When you reboot you should no longer have the 90 second delay.

HTH
Dai_trying
 
Posts: 332
Joined: 2016-01-07 12:25

Re: 9.1 multi-boot how-to?

Postby MrGlasspoole » 2017-08-31 23:58

Thanks Dai_trying!
That did it and in no tutorial i did see this mentioned.

But why is it so complicated in Linux in 2017?
MrGlasspoole
 
Posts: 13
Joined: 2012-12-22 21:34

Re: 9.1 multi-boot how-to?

Postby Bulkley » 2017-09-01 01:27

MrGlasspoole wrote:But why is it so complicated in Linux in 2017?


The usual answer to such a question is that someone solved one problem by creating another.
Bulkley
 
Posts: 5330
Joined: 2006-02-11 18:35

Re: 9.1 multi-boot how-to?

Postby Dai_trying » 2017-09-01 06:23

I wouldn't say it is particularly complicated, but the 90 second delay while looking for the (swap) UUID that does not exist is caused by the fact that most distro's format the swap partition when they install, I have learned to check the partitioning options when installing any distro (as I sometimes have 5 or 6 different ones on any given machine) to make sure swap is not formatted, and usually have to manually insert a swap entry to fstab on a fresh install because to disable formatting of swap partition you have to tell the installer not to use swap.
It's just one of the things I have learned to check before committing to install and have had no issues (unless I forget to check) so far.
Dai_trying
 
Posts: 332
Joined: 2016-01-07 12:25

Re: 9.1 multi-boot how-to?

Postby alan stone » 2017-09-01 07:57

MrGlasspoole wrote:That did it and in no tutorial i did see this mentioned.

FYI, it's mentioned here - though I concur, not obvious to find when not knowing what causes the problem.
Debian 8.9 32bit, WM: Openbox
Computers are like air conditioners. They work fine until you start opening windows. - Author Unknown
Programming is like sex. One mistake and you have to support it for the rest of your life. - Michael Sinz
User avatar
alan stone
 
Posts: 211
Joined: 2011-10-22 14:08
Location: In my body.

Re: 9.1 multi-boot how-to?

Postby sunrat » 2017-09-01 22:14

If something is delaying the start process, journalctl is your friend.
First time I ran into the changed UUID swap problem I didn't know what was causing it. journalctl highlighted it instantly.

Code: Select all
journalctl -b -p 3
will show errors for the current boot,
Code: Select all
journalctl -b -1 -p 3
for the previous boot. You can change the p value for more or less severe errors, p = priority.

see man journalctl for more info.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 2041
Joined: 2006-08-29 09:12
Location: Melbourne, Australia


Return to Installation

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable