Cannot change keyboard/console language permanently

Help with issues regarding installation of Debian

Cannot change keyboard/console language permanently

Postby mabra » 2017-09-09 02:17

Hi !
I need some understanding, what is behind the stuff.
I am using debian stretch, installed from netinst.iso and then runned a changeroot setup onto another partition (with zfs).
I am always using UTF-8 as system locale and provide two german locales too.
If your are installing a desktop, erything looks right - but not from netinst or from chroot install.
I have installed the locales, the console-date and the keyboard configuration and trie to configure
both. This works in some way and changes the keyboard on the fly, until I login - then english layout
is back.

I'll have never and will never (in a first step) touch files or environment variables - I have never needed
this. There must be commands to do this.
I swaw tips on changing files and compared these to a working machine. They do not exist
on my machines, where everything is right - so no reason touch some files (in a first glance).

When I get the keyboard working, I am doing a "update-initramfs -u -k all" befor I reboot.

Any help, which explains the dependencies would be really very welcome!

Thanks anyway,
Manfred
User avatar
mabra
 
Posts: 77
Joined: 2010-10-16 16:53

Re: Cannot change keyboard/console language permanently

Postby pylkko » 2017-09-09 04:14

Please post the output of:
Code: Select all
 localectl status

And
Code: Select all
localectl list-keymaps
User avatar
pylkko
 
Posts: 1113
Joined: 2014-11-06 19:02

Re: Cannot change keyboard/console language permanently

Postby mabra » 2017-09-09 13:37

Hello,

and thanks for your reply!

pylkko wrote:Please post the output of:
Code: Select all
 localectl status

And
Code: Select all
localectl list-keymaps


Code: Select all
$ localectl status
   System Locale: LANG=en_US.UTF-8
       VC Keymap: de-latin1
      X11 Layout: de
       X11 Model: pc105
     X11 Options: lv3:ralt_switch,terminate:ctrl_alt_bksp

Will note again: I have (currently) NO X installed.
Code: Select all
$ localectl list-keymaps
Couldn't find any console keymaps.

The wonder is the second, I assume. I do not know, why this is!
Note: Made both from a ssh session - not sure, if this gives a difference. I say that,
because via ssh, I never had this problem!
Ann.Just to be sure (the server is not in my living rooms): Same at the console directly.
Code: Select all
$ apt-cache policy console-setup
console-setup:
  Installed: (none)
  Candidate: 1.164
  Version table:
     1.164 990
        990 http://httpredir.debian.org/debian stretch/main amd64 Packages

Is it this, what I am missing?

Regards,
Manfred
User avatar
mabra
 
Posts: 77
Joined: 2010-10-16 16:53

Re: Cannot change keyboard/console language permanently

Postby debiman » 2017-09-10 10:53

so you want german locale?

reading
Code: Select all
man localectl
i see:
Code: Select all
set-locale LOCALE...
Set the system locale. This takes one or more assignments such as "LANG=de_DE.utf8", "LC_MESSAGES=en_GB.utf8", and so on. See locale(7) for details on the available settings and their meanings. Use list-locales for a list of available locales (see below).

list-locales
List available locales useful for configuration with set-locale.
since your keymap appears to be correct already, those two commands should help.
use with sudo or su.
User avatar
debiman
 
Posts: 1341
Joined: 2013-03-12 07:18


Return to Installation

Who is online

Users browsing this forum: No registered users and 12 guests

fashionable