Help with i-nex installation

Help with issues regarding installation of Debian

Help with i-nex installation

Postby Motas652 » 2017-09-12 19:05

Hi,
I need a help please with installing i-nex.
I followed the steps in the read me file but I am getting an error message. I did a google search, youtube but found no answer.


Please assist.

Commands I used. (Reference https://github.com/i-nex/I-Nex)
git clone https://github.com/eloaders/I-Nex.git
cd ./I-Nex && \
fakeroot debian/rules build && \
fakeroot debian/rules binary && \
cd .. && \
sudo dpkg -i ./i-nex*.deb

Message shown on command line:
mutamadsha@kali:~/I-Nex$ fakeroot debian/rules binary && \
> cd .. && \
> sudo dpkg -i ./i-nex*.deb
dh binary --with autoreconf
make: dh: Command not found
debian/rules:18: recipe for target 'binary' failed
make: *** [binary] Error 127
mutamadsha@kali:~/I-Nex$



Thank you.
Motas652
 
Posts: 1
Joined: 2017-09-12 07:59

Re: Help with i-nex installation

Postby arochester » 2017-09-12 19:23

mutamadsha@kali


Kali Linux Forums >>> https://forums.kali.org/
"Something to be aware of: Debian is a core or source distribution. This means there are many Debian-based distributions. THEY ARE NOT DEBIAN."
arochester
 
Posts: 1090
Joined: 2010-12-07 19:55

Re: Help with i-nex installation

Postby stevepusser » 2017-09-12 19:41

https://build.opensuse.org/package/show ... -nex/i-nex

Wait, why did it fail on the i386 Stretch build only? Let me trigger a rebuild and see what happens...OK, built.

make: dh: Command not found


Usually is because you don't have Debian packaging tools installed, debhelper in particular. Those instructions are very incomplete, and are useless. My builds at least also need to build against a "libcpuid" package that is not in Debian or Ubuntu, so I have to have that in my i-nex repo also. Manual builders need to build libcpuid first and then install it and its -dev package before installing all of i-nex's other build-deps.

If you are indeed using Kali, that's not the platform to learn on. Here is some Kali boilerplate I copied off Reddit:

Kali Linux is an incredibly specialized and notably unsafe distro designed to be used in a live environment by an incredibly small group of very technically savvy people. You are not part of this group. It is NOT Debian. Please do not use Kali Linux.

f you're interested in any of the tools Kali includes, they can be installed on basically any normal Linux distro.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Krita 3.3.2.1, Pale Moon 27.6.0, Audacity 2.2.0, mpv 0.27.0, Corebird 1.7.1, Firefox 57.0, SMPlayer 17.11.2
User avatar
stevepusser
 
Posts: 8905
Joined: 2009-10-06 05:53

Re: Help with i-nex installation

Postby debiman » 2017-09-14 18:16

i-nex = vanity software

also i once tried to install it and realised it's buggy/sluggish beyond usability.

why, oh why?

use inxi instead.
User avatar
debiman
 
Posts: 1545
Joined: 2013-03-12 07:18


Return to Installation

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable