[RESOLVED] ... EG1032 v3 Not Detected by 9.1 i386 Netinst CD

Help with issues regarding installation of Debian

[RESOLVED] ... EG1032 v3 Not Detected by 9.1 i386 Netinst CD

Postby tanstaafl-tanj » 2017-09-27 14:46

i have an old e-Machines PC with an AMD Athlon XP 2500+ CPU (from /proc/cpuinfo) and a Linksys EG1032 v3 Instant Gigabit Desktop Network Adapter (according to WinXP, with which machine originally came installed). i used gparted to squeeze down the WinXP partition and booted the "debian-9.1.0-i386-netinst.iso" CD, but it was unable to detect the EG1032. i googled a bit and found that Linksys had changed the v3 version to use the Realtek 8169s chipset, and people back in 2005 or so had success re-compiling the kernel, so figuring that the 9.1 debian kernel already had the necessary fix, i tried using the Realtek 8169 module, but the loader still couldn't detect the card. i then finished installing from the netinst CD, then shut down and booted with a KNOPPIX 7.2 CD, and it had no problem finding the card as eth0 and connecting to the network.

next, i tried to find specific information about the card on debian.org, but struck out. i then tried to find something here, but the latest post about the card here is 12 years old and more than 2 major kernel versions ago. ordinarily, i would bite the bullet and try recompiling the kernel (which i've never done), but i have other things to do, and a friend is waiting for me to get this machine working, so i'm asking for help. does anybody know why the netinst can't find this old card?
Last edited by tanstaafl-tanj on 2017-10-02 20:00, edited 1 time in total.
tanstaafl-tanj
 
Posts: 3
Joined: 2017-09-27 13:21
Location: eastern north america

Re: Linksys EG1032 v3 Not Detected by Debian 9.1 i386 Netins

Postby p.H » 2017-09-27 15:21

What does "lspci -nn" print about the ethernet adapter ?
p.H
 
Posts: 160
Joined: 2017-09-17 07:12

Re: Linksys EG1032 v3 Not Detected by Debian 9.1 i386 Netins

Postby tanstaafl-tanj » 2017-09-28 15:42

OK, this might be a hardware problem; KNOPPIX 7.2 no longer finds eth0, and the same thing that shows up in lspci for debian base is what shows up for KNOPPIX 7.2 (BTW, i'm using KNOPPIX 7.2 because the DVD drive isn't working correctly). i'll open up the box and see what i can do, then report back here.

thank u for the quick response!
tanstaafl-tanj
 
Posts: 3
Joined: 2017-09-27 13:21
Location: eastern north america

Re: Linksys EG1032 v3 Not Detected by Debian 9.1 i386 Netins

Postby arochester » 2017-09-28 15:51

It might be quicker and easier to change the card for another...
"Something to be aware of: Debian is a core or source distribution. This means there are many Debian-based distributions. THEY ARE NOT DEBIAN."
arochester
 
Posts: 1089
Joined: 2010-12-07 19:55

Re: Linksys EG1032 v3 Not Detected by Debian 9.1 i386 Netins

Postby stevepusser » 2017-09-28 22:21

Some related Realtek NICs require non-free firmware: https://packages.debian.org/stretch/firmware-realtek

You could try an ISO image which contains the non-free firmware.

Are there any missing firmware messages when you run as sysadmin:
Code: Select all
dmesg|grep -Ei 'wlan|firmw|dhc'
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Krita 3.3.2.1, Pale Moon 27.6.0, Audacity 2.2.0, mpv 0.27.0, Corebird 1.7.1, Firefox 57.0, SMPlayer 17.11.2
User avatar
stevepusser
 
Posts: 8905
Joined: 2009-10-06 05:53

Re: Linksys EG1032 v3 Not Detected by Debian 9.1 i386 Netins

Postby tanstaafl-tanj » 2017-10-02 19:58

OK, it was a hardware problem; the card had been loosened, then fastened back down with a huge dustbunny insulating the PCI connection. after applying a little vacuum, all is now OK.

thanks to all for your assistance!
tanstaafl-tanj
 
Posts: 3
Joined: 2017-09-27 13:21
Location: eastern north america


Return to Installation

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable