Grub install failure with intel compute stick

Help with issues regarding installation of Debian

Grub install failure with intel compute stick

Postby ljones0 » 2017-11-08 15:41

Hello!

First of all (and rather than type of lots of stuff which really isn't relevent) and although I wouldn't personally want/buy one of these devices myself I have recently just been given an unwanted device -- it's an intel compute stick STCK1A8LFC . That's one of the older devices with the awful bay/cherry trail; mine was a 1GB (RAM) unit complete with a working (but ancient) version of ubuntu. So naturally I decided to give debian a try.....( btw, I can confirm the stick is working as the older ubuntu was running ok).

Unfortunatly though the installation process never seems to complete. Although this devices' wifi chipset does not work with debian (from what I read it is a PITA anyway) I am able to use a usb hub and connect to the internet using a usb device.

Partitioning (which I do manually) seems to work, as does the software installation. But the problem hits when the installer tries to install grub. I get this error screen.

Code: Select all
"Executing grub-install dummy failed"


I then dropped out to a command line and tried to find out what was going on. this was the answer.

Code: Select all
blk_update_request: I/O error, dev mmcblk1rpmb, sector 0


That made me think that I had in some way killed the flash memory on the device. So I then downloaded - just to test - the latest ubuntu version (x86-64, 16.04-3). And apart from getting the EFI files in the wrong place (it put them in /efi/ubuntu; the stick expects /efi/boot) it did not have any problems with grub.

And then I found this which seems to be related. In particular this line from the post:

Code: Select all
kernel: blk_update_request: I/O error, dev mmcblk1rpmb, sector 0


From what I can gather - and this is just a guess(!) the debian installer is trying to install grub to the wrong place. It shouldn't be going to /dev/mmcblk1rpmb - it should really be going to /dev/mmcblk1 ! I did also try specifiying "systemd.gpt_auto=0" as per that post on that website though it didn't seem to make any difference.

Has anyone experienced or seen this problem before?

For now, I've created a workaround by pinching ubuntu's EFI grub files, putting them in /efi/boot (via the debian installer recovery option, and then to a command line) and then doing in the grub command line :

Listing of /dev/mmc* via debain installer command line:
Code: Select all
/dev/mmcblk1
/dev/mmcblk1boot0
/dev/mmcblk1boot1
/dev/mmcblk1p1
/dev/mmcblk1p2
/dev/mmcblk1rpmb


"rpmb" apparently stands for "Replay Protected Memory Block" according to this website. Don't think grub should be going there!

Code: Select all
ls
(my 'root' is hd0,gpt2)

set root=(hd0,gpt2)
linux /boot/vmlinuz-4.12.0-1-amd64 root=/dev/mmcblk1p2
initrd /boot/initrd.img-4.12.0.1-amd64
boot


That then boots. But why would grub get installed to the wrong place?

ljones
ljones0
 
Posts: 67
Joined: 2013-03-30 22:51

Return to Installation

Who is online

Users browsing this forum: No registered users and 2 guests

fashionable