9.2.1 boot fails to find cpu0 device

Help with issues regarding installation of Debian

9.2.1 boot fails to find cpu0 device

Postby giul51 » 2017-11-10 14:25

I installed the latest version of Stretch i686 , into a clean partition, on my desktop
MB ASUS A7V600-X, Athlon XP 2400, ATI Radeon 9200.
In another partition I have Jessie installed, which is working fine.

When I booted on Stretch, through the new grub2 installed on the MBR, I got an error
about a wrong "metadata_csum" and the boot hanged, and could not access the other OS's.

Booting on Jessie (thanks to supergrub2 disk) and reconstructing grub from there, when trying to
boot on Stretch, I get the error
"failed to find cpu0 device node"
after which the boot continues for a while and finally hangs
with a black screen just after showing "root login ..".

I tried to re-install changing some options about drivers and arch (i586), but no difference.
Googling around I could not find understandable information about what "cpu0 node" might imply, and so
whether it is a matter of settings, of a bug, or what else, nor what is the change from Jessie to Stretch that causes problems for my architecture.
------ update -------
Trying again to boot on the installed Stretch, always arriving to the black screen, I realized I could login on tty2 (CTRL+ALT+F2), so I could activate dmesg. Trying to start KDE, I got an immediate stop on error.
Looking at /var/log/ I found a .xsession-errors where, among many others, it is stated that kdeinit crashed and the reason (as far as I can understand) seems to be:
"QStandardPaths: wrong ownership on runtime directory /run/user/1000, 1000 instead of 0"
(I can attach the file if requested)
So, I was curious to see if the problem was limited to KDE desktop, and re-installed choosing Gnome.
Same result, with the only difference that on the dark page a pointer appears and nothing else. But the login through tty2 in this case does not work, because the dark page continuously alternates with the boot screen, where it seems that some process is continuosly trying to access something ....
So actually, the mis-functioning looks not to be much related to cpu0 device (?).

Thanks for providing any suggestion, hint.
Last edited by giul51 on 2017-11-11 18:32, edited 2 times in total.
Posts: 11
Joined: 2016-02-20 19:52

Re: 9.2.1 boot fails to find cpu0 device

Postby arochester » 2017-11-11 12:02

Stretch i686

AMD64 or i386 >>> https://www.debian.org/releases/stable/installmanual

Have you installed 32 bit on a 64 bit computer?
Posts: 1349
Joined: 2010-12-07 19:55

Re: 9.2.1 boot fails to find cpu0 device

Postby giul51 » 2017-11-11 16:20

No, I did not do that.
My computer is an old 32 bit, and I installed Stretch 32 bit (i386).
During installation, for the kernel, you are then given the choice among 586 and 686 (with or without PAE)
and I tried both but no success.
Today I also tried to re-install changing the desktop choice from KDE to Gnome, but same problem.
I realized that in both cases I can log into tty2 (CTRL+ALT+F2), but cannot start KDE or X
Posts: 11
Joined: 2016-02-20 19:52

Return to Installation

Who is online

Users browsing this forum: No registered users and 6 guests