Set BIOS to defaults lost boot manager

Help with issues regarding installation of Debian

Set BIOS to defaults lost boot manager

Postby elton-w » 2017-12-01 05:10

Device (usually) dual boots Windows 10, and Debian Stretch being the default. Correcting system time in the BIOS, and (unfortunately) reset to defaults. Machine now it boots to Windows 10 only instead of going to Debian as the default partition. :oops:
I'm rather new to Debian. It had been installed by several people during an install-fest this past summer.

Almost everything is backed up, but I would rather not do a fresh install ...escept as a last resort.
Is there some way I can recover the boot-manage'?

If memory serves me right, there are 10 partitions on the device of which dev/sda8 and /dev/sda9 being the / and swap partitions respectively. I do have the usb stick (Stretch installer) was given given out during the Conference.
Machine specs: Lenovo G-50-45, AMD, 4 Gb RAM, 500 Gb hard drive.

Assistance and guidance woud be most appreciated.

[please excuse any typos, as my vision is not ...good)
...respectfully...
Registered Linux User #193975-85134
elton-w
 
Posts: 33
Joined: 2017-10-15 18:57
Location: Montréal, Québec, CANADA

Re: Set BIOS to defaults lost boot manager

Postby bw123 » 2017-12-01 05:45

It's probably this:
https://wiki.debian.org/UEFI

My advice is read until you kinda understand, then take a chance at finding the right bios settings. Don't try to repair it from the other os.
User avatar
bw123
 
Posts: 2454
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Set BIOS to defaults lost boot manager

Postby pylkko » 2017-12-01 06:08

If you lost the link from the firmware to the root partition of the OS, but you know where it is, then fixing this should be pretty easy as most implementations of UEFI allow you to browse the computer and attached devices for booting. If you are not sure where the right partitions recides, but you have a bootable USB stick, what you can do is boot into that USB OS and from there list the partitions using tools like "lsblk". The USB stick OS (Debian) will most likely already have (or allow you to install) efibootmgr, a tool that allows you to manipulate the UEFI values from linux. This does not sound like it requires a reinstall at all. However, I am not 100% certain I got you right.

EDIT: typo in efibootmgr
Last edited by pylkko on 2017-12-01 21:00, edited 1 time in total.
User avatar
pylkko
 
Posts: 1212
Joined: 2014-11-06 19:02

Re: Set BIOS to defaults lost boot manager

Postby Head_on_a_Stick » 2017-12-01 06:34

Load up a "live" ISO image with UEFI support and post the full output of these commands:
Code: Select all
# parted --list
# efibootmgr -v

Thanks!
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 6784
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Set BIOS to defaults lost boot manager

Postby elton-w » 2017-12-01 17:52

...a quick "thank you" to all who responded, in acknowledgement. I am now looking mong my usb sticks to find a bootable one: I should have ether the Debian one or a Mint linux 16 nearby I'll be swithng between this Lenovo and another Widows to machine as respond, so please bear with me!
Registered Linux User #193975-85134
elton-w
 
Posts: 33
Joined: 2017-10-15 18:57
Location: Montréal, Québec, CANADA

Re: Set BIOS to defaults lost boot manager

Postby Head_on_a_Stick » 2017-12-01 17:53

I can make some sense of this command output from Windows:
Code: Select all
bcdedit

EDIT: that output is roughly analogous to the `efibootmgr -v` command.
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 6784
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Set BIOS to defaults lost boot manager

Postby elton-w » 2017-12-01 18:26

Head_on_a_Stick wrote:I can make some sense of this command output from Windows:
Code: Select all
bcdedit

EDIT: that output is roughly analogous to the `efibootmgr -v` command.

I have now managed with a Mint Linux 16 stick, loaded frefox.and logged into this forum on the very same Lenovo.
so from the console, I get:
Code: Select all
mint@mint ~ $ parted --list
mint@mint ~ $ efibootmgr -v
BootCurrent: 0005
Timeout: 0 seconds
BootOrder: 0008,0003,0002,2001,2003,0000,2002
Boot0000* Lenovo Recovery System   HD(3,GPT,e24a9fff-6b2f-42fc-9661-9f16299a3d6f,0x276800,0x1f4000)/File(\EFI\Microsoft\Boot\LrsBootMgr.efi)RC
Boot0001* EFI Network 0 for IPv4 (68-F7-28-C8-58-8B)    PciRoot(0x0)/Pci(0x2,0x4)/Pci(0x0,0x0)/MAC(68f728c8588b,0)/IPv4(0.0.0.0:0<->0.0.0.0:0,0,0)RC
Boot0002* ubuntu   HD(3,GPT,e24a9fff-6b2f-42fc-9661-9f16299a3d6f,0x276800,0x1f4000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0003* Windows Boot Manager   HD(2,GPT,0cc859a4-1d2b-4cbb-a8dc-0f66f78adabb,0x1f4800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot0004* EFI Network 0 for IPv6 (68-F7-28-C8-58-8B)    PciRoot(0x0)/Pci(0x2,0x4)/Pci(0x0,0x0)/MAC(68f728c8588b,0)/IPv6([::]:<->[::]:,0,0)RC
Boot0005* EFI USB Device (USB DISK 2.0)   PciRoot(0x0)/Pci(0x10,0x0)/USB(2,0)/HD(1,MBR,0x59,0x355a6c,0x1280)RC
Boot0008* debian   HD(2,GPT,0cc859a4-1d2b-4cbb-a8dc-0f66f78adabb,0x1f4800,0x82000)/File(\EFI\debian\grubx64.efi)
Boot2001* EFI USB Device   RC
Boot2002* EFI DVD/CDROM   RC
Boot2003* EFI Network   RC
mint@mint ~ $


I don't seem to be getting any result with the "psrted" command
Registered Linux User #193975-85134
elton-w
 
Posts: 33
Joined: 2017-10-15 18:57
Location: Montréal, Québec, CANADA

Re: Set BIOS to defaults lost boot manager

Postby elton-w » 2017-12-01 18:27

whoops ..."parted" command, I mean...
Registered Linux User #193975-85134
elton-w
 
Posts: 33
Joined: 2017-10-15 18:57
Location: Montréal, Québec, CANADA

Re: Set BIOS to defaults lost boot manager

Postby Head_on_a_Stick » 2017-12-01 18:36

Try
Code: Select all
/sbin/parted --list

(as root)

The `efibootmgr` output claims that Debian's GRUB .efi loader is set as the default.

Have you disabled Secure Boot?

Is Debian's grubx64.efi loader actually present on the EFI system partition?
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 6784
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Set BIOS to defaults lost boot manager

Postby elton-w » 2017-12-01 18:53

additional info: I'm now running in a Mnnt Lmux 16 "live session" ans am able to run gparted. CORRECIOT to my original post, there are 9 partitions in all.
The debian partitions are /dev/sda9 mounted as "/", with /dev/sda8 being the 4 Gb swap partition
Registered Linux User #193975-85134
elton-w
 
Posts: 33
Joined: 2017-10-15 18:57
Location: Montréal, Québec, CANADA

Re: Set BIOS to defaults lost boot manager

Postby elton-w » 2017-12-01 19:05

parted -l gives me:
Code: Select all
mint@mint ~ $ sudo parted -l
Model: ATA WDC WD5000LPCX-2 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number  Start   End     Size    File system     Name                          Flags
 1      1049kB  1050MB  1049MB  ntfs            Basic data partition          hidden, diag
 2      1050MB  1322MB  273MB   fat32           EFI system partition          boot, hidden, esp
 3      1322MB  2371MB  1049MB  fat32           Basic data partition          hidden
 4      2371MB  2505MB  134MB                   Microsoft reserved partition  msftres
 5      2505MB  42.5GB  40.0GB  ntfs            Basic data partition          msftdata
 9      42.5GB  456GB   414GB   ext4
 8      456GB   460GB   4000MB  linux-swap(v1)
 6      460GB   487GB   26.8GB  ntfs            Basic data partition          msftdata
 7      487GB   500GB   13.1GB  ntfs            Basic data partition          hidden, diag


Warning: The driver descriptor says the physical block size is 2048 bytes, but
Linux says it is 512 bytes.
Ignore/Cancel? i                                                         
Model:  USB DISK 2.0 (scsi)
Disk /dev/sdb: 32.1GB
Sector size (logical/physical): 2048B/512B
Partition Table: mac
Disk Flags:

Number  Start   End     Size    File system  Name   Flags
 1      2048B   6143B   4096B                Apple
 2      1790MB  1793MB  2425kB               EFI


mint@mint ~ $
Registered Linux User #193975-85134
elton-w
 
Posts: 33
Joined: 2017-10-15 18:57
Location: Montréal, Québec, CANADA

Re: Set BIOS to defaults lost boot manager

Postby elton-w » 2017-12-01 19:14

Head_on_a_Stick wrote:Try
Code: Select all
/sbin/parted --list

(as root)

The `efibootmgr` output claims that Debian's GRUB .efi loader is set as the default.

Have you disabled Secure Boot?

Is Debian's grubx64.efi loader actually present on the EFI system partition?

Perhaps I did that when I was i the BIOS settings? Oddly, I seem to be able to find the correct boot image when using the Mint Lnux, but I can's seem to find my my way with the Debian stick which complains ...something to the effect that I should turn off secure boor?
Registered Linux User #193975-85134
elton-w
 
Posts: 33
Joined: 2017-10-15 18:57
Location: Montréal, Québec, CANADA

Re: Set BIOS to defaults lost boot manager

Postby Head_on_a_Stick » 2017-12-01 19:21

elton-w wrote:I should turn off secure boot

^ This.
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 6784
Joined: 2014-06-01 17:46
Location: /dev/chair

[SOLVED]: Set BIOS to defaults lost boot manager

Postby elton-w » 2017-12-01 20:43

Head_on_a_Stick wrote:
elton-w wrote:I should turn off secure boot

^ This.

This is now solved, and perhaps explains why I couldn't boot the "Stretch" memory stick, ...once again it resets to FOUR HOURS AHEAD in Widows. On this Lenovo G50-45, the problem is consistent, and persists, despite a firmware upgrade, and upgrading from Win. 8.1 to 10.
No such problem with any of my other machines running Windows.

I'll just live with the constant aggravation of re-setting the clock with each boot to Windows :x

Again, thank you for your help :!:
Registered Linux User #193975-85134
elton-w
 
Posts: 33
Joined: 2017-10-15 18:57
Location: Montréal, Québec, CANADA

Re: Set BIOS to defaults lost boot manager

Postby bw123 » 2017-12-01 21:12

once again it resets to FOUR HOURS AHEAD in Widows


Wow, that brings back memories. On win2k and xp I eventually gave up and just told windows I was in UTC time. The clock was always wrong but grand theft auto 3 didn't care.

This is now solved,


Good job.
User avatar
bw123
 
Posts: 2454
Joined: 2011-05-09 06:02
Location: TN_USA

Next

Return to Installation

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable