Black Screen and System unresponsive after Suspend

Help with issues regarding installation of Debian

Black Screen and System unresponsive after Suspend

Postby AppleCookies » 2018-01-06 11:47

Decided to post here to attain more visibility.

So this is a problem that is frustrating me quite a bit. I do a net Install of Debian 9.3, no matter the desktop environment or at what point in time I suspend the PC, when I bot it back up the monitor goes black like it has no signal.

I had got around this problem by using sgfxi to install the nvidia distro drivers, with the proprietary drivers I could leave the pc in Suspend or hibernate all day long and this problem wouldn't verify at all.
Although since I wanna move the SSD to an enclosure so that I can carry it around and plug it inside different PCs, I can't install proprietary drivers.

Now it would have been cool if sgfxi would have removed the proprietary drivers and brought back the initial drivers which allowed me to plug the system in different PCs without issues, indeed it does offer an option sgfxi -n, but unfortunately it doesn't really work as expected and gives me some lightdm error when plugged in a different pc than the one where I had installed the proprietary drivers, hence I decided to drop it.

Now although I'm left with this nasty problem that Debian just doesn't want to boot properly after a Suspend or an hibernate. It gets to a black screen like the monitor receives no signal and the system is completely unresponsive to the keyboard.

Quite sucks...
AppleCookies
 
Posts: 6
Joined: 2018-01-06 11:25

Re: Black Screen and System unresponsive after Suspend

Postby Head_on_a_Stick » 2018-01-06 13:51

AppleCookies wrote:Now although I'm left with this nasty problem that Debian just doesn't want to boot properly after a Suspend or an hibernate. It gets to a black screen like the monitor receives no signal and the system is completely unresponsive to the keyboard.

[...]

Quite sucks...

Yes, I agree, running foreign scripts (as root) does seem rather silly :mrgreen:

Try https://wiki.debian.org/NvidiaGraphicsD ... of_failure

Use systemd's journal to investigate your black screen problem:

https://www.digitalocean.com/community/ ... stemd-logs
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 7412
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Black Screen and System unresponsive after Suspend

Postby AppleCookies » 2018-01-06 14:51

Head_on_a_Stick wrote: Yes, I agree, running foreign scripts (as root) does seem rather silly :mrgreen:

Try https://wiki.debian.org/NvidiaGraphicsD ... of_failure

Use systemd's journal to investigate your black screen problem:

https://www.digitalocean.com/community/ ... stemd-logs


I actually don't recall right now if I've tried that option. Seems rather weird to me that a fresh installed Debian system has these kind of issues related to Suspend and hibernate. I will paste back what the systemd's journal outputs, since I'm forced to reboot when it happens, I hope that it won't be cleared.


Regarding the proprietary drivers:

Code: Select all
# /etc/init.d/gdm3 stop  (gdm3 for gnome 3)


According to your knowledge, isn't using...
Code: Select all
apt-get remove --purge nvidia-* to clear up conflicting nvidia packages


And

Code: Select all
#systemctl stop display-manager


...more effective?

Also I probably didn't mention this but I have a skylake build (MSIH170GamingM3 + i5-6500 + GTX970)

Also tried CentOS, same Suspend and hibernate black screen problem with no mouse or keyboard detected, + the issue that this time reboot didn't work at all and I had to force a shutdown.

I'm gonna report back the output of the systemd's journal in a bit.
AppleCookies
 
Posts: 6
Joined: 2018-01-06 11:25

Re: Black Screen and System unresponsive after Suspend

Postby Head_on_a_Stick » 2018-01-06 15:04

AppleCookies wrote:since I'm forced to reboot when it happens, I hope that it won't be cleared.

Use this command to generate persistent journal logs:
Code: Select all
# mkdir -p /var/log/journal

Or edit the relevant configuration file with reference to journald.conf(5).

AppleCookies wrote:According to your knowledge

I didn't write that page, I would never purchase hardware from Nvidia, how dare you! :x

I have a skylake build (MSIH170GamingM3 + i5-6500 + GTX970)

Oh great, another one... :roll:
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 7412
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Black Screen and System unresponsive after Suspend

Postby AppleCookies » 2018-01-06 16:02

Head_on_a_Stick wrote:
AppleCookies wrote:According to your knowledge

I didn't write that page, I would never purchase hardware from Nvidia, how dare you! :x


I mean, the two commands were just meant to stop the de and relative processes...

Head_on_a_Stick wrote:
I have a skylake build (MSIH170GamingM3 + i5-6500 + GTX970)

Oh great, another one... :roll:


Wait... seriously? :cry:

Ok Attached to this message there is the output of the Journal. I don't think it catches the part after I wake him up from suspend though... https://pastebin.com/DkqLeyRv (it didn't let me upload it by the forum feature).
AppleCookies
 
Posts: 6
Joined: 2018-01-06 11:25

Re: Black Screen and System unresponsive after Suspend

Postby Head_on_a_Stick » 2018-01-06 17:38

AppleCookies wrote:Wait... seriously? :cry:

Look into my eyes: :|

AppleCookies wrote:https://pastebin.com/DkqLeyRv

Nothing unusual there (that I can see).

I would recommend disabling the discrete GPU and trying with the Intel card instead, does that wake from suspend correctly?
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 7412
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Black Screen and System unresponsive after Suspend

Postby AppleCookies » 2018-01-06 18:04

Head_on_a_Stick wrote:I would recommend disabling the discrete GPU and trying with the Intel card instead, does that wake from suspend correctly?


I didn't try since this is a desktop PC, but it would be very weird since the issue should be with Skylake and not the gtx970 no? :?
AppleCookies
 
Posts: 6
Joined: 2018-01-06 11:25

Re: Black Screen and System unresponsive after Suspend

Postby Head_on_a_Stick » 2018-01-06 19:29

AppleCookies wrote:this is a desktop PC, but it would be very weird since the issue should be with Skylake and not the gtx970 no? :?

Well yes but it would at least help us narrow down where exactly the problem is.
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 7412
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Black Screen and System unresponsive after Suspend

Postby AppleCookies » 2018-01-06 19:32

I can try but I doubt that the problem is the GPU. Is Debian 10 going to support skylake and coffee lake?
AppleCookies
 
Posts: 6
Joined: 2018-01-06 11:25

Re: Black Screen and System unresponsive after Suspend

Postby Head_on_a_Stick » 2018-01-06 19:36

AppleCookies wrote:Is Debian 10 going to support skylake and coffee lake?

I should think so, yes but Intel cards now require firmware blobs for full performance (just like AMD).

You should be able to get Skylake working with stretch-backports (+ firmware), I would hope.
"Only the mediocre are always at their best." — Jean Giraudoux
User avatar
Head_on_a_Stick
 
Posts: 7412
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to Installation

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable