Desktop icons disappeared after upgrade

Help with issues regarding installation of Debian

Desktop icons disappeared after upgrade

Postby Moriturus » 2018-01-10 09:41

Hi,
Yesterday, I installed debian 9 (I was still on 8 ). The installation worked ok. However, since I reinstalled, my desktop does not show any icons anymore. I use Gnome3 as desktop (as I've been doing since the last two versions). The installation was clean install over /, but I kept my /home directory in a different partition. I've been using debian in my laptop acer aspire timelineU (intel i3, 4Gb of ram) since version 6. Everything has always worked perfectly and smoothly.
I've tried all what is suggested here (http://forums.debian.net/viewtopic.php?f=17&t=133931), but tweak tool and deconf-editor say that my desktop icons are visible. There are certainly many icons in the Desktop folder in my /home, but none of them appear in the Desktop.
Any help is very welcome.
Thanks
Moriturus
 
Posts: 1
Joined: 2018-01-09 19:36

Re: Desktop icons disappeared after upgrade

Postby dotlj » 2018-01-27 09:13

I'm not sure that I can help, not using Gnome and not having a Desktop directory. I prefer a menu. You may have read

https://www.debian.org/releases/stable/i386/release-notes/ch-upgrading.en.html

https://www.debian.org/releases/stretch/amd64/release-notes/ch-information.en.html

5.3.3. Desktops will migrate to libinput Xorg driver
[Note] Note

This section is only relevant if you have tweaked or need to change the default Xorg input configuration.

In jessie, the default input driver for Xorg is the evdev driver. In stretch, the default has changed to libinput. If you have Xorg configuration that relies on the evdev driver, you will either have to convert it to the libinput driver or reconfigure your system to use the evdev driver.

The following is an example configuration for libinput to enable the “Emulate3Buttons” feature.

Section "InputClass"
Identifier "mouse"
MatchIsPointer "on"
Driver "libinput"
Option "MiddleEmulation" "on"
EndSection

Insert it into /etc/X11/xorg.conf.d/41-middle-emulation.conf, reboot (or restart your Xserver) and it should now be enabled.

The evdev driver is still available in the xserver-xorg-input-evdev package.


5.3.4. Upstart removed

Due to the lack of upstream maintainers, the Upstart init system has been removed from stretch. If your system relies on this package, you should note that it will not be updated during the lifetime of Debian 9, and starting from Debian 10 (buster), Upstart jobs may be removed from packages.

Please consider switching to a supported init system, like systemd or OpenRC.


may have some clues that provide help.
User avatar
dotlj
 
Posts: 591
Joined: 2009-12-25 17:21


Return to Installation

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable
cron