[SOLVED] Can't install from backports (Stretch)

Help with issues regarding installation of Debian

[SOLVED] Can't install from backports (Stretch)

Postby -iak- » 2018-01-30 21:43

Hi everybody.

I'm on Debian Stretch and I'm trying to install Libreoffice Fresh (5.4) from the backports repository, but all I get when I run
Code: Select all
sudo apt -t stretch-backports install libreoffice
is
Code: Select all
libreoffice is already the newest version (1:5.2.7-1)


Here's my /etc/apt/sources.list:

Code: Select all
deb http://ftp.it.debian.org/debian/ stretch main contrib non-free

deb http://security.debian.org/ stretch/updates main contrib non-free
deb-src http://security.debian.org/ stretch/updates main contrib non-free

# Backports per Debian 9 (Stretch) - da testing
deb http://ftp.it.debian.org/debian/ stretch-backports main contrib non-free
deb-src http://ftp.it.debian.org/debian/ stretch-backports main contrib non-free


and here's my /etc/apt/preferences:
Code: Select all
Package: *
Pin: release a=stable
Pin-Priority: 1000

Package: *
Pin: release a=unstable
Pin-Priority: 900

Package: libfontconfig1
Pin: release a=unstable
Pin-Priority: 900

Package: fontconfig-config
Pin: release a=unstable
Pin-Priority: 900

Package: libnss3
Pin: release a=unstable
Pin-Priority: 900


I changed some values in order to make a blind attempt to solve the problem, but I kept the "unstable" priority lower than the "stable one".

Can someone please help me?

Thanks in advance.
Last edited by -iak- on 2018-02-03 14:16, edited 1 time in total.
-iak-
 
Posts: 16
Joined: 2017-10-16 17:02

Re: Can't install from backports (Stretch)

Postby arochester » 2018-01-30 21:51

Code: Select all
deb http://ftp.debian.org/debian stretch-backports main
deb-src http://ftp.debian.org/debian stretch-backports main
?
arochester
 
Posts: 1310
Joined: 2010-12-07 19:55

Re: Can't install from backports (Stretch)

Postby -iak- » 2018-01-30 22:02

Thank you arochester .
Same problem
-iak-
 
Posts: 16
Joined: 2017-10-16 17:02

Re: Can't install from backports (Stretch)

Postby bw123 » 2018-01-30 22:07

I changed some values [in /etc/apt/preferences] in order to make a blind attempt to solve the problem,


Blind attempts might not be good idea with apt. I don't use pinning myself, so I'm not sure how well that would work.
User avatar
bw123
 
Posts: 3267
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Can't install from backports (Stretch)

Postby stevepusser » 2018-01-30 22:12

What versions does apt show as available in your current sources, then?

Code: Select all
apt policy libreoffice
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: GIMP 2.10.6, Pale Moon 28.0.1, wine-staging 3.15, qBittorrent 4.1.2, Linux kernel 4.18.6, virtualbox 5.2.18
User avatar
stevepusser
 
Posts: 9899
Joined: 2009-10-06 05:53

Re: Can't install from backports (Stretch)

Postby -iak- » 2018-01-30 22:29

stevepusser wrote:What versions does apt show as available in your current sources, then?

Code: Select all
apt policy libreoffice


I see both, the stable and the unstable one. Sorry, I'm still new to Debian.

Code: Select all
apt policy libreoffice
libreoffice:
  Installato: 1:5.2.7-1
  Candidato:  1:5.2.7-1
  Tabella versione:
     1:5.4.4-1~bpo9+1 100
        100 http://ftp.debian.org/debian stretch-backports/main i386 Packages
 *** 1:5.2.7-1 1000
       1000 http://ftp.it.debian.org/debian stretch/main i386 Packages
       1000 http://deb.debian.org/debian stretch/main i386 Packages
        100 /var/lib/dpkg/status
-iak-
 
Posts: 16
Joined: 2017-10-16 17:02

Re: Can't install from backports (Stretch)

Postby stevepusser » 2018-01-30 22:42

There's another way to tell it to install an exact version. What do you get from
Code: Select all
sudo apt install libreoffice=1:5.4.4-1~bpo9+1
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: GIMP 2.10.6, Pale Moon 28.0.1, wine-staging 3.15, qBittorrent 4.1.2, Linux kernel 4.18.6, virtualbox 5.2.18
User avatar
stevepusser
 
Posts: 9899
Joined: 2009-10-06 05:53

Re: Can't install from backports (Stretch)

Postby -iak- » 2018-01-30 23:01

stevepusser wrote:There's another way to tell it to install an exact version. What do you get from
Code: Select all
sudo apt install libreoffice=1:5.4.4-1~bpo9+1


I get this:
Code: Select all
$ sudo apt install libreoffice=1:5.4.4-1~bpo9+1
[sudo] password di ale:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
 libreoffice : Dipende: libreoffice-core (= 1:5.4.4-1~bpo9+1) ma la versione 1:5.2.7-1 sta per essere installata
               Raccomanda: fonts-open-sans ma non è installabile
               Raccomanda: libreoffice-java-common (>= 1:5.4.4~) ma la versione 1:5.2.7-1 sta per essere installata
E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.


(An approximate tranlation I think could be → E: Can't fix problems, there are damaged packages locked)
-iak-
 
Posts: 16
Joined: 2017-10-16 17:02

Re: Can't install from backports (Stretch)

Postby stevepusser » 2018-01-30 23:45

Aptitude is smarter than apt in figuring these things out. Try installing it and trying the same command except with aptitude.

Code: Select all
sudo aptitude install libreoffice=1:5.4.4-1~bpo9+1


Aptitude tries multiple solutions. Very likely the first, then more after that, will not be what you want. Just keep hitting "n" to refuse that solution and go to the next until you get what you want: upgrades of the packages with nothing you need being removed. Sometimes this takes a while.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: GIMP 2.10.6, Pale Moon 28.0.1, wine-staging 3.15, qBittorrent 4.1.2, Linux kernel 4.18.6, virtualbox 5.2.18
User avatar
stevepusser
 
Posts: 9899
Joined: 2009-10-06 05:53

Re: Can't install from backports (Stretch)

Postby -iak- » 2018-01-31 00:50

stevepusser wrote:Aptitude is smarter than apt in figuring these things out. Try installing it and trying the same command except with aptitude.

Code: Select all
sudo aptitude install libreoffice=1:5.4.4-1~bpo9+1


Aptitude tries multiple solutions. Very likely the first, then more after that, will not be what you want. Just keep hitting "n" to refuse that solution and go to the next until you get what you want: upgrades of the packages with nothing you need being removed. Sometimes this takes a while.


Thanks, it did work! Libreoffice is up to date but it has no integration with the desktop theme, and it is no more in Italian.

Image

I got this at the end of the installation process:
Code: Select all
W: APT had planned for dpkg to do more than it reported back (182 vs 189).
   Affected packages: libreoffice-core:i386
                                                     
Stato attuale: 0 (-26) upgradable.


What does it mean? Can it be related to the theme/language issues?
Last edited by -iak- on 2018-01-31 01:16, edited 1 time in total.
-iak-
 
Posts: 16
Joined: 2017-10-16 17:02

Re: Can't install from backports (Stretch)

Postby GarryRicketson » 2018-01-31 01:08

User avatar
GarryRicketson
 
Posts: 5040
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: Can't install from backports (Stretch)

Postby -iak- » 2018-01-31 01:17



Sorry, I cropped it.
-iak-
 
Posts: 16
Joined: 2017-10-16 17:02

Re: Can't install from backports (Stretch)

Postby stevepusser » 2018-01-31 02:15

For Italian, make sure to upgrade to the libreoffice-l10n-it in backports also: https://packages.debian.org/stretch-bac ... ce-l10n-it and maybe libreoffice-help-it for the help files.

If you want GNOME or Cinnamon integration, install libreoffice-gtk3 from backports. For gtk2 bases, like xfce or lxde, libreoffice-gtk2, and libreoffice-kde for KDE.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: GIMP 2.10.6, Pale Moon 28.0.1, wine-staging 3.15, qBittorrent 4.1.2, Linux kernel 4.18.6, virtualbox 5.2.18
User avatar
stevepusser
 
Posts: 9899
Joined: 2009-10-06 05:53

Re: Can't install from backports (Stretch)

Postby -iak- » 2018-02-03 14:16

Everything works fine now. Thanks a lot.

I just wonder why
Code: Select all
sudo apt -t stretch-backports install libreoffice
didn't work.

I'm marking this as "solved".
-iak-
 
Posts: 16
Joined: 2017-10-16 17:02


Return to Installation

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable