SOLVED - Trouble Installing NVIDIA Driver (Again)

Help with issues regarding installation of Debian

SOLVED - Trouble Installing NVIDIA Driver (Again)

Postby Caitlin » 2018-02-15 07:38

I've been reinstalling Stretch and seem to have run into a problem building the NVIDIA driver. (I built it but it was missing the xorg and xorg-dev packages.) So I purged nvidia. and tried to reinstall -- but this time it wouldn't build.

(This is similar to a problem I reported here some time ago. But this time I purged nvidia. properly and it still won't rebuild.)

I'm including a large amount of terminal output:

Code: Select all
root@Blackbird:/home/user# apt-get install nvidia-detect
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  nvidia-detect
0 upgraded, 1 newly installed, 0 to remove and 33 not upgraded.
Need to get 0 B/174 kB of archives.
After this operation, 221 kB of additional disk space will be used.
Selecting previously unselected package nvidia-detect.
(Reading database ... 122464 files and directories currently installed.)
Preparing to unpack .../nvidia-detect_375.82-1~deb9u1_amd64.deb ...
Unpacking nvidia-detect (375.82-1~deb9u1) ...
Setting up nvidia-detect (375.82-1~deb9u1) ...
root@Blackbird:/home/user# nvidia-detect
Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108 [GeForce GT 430] [10de:0de1] (rev a1)

Checking card:  NVIDIA Corporation GF108 [GeForce GT 430] (rev a1)
Your card is supported by all driver versions.
It is recommended to install the
    nvidia-driver
package.
root@Blackbird:/home/user# apt-get purge nvidia.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'boinc-nvidia-cuda' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-340xx-fbc1' for regex 'nvidia.'
Note, selecting 'libnvidia-ptxjitcompiler' for regex 'nvidia.'
Note, selecting 'nvidia-325-updates' for regex 'nvidia.'
Note, selecting 'nvidia-346-updates' for regex 'nvidia.'
Note, selecting 'nvidia-driver-binary' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-smi' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-340xx-cuda1' for regex 'nvidia.'
Note, selecting 'libnvidia-compiler-375.82' for regex 'nvidia.'
Note, selecting 'libnvidia-compiler-304.135' for regex 'nvidia.'
Note, selecting 'libnvidia-compiler-304.137' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-driver-bin' for regex 'nvidia.'
Note, selecting 'nvidia-kernel-375.82' for regex 'nvidia.'
Note, selecting 'libgl1-nvidia-glx-340.102' for regex 'nvidia.'
Note, selecting 'libgl1-nvidia-glx-340.106' for regex 'nvidia.'
Note, selecting 'nvidia-cuda-mps' for regex 'nvidia.'
Note, selecting 'nvidia-support' for regex 'nvidia.'
Note, selecting 'libxvmcnvidia1' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-driver-bin' for regex 'nvidia.'
Note, selecting 'nvidia-kernel-support-any' for regex 'nvidia.'
Note, selecting 'libgles-nvidia1' for regex 'nvidia.'
Note, selecting 'libgles-nvidia2' for regex 'nvidia.'
Note, selecting 'nvidia-kernel-common' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-alternative--kmod-alias' for regex 'nvidia.'
Note, selecting 'nvidia-glx' for regex 'nvidia.'
Note, selecting 'nvidia-cg-toolkit' for regex 'nvidia.'
Note, selecting 'libnvidia-ml1' for regex 'nvidia.'
Note, selecting 'nvidia-vulkan-icd' for regex 'nvidia.'
Note, selecting 'nvidia-driver-libs-i386' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-driver-libs' for regex 'nvidia.'
Note, selecting 'nvidia-kernel-384.111' for regex 'nvidia.'
Note, selecting 'nvidia-egl-icd' for regex 'nvidia.'
Note, selecting 'libgl1-nvidia-legacy-340xx-glx-i386:i386' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-304xx-compiler' for regex 'nvidia.'
Note, selecting 'nvidia-driver-bin-304.135' for regex 'nvidia.'
Note, selecting 'nvidia-driver-bin-304.137' for regex 'nvidia.'
Note, selecting 'nvidia-nonglvnd-vulkan-icd' for regex 'nvidia.'
Note, selecting 'xserver-xorg-video-nvidia-any' for regex 'nvidia.'
Note, selecting 'nvidia-driver-libs-nonglvnd-i386' for regex 'nvidia.'
Note, selecting 'nvidia-driver' for regex 'nvidia.'
Note, selecting 'nvidia-367-updates' for regex 'nvidia.'
Note, selecting 'xserver-xorg-video-nvidia-legacy-340xx' for regex 'nvidia.'
Note, selecting 'nvidia-modprobe' for regex 'nvidia.'
Note, selecting 'nvidia-settings-legacy-340xx' for regex 'nvidia.'
Note, selecting 'libegl1-nvidia-legacy-340xx' for regex 'nvidia.'
Note, selecting 'nvidia-texture-tools' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-340xx-ifr1' for regex 'nvidia.'
Note, selecting 'nvidia-alternative-legacy-173xx' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-304xx-cfg1' for regex 'nvidia.'
Note, selecting 'nvidia-xconfig' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-vdpau-driver' for regex 'nvidia.'
Note, selecting 'nvidia-alternative--kmod-alias' for regex 'nvidia.'
Note, selecting 'nvidia-349-updates' for regex 'nvidia.'
Note, selecting 'nvidia-vulkan-common' for regex 'nvidia.'
Note, selecting 'libnvidia-glcore-340.102' for regex 'nvidia.'
Note, selecting 'libnvidia-glcore-340.106' for regex 'nvidia.'
Note, selecting 'libnvidia-encode1' for regex 'nvidia.'
Note, selecting 'nvidia-310-updates' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-smi' for regex 'nvidia.'
Note, selecting 'nvidia-331-updates' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-340xx-compiler' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-vdpau-driver' for regex 'nvidia.'
Note, selecting 'nvidia-vdpau-driver' for regex 'nvidia.'
Note, selecting 'libgl1-nvidia-glvnd-glx' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-kernel-support' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-alternative--kmod-alias' for regex 'nvidia.'
Note, selecting 'libnvidia-cfg1-any' for regex 'nvidia.'
Note, selecting 'glvnd-nvidia-abi-375.20' for regex 'nvidia.'
Note, selecting 'libgl1-nvidia-glx-304.135' for regex 'nvidia.'
Note, selecting 'libgl1-nvidia-glx-304.137' for regex 'nvidia.'
Note, selecting 'libnvidia-compiler-384.111' for regex 'nvidia.'
Note, selecting 'libgles1-nvidia-legacy-340xx' for regex 'nvidia.'
Note, selecting 'libglx-nvidia0' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-opencl-icd' for regex 'nvidia.'
Note, selecting 'nvidia-smi' for regex 'nvidia.'
Note, selecting 'nvidia-313-updates' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-kernel-dkms' for regex 'nvidia.'
Note, selecting 'nvidia-334-updates' for regex 'nvidia.'
Note, selecting 'libnvidia-egl-wayland1' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-kernel-source' for regex 'nvidia.'
Note, selecting 'nvidia-detect' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-opencl-icd' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-340xx-eglcore' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-driver-libs' for regex 'nvidia.'
Note, selecting 'libnvidia-egl-wayland-375.82' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-304xx-glcore' for regex 'nvidia.'
Note, selecting 'nvidia-kernel-dkms' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-driver-libs-i386' for regex 'nvidia.'
Note, selecting 'nvidia-current-updates' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-alternative' for regex 'nvidia.'
Note, selecting 'xserver-xorg-video-nvidia-legacy-304xx' for regex 'nvidia.'
Note, selecting 'libegl-nvidia0' for regex 'nvidia.'
Note, selecting 'nvidia-settings-legacy-304xx' for regex 'nvidia.'
Note, selecting 'nvidia-egl-common' for regex 'nvidia.'
Note, selecting 'nvidia-driver-bin-384.111' for regex 'nvidia.'
Note, selecting 'libnvidia-eglcore-384.111' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-driver-libs-i386' for regex 'nvidia.'
Note, selecting 'libnvidia-egl-wayland' for regex 'nvidia.'
Note, selecting 'nvidia-nsight' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-340xx-cuda1-i386' for regex 'nvidia.'
Note, selecting 'libgl1-nvidia-glx' for regex 'nvidia.'
Note, selecting 'libnvidia-ptxjitcompiler1' for regex 'nvidia.'
Note, selecting 'nvidia-352-updates' for regex 'nvidia.'
Note, selecting 'libnvidia-cfg1' for regex 'nvidia.'
Note, selecting 'libgl1-nvidia-legacy-340xx-glx' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-check' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-304xx-cuda1-i386' for regex 'nvidia.'
Note, selecting 'nvidia-opencl-common' for regex 'nvidia.'
Note, selecting 'nvidia-egl-wayland-icd' for regex 'nvidia.'
Note, selecting 'libgl1-nvidia-glx-375.82' for regex 'nvidia.'
Note, selecting 'libnvidia-fatbinaryloader' for regex 'nvidia.'
Note, selecting 'libnvidia-fbc1' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-kernel-304.135' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-kernel-304.137' for regex 'nvidia.'
Note, selecting 'nvidia-355-updates' for regex 'nvidia.'
Note, selecting 'nvidia-driver-libs-nonglvnd' for regex 'nvidia.'
Note, selecting 'libgl1-nvidia-glx-any' for regex 'nvidia.'
Note, selecting 'libnvidia-glcore-304.135' for regex 'nvidia.'
Note, selecting 'libnvidia-glcore-304.137' for regex 'nvidia.'
Note, selecting 'libgles2-nvidia-legacy-340xx' for regex 'nvidia.'
Note, selecting 'libgl1-nvidia-legacy-304xx-glx' for regex 'nvidia.'
Note, selecting 'nvidia-kernel-support' for regex 'nvidia.'
Note, selecting 'nvidia-current' for regex 'nvidia.'
Note, selecting 'nvidia-profiler' for regex 'nvidia.'
Note, selecting 'libnvidia-compiler' for regex 'nvidia.'
Note, selecting 'libgl1-nvidia-glx-384.111' for regex 'nvidia.'
Note, selecting 'nvidia-337-updates' for regex 'nvidia.'
Note, selecting 'nvidia-358-updates' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-kernel-340.102' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-kernel-340.106' for regex 'nvidia.'
Note, selecting 'nvidia-alternative-legacy-96xx' for regex 'nvidia.'
Note, selecting 'nvidia-cuda-toolkit' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-driver' for regex 'nvidia.'
Note, selecting 'nvidia-driver-libs' for regex 'nvidia.'
Note, selecting 'nvidia-driver-bin' for regex 'nvidia.'
Note, selecting 'nvidia-kernel-source' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-kernel-support' for regex 'nvidia.'
Note, selecting 'nvidia-319-updates' for regex 'nvidia.'
Note, selecting 'nvidia-glx-any' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-304xx-nvcuvid1' for regex 'nvidia.'
Note, selecting 'nvidia-driver-bin-375.82' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-340xx-encode1' for regex 'nvidia.'
Note, selecting 'nvidia-visual-profiler' for regex 'nvidia.'
Note, selecting 'nvidia-persistenced' for regex 'nvidia.'
Note, selecting 'libgl1-nvidia-glx-i386:i386' for regex 'nvidia.'
Note, selecting 'libnvidia-compiler-340.102' for regex 'nvidia.'
Note, selecting 'libnvidia-compiler-340.106' for regex 'nvidia.'
Note, selecting 'libgl1-nvidia-legacy-304xx-glx-i386:i386' for regex 'nvidia.'
Note, selecting 'libnvidia-glcore-375.82' for regex 'nvidia.'
Note, selecting 'libnvidia-ifr1' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-kernel-support--v1' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-340xx-glcore' for regex 'nvidia.'
Note, selecting 'nvidia-304-updates' for regex 'nvidia.'
Note, selecting 'nvidia-installer-cleanup' for regex 'nvidia.'
Note, selecting 'libgl1-glvnd-nvidia-glx' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-driver' for regex 'nvidia.'
Note, selecting 'nvidia-egl-wayland-common' for regex 'nvidia.'
Note, selecting 'nvidia-cuda-dev' for regex 'nvidia.'
Note, selecting 'nvidia-cuda-doc' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-340xx-ml1' for regex 'nvidia.'
Note, selecting 'nvidia-340-updates' for regex 'nvidia.'
Note, selecting 'nvidia-361-updates' for regex 'nvidia.'
Note, selecting 'nvidia-libopencl1-dev' for regex 'nvidia.'
Note, selecting 'libnvidia-glcore-384.111' for regex 'nvidia.'
Note, selecting 'nvidia-opencl-dev' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-kernel-dkms' for regex 'nvidia.'
Note, selecting 'nvidia-driver-bin-340.102' for regex 'nvidia.'
Note, selecting 'boinc-client-nvidia-cuda' for regex 'nvidia.'
Note, selecting 'nvidia-driver-bin-340.106' for regex 'nvidia.'
Note, selecting 'libnvidia-eglcore-340.102' for regex 'nvidia.'
Note, selecting 'libnvidia-eglcore-340.106' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-340xx-nvcuvid1' for regex 'nvidia.'
Note, selecting 'nvidia-cg-dev' for regex 'nvidia.'
Note, selecting 'nvidia-cg-doc' for regex 'nvidia.'
Note, selecting 'nvidia-libopencl1' for regex 'nvidia.'
Note, selecting 'libnvidia-glcore' for regex 'nvidia.'
Note, selecting 'nvidia-cuda-gdb' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-304' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-310' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-313' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-319' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-325' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-331' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-334' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-337' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-340' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-343' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-346' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-349' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-352' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-355' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-358' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-361' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-364' for regex 'nvidia.'
Note, selecting 'nvidia-experimental-367' for regex 'nvidia.'
Note, selecting 'nvidia-nonglvnd-vulkan-common' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-alternative' for regex 'nvidia.'
Note, selecting 'nvidia-343-updates' for regex 'nvidia.'
Note, selecting 'nvidia-364-updates' for regex 'nvidia.'
Note, selecting 'nvidia-304' for regex 'nvidia.'
Note, selecting 'nvidia-310' for regex 'nvidia.'
Note, selecting 'nvidia-313' for regex 'nvidia.'
Note, selecting 'nvidia-319' for regex 'nvidia.'
Note, selecting 'nvidia-325' for regex 'nvidia.'
Note, selecting 'nvidia-331' for regex 'nvidia.'
Note, selecting 'nvidia-334' for regex 'nvidia.'
Note, selecting 'nvidia-337' for regex 'nvidia.'
Note, selecting 'nvidia-340' for regex 'nvidia.'
Note, selecting 'nvidia-343' for regex 'nvidia.'
Note, selecting 'nvidia-346' for regex 'nvidia.'
Note, selecting 'nvidia-349' for regex 'nvidia.'
Note, selecting 'nvidia-352' for regex 'nvidia.'
Note, selecting 'nvidia-355' for regex 'nvidia.'
Note, selecting 'nvidia-358' for regex 'nvidia.'
Note, selecting 'nvidia-361' for regex 'nvidia.'
Note, selecting 'nvidia-364' for regex 'nvidia.'
Note, selecting 'nvidia-367' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-340xx-cfg1' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-304xx-ml1' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-304xx-kernel-support--v1' for regex 'nvidia.'
Note, selecting 'libnvidia-eglcore' for regex 'nvidia.'
Note, selecting 'nvidia-kernel-support--v1' for regex 'nvidia.'
Note, selecting 'nvidia-settings' for regex 'nvidia.'
Note, selecting 'libnvidia-legacy-304xx-cuda1' for regex 'nvidia.'
Note, selecting 'nvidia-legacy-340xx-kernel-source' for regex 'nvidia.'
Note, selecting 'libnvidia-eglcore-375.82' for regex 'nvidia.'
Note, selecting 'nvidia-opencl-icd' for regex 'nvidia.'
Note, selecting 'nvidia-alternative' for regex 'nvidia.'
Package 'boinc-nvidia-cuda' is not installed, so not removed
Note, selecting 'libnvidia-egl-wayland' instead of 'libnvidia-egl-wayland-375.82'
Package 'libgl1-nvidia-glx-384.111' is not installed, so not removed
Note, selecting 'nvidia-alternative' instead of 'nvidia-alternative--kmod-alias'
Package 'nvidia-glx' is not installed, so not removed
Note, selecting 'nvidia-driver-libs-i386:i386' instead of 'nvidia-driver-libs-i386'
Note, selecting 'nvidia-driver-libs-nonglvnd-i386:i386' instead of 'nvidia-driver-libs-nonglvnd-i386'
Note, selecting 'nvidia-kernel-support' instead of 'nvidia-kernel-support--v1'
Package 'libxvmcnvidia1' is not installed, so not removed
Note, selecting 'libnvidia-legacy-304xx-cuda1-i386:i386' instead of 'libnvidia-legacy-304xx-cuda1-i386'
Package 'libgl1-nvidia-glx-304.137' is not installed, so not removed
Note, selecting 'nvidia-legacy-304xx-alternative' instead of 'nvidia-legacy-304xx-alternative--kmod-alias'
Note, selecting 'nvidia-legacy-304xx-driver-libs-i386:i386' instead of 'nvidia-legacy-304xx-driver-libs-i386'
Note, selecting 'nvidia-legacy-304xx-kernel-support' instead of 'nvidia-legacy-304xx-kernel-support--v1'
Note, selecting 'libnvidia-legacy-340xx-cuda1-i386:i386' instead of 'libnvidia-legacy-340xx-cuda1-i386'
Package 'libgl1-nvidia-glx-340.106' is not installed, so not removed
Note, selecting 'nvidia-legacy-340xx-alternative' instead of 'nvidia-legacy-340xx-alternative--kmod-alias'
Note, selecting 'nvidia-legacy-340xx-driver-libs-i386:i386' instead of 'nvidia-legacy-340xx-driver-libs-i386'
Note, selecting 'nvidia-legacy-340xx-kernel-support' instead of 'nvidia-legacy-340xx-kernel-support--v1'
Package 'libgl1-nvidia-glx-i386:i386' is not installed, so not removed
Package 'libgl1-nvidia-legacy-304xx-glx-i386:i386' is not installed, so not removed
Package 'libgl1-nvidia-legacy-340xx-glx-i386:i386' is not installed, so not removed
Note, selecting 'nvidia-kernel-dkms' instead of 'nvidia-kernel-375.82'
Note, selecting 'libnvidia-compiler' instead of 'libnvidia-compiler-375.82'
Note, selecting 'libnvidia-eglcore' instead of 'libnvidia-eglcore-375.82'
Package 'libgl1-nvidia-glx-375.82' is not installed, so not removed
Note, selecting 'libnvidia-glcore' instead of 'libnvidia-glcore-375.82'
Note, selecting 'nvidia-driver-bin' instead of 'nvidia-driver-bin-375.82'
Note, selecting 'nvidia-legacy-304xx-kernel-dkms' instead of 'nvidia-legacy-304xx-kernel-304.135'
Note, selecting 'libnvidia-legacy-304xx-compiler' instead of 'libnvidia-compiler-304.135'
Package 'libgl1-nvidia-glx-304.135' is not installed, so not removed
Note, selecting 'libnvidia-legacy-304xx-glcore' instead of 'libnvidia-glcore-304.135'
Note, selecting 'nvidia-legacy-304xx-driver-bin' instead of 'nvidia-driver-bin-304.135'
Note, selecting 'nvidia-legacy-340xx-kernel-dkms' instead of 'nvidia-legacy-340xx-kernel-340.102'
Note, selecting 'libnvidia-legacy-340xx-compiler' instead of 'libnvidia-compiler-340.102'
Note, selecting 'libnvidia-legacy-340xx-eglcore' instead of 'libnvidia-eglcore-340.102'
Package 'libgl1-nvidia-glx-340.102' is not installed, so not removed
Note, selecting 'libnvidia-legacy-340xx-glcore' instead of 'libnvidia-glcore-340.102'
Note, selecting 'nvidia-legacy-340xx-driver-bin' instead of 'nvidia-driver-bin-340.102'
Package 'nvidia-current' is not installed, so not removed
Package 'nvidia-current-updates' is not installed, so not removed
Package 'nvidia-driver-binary' is not installed, so not removed
Package 'nvidia-304' is not installed, so not removed
Package 'nvidia-304-updates' is not installed, so not removed
Package 'nvidia-experimental-304' is not installed, so not removed
Package 'nvidia-310' is not installed, so not removed
Package 'nvidia-310-updates' is not installed, so not removed
Package 'nvidia-experimental-310' is not installed, so not removed
Package 'nvidia-313' is not installed, so not removed
Package 'nvidia-313-updates' is not installed, so not removed
Package 'nvidia-experimental-313' is not installed, so not removed
Package 'nvidia-319' is not installed, so not removed
Package 'nvidia-319-updates' is not installed, so not removed
Package 'nvidia-experimental-319' is not installed, so not removed
Package 'nvidia-325' is not installed, so not removed
Package 'nvidia-325-updates' is not installed, so not removed
Package 'nvidia-experimental-325' is not installed, so not removed
Package 'nvidia-331' is not installed, so not removed
Package 'nvidia-331-updates' is not installed, so not removed
Package 'nvidia-experimental-331' is not installed, so not removed
Package 'nvidia-334' is not installed, so not removed
Package 'nvidia-334-updates' is not installed, so not removed
Package 'nvidia-experimental-334' is not installed, so not removed
Package 'nvidia-337' is not installed, so not removed
Package 'nvidia-337-updates' is not installed, so not removed
Package 'nvidia-experimental-337' is not installed, so not removed
Package 'nvidia-340' is not installed, so not removed
Package 'nvidia-340-updates' is not installed, so not removed
Package 'nvidia-experimental-340' is not installed, so not removed
Package 'nvidia-343' is not installed, so not removed
Package 'nvidia-343-updates' is not installed, so not removed
Package 'nvidia-experimental-343' is not installed, so not removed
Package 'nvidia-346' is not installed, so not removed
Package 'nvidia-346-updates' is not installed, so not removed
Package 'nvidia-experimental-346' is not installed, so not removed
Package 'nvidia-349' is not installed, so not removed
Package 'nvidia-349-updates' is not installed, so not removed
Package 'nvidia-experimental-349' is not installed, so not removed
Package 'nvidia-352' is not installed, so not removed
Package 'nvidia-352-updates' is not installed, so not removed
Package 'nvidia-experimental-352' is not installed, so not removed
Package 'nvidia-355' is not installed, so not removed
Package 'nvidia-355-updates' is not installed, so not removed
Package 'nvidia-experimental-355' is not installed, so not removed
Package 'nvidia-358' is not installed, so not removed
Package 'nvidia-358-updates' is not installed, so not removed
Package 'nvidia-experimental-358' is not installed, so not removed
Package 'nvidia-361' is not installed, so not removed
Package 'nvidia-361-updates' is not installed, so not removed
Package 'nvidia-experimental-361' is not installed, so not removed
Package 'nvidia-364' is not installed, so not removed
Package 'nvidia-364-updates' is not installed, so not removed
Package 'nvidia-experimental-364' is not installed, so not removed
Package 'nvidia-367' is not installed, so not removed
Package 'nvidia-367-updates' is not installed, so not removed
Package 'nvidia-experimental-367' is not installed, so not removed
Package 'nvidia-alternative-legacy-173xx' is not installed, so not removed
Package 'nvidia-alternative-legacy-96xx' is not installed, so not removed
Note, selecting 'libnvtt-bin' instead of 'nvidia-texture-tools'
Package 'nvidia-libopencl1-dev' is not installed, so not removed
Package 'boinc-client-nvidia-cuda' is not installed, so not removed
Package 'nvidia-modprobe' is not installed, so not removed
Package 'nvidia-persistenced' is not installed, so not removed
Package 'nvidia-settings' is not installed, so not removed
Package 'nvidia-xconfig' is not installed, so not removed
Package 'libegl-nvidia0' is not installed, so not removed
Package 'libgl1-glvnd-nvidia-glx' is not installed, so not removed
Package 'libgl1-nvidia-glvnd-glx' is not installed, so not removed
Package 'libgl1-nvidia-glx' is not installed, so not removed
Package 'libgles-nvidia1' is not installed, so not removed
Package 'libgles-nvidia2' is not installed, so not removed
Package 'libglx-nvidia0' is not installed, so not removed
Package 'libnvidia-cfg1' is not installed, so not removed
Package 'libnvidia-compiler' is not installed, so not removed
Package 'libnvidia-egl-wayland' is not installed, so not removed
Package 'libnvidia-egl-wayland1' is not installed, so not removed
Package 'libnvidia-eglcore' is not installed, so not removed
Package 'libnvidia-encode1' is not installed, so not removed
Package 'libnvidia-fatbinaryloader' is not installed, so not removed
Package 'libnvidia-fbc1' is not installed, so not removed
Package 'libnvidia-glcore' is not installed, so not removed
Package 'libnvidia-ifr1' is not installed, so not removed
Package 'libnvidia-ml1' is not installed, so not removed
Package 'libnvidia-ptxjitcompiler' is not installed, so not removed
Package 'libnvidia-ptxjitcompiler1' is not installed, so not removed
Package 'nvidia-alternative' is not installed, so not removed
Package 'nvidia-cuda-mps' is not installed, so not removed
Package 'nvidia-driver' is not installed, so not removed
Package 'nvidia-driver-bin' is not installed, so not removed
Package 'nvidia-driver-libs' is not installed, so not removed
Package 'nvidia-driver-libs-nonglvnd' is not installed, so not removed
Package 'nvidia-egl-common' is not installed, so not removed
Package 'nvidia-egl-icd' is not installed, so not removed
Package 'nvidia-egl-wayland-common' is not installed, so not removed
Package 'nvidia-egl-wayland-icd' is not installed, so not removed
Package 'nvidia-kernel-dkms' is not installed, so not removed
Package 'nvidia-kernel-source' is not installed, so not removed
Package 'nvidia-kernel-support' is not installed, so not removed
Package 'nvidia-legacy-check' is not installed, so not removed
Package 'nvidia-libopencl1' is not installed, so not removed
Package 'nvidia-nonglvnd-vulkan-common' is not installed, so not removed
Package 'nvidia-nonglvnd-vulkan-icd' is not installed, so not removed
Package 'nvidia-opencl-common' is not installed, so not removed
Package 'nvidia-opencl-icd' is not installed, so not removed
Package 'nvidia-smi' is not installed, so not removed
Package 'nvidia-vdpau-driver' is not installed, so not removed
Package 'nvidia-vulkan-common' is not installed, so not removed
Package 'nvidia-vulkan-icd' is not installed, so not removed
Package 'libgl1-nvidia-legacy-304xx-glx' is not installed, so not removed
Package 'libnvidia-legacy-304xx-cfg1' is not installed, so not removed
Package 'libnvidia-legacy-304xx-compiler' is not installed, so not removed
Package 'libnvidia-legacy-304xx-cuda1' is not installed, so not removed
Package 'libnvidia-legacy-304xx-glcore' is not installed, so not removed
Package 'libnvidia-legacy-304xx-ml1' is not installed, so not removed
Package 'libnvidia-legacy-304xx-nvcuvid1' is not installed, so not removed
Package 'nvidia-legacy-304xx-alternative' is not installed, so not removed
Package 'nvidia-legacy-304xx-driver' is not installed, so not removed
Package 'nvidia-legacy-304xx-driver-bin' is not installed, so not removed
Package 'nvidia-legacy-304xx-driver-libs' is not installed, so not removed
Package 'nvidia-legacy-304xx-kernel-dkms' is not installed, so not removed
Package 'nvidia-legacy-304xx-kernel-source' is not installed, so not removed
Package 'nvidia-legacy-304xx-kernel-support' is not installed, so not removed
Package 'nvidia-legacy-304xx-opencl-icd' is not installed, so not removed
Package 'nvidia-legacy-304xx-smi' is not installed, so not removed
Package 'nvidia-legacy-304xx-vdpau-driver' is not installed, so not removed
Package 'xserver-xorg-video-nvidia-legacy-304xx' is not installed, so not removed
Package 'libegl1-nvidia-legacy-340xx' is not installed, so not removed
Package 'libgl1-nvidia-legacy-340xx-glx' is not installed, so not removed
Package 'libgles1-nvidia-legacy-340xx' is not installed, so not removed
Package 'libgles2-nvidia-legacy-340xx' is not installed, so not removed
Package 'libnvidia-legacy-340xx-cfg1' is not installed, so not removed
Package 'libnvidia-legacy-340xx-compiler' is not installed, so not removed
Package 'libnvidia-legacy-340xx-cuda1' is not installed, so not removed
Package 'libnvidia-legacy-340xx-eglcore' is not installed, so not removed
Package 'libnvidia-legacy-340xx-encode1' is not installed, so not removed
Package 'libnvidia-legacy-340xx-fbc1' is not installed, so not removed
Package 'libnvidia-legacy-340xx-glcore' is not installed, so not removed
Package 'libnvidia-legacy-340xx-ifr1' is not installed, so not removed
Package 'libnvidia-legacy-340xx-ml1' is not installed, so not removed
Package 'libnvidia-legacy-340xx-nvcuvid1' is not installed, so not removed
Package 'nvidia-legacy-340xx-alternative' is not installed, so not removed
Package 'nvidia-legacy-340xx-driver' is not installed, so not removed
Package 'nvidia-legacy-340xx-driver-bin' is not installed, so not removed
Package 'nvidia-legacy-340xx-driver-libs' is not installed, so not removed
Package 'nvidia-legacy-340xx-kernel-dkms' is not installed, so not removed
Package 'nvidia-legacy-340xx-kernel-source' is not installed, so not removed
Package 'nvidia-legacy-340xx-kernel-support' is not installed, so not removed
Package 'nvidia-legacy-340xx-opencl-icd' is not installed, so not removed
Package 'nvidia-legacy-340xx-smi' is not installed, so not removed
Package 'nvidia-legacy-340xx-vdpau-driver' is not installed, so not removed
Package 'xserver-xorg-video-nvidia-legacy-340xx' is not installed, so not removed
Package 'nvidia-cg-dev' is not installed, so not removed
Package 'nvidia-cg-doc' is not installed, so not removed
Package 'nvidia-cg-toolkit' is not installed, so not removed
Package 'nvidia-cuda-dev' is not installed, so not removed
Package 'nvidia-cuda-doc' is not installed, so not removed
Package 'nvidia-cuda-gdb' is not installed, so not removed
Package 'nvidia-cuda-toolkit' is not installed, so not removed
Package 'nvidia-nsight' is not installed, so not removed
Package 'nvidia-opencl-dev' is not installed, so not removed
Package 'nvidia-profiler' is not installed, so not removed
Package 'nvidia-visual-profiler' is not installed, so not removed
Package 'nvidia-settings-legacy-304xx' is not installed, so not removed
Package 'nvidia-settings-legacy-340xx' is not installed, so not removed
Package 'nvidia-installer-cleanup' is not installed, so not removed
Package 'nvidia-kernel-common' is not installed, so not removed
Package 'nvidia-support' is not installed, so not removed
The following packages will be REMOVED:
  nvidia-detect*
0 upgraded, 0 newly installed, 1 to remove and 33 not upgraded.
After this operation, 221 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 122478 files and directories currently installed.)
Removing nvidia-detect (375.82-1~deb9u1) ...
root@Blackbird:/home/user# apt-get install nvidia-xconfig xorg xorg-dev linux-headers-$(uname -r|sed 's/[^-]*-[^-]*-//') nvidia-legacy-340xx-driver --no-install-recommends
Reading package lists... Done
Building dependency tree       
Reading state information... Done
linux-headers-amd64 is already the newest version (4.9+80+deb9u3).
xorg is already the newest version (1:7.7+19).
xorg-dev is already the newest version (1:7.7+19).
The following additional packages will be installed:
  glx-alternative-nvidia glx-diversions libegl1-nvidia-legacy-340xx
  libgl1-nvidia-legacy-340xx-glx libnvidia-legacy-340xx-eglcore
  libnvidia-legacy-340xx-glcore libnvidia-legacy-340xx-ml1
  nvidia-installer-cleanup nvidia-kernel-common
  nvidia-legacy-340xx-alternative nvidia-legacy-340xx-driver-bin
  nvidia-legacy-340xx-driver-libs nvidia-legacy-340xx-kernel-dkms
  nvidia-legacy-340xx-kernel-support nvidia-legacy-340xx-vdpau-driver
  nvidia-modprobe nvidia-support xserver-xorg-video-nvidia-legacy-340xx
Suggested packages:
  nvidia-driver
Recommended packages:
  nvidia-settings-legacy-340xx nvidia-persistenced
  nvidia-legacy-340xx-driver-libs-i386 libgles1-nvidia-legacy-340xx
  libgles2-nvidia-legacy-340xx libnvidia-legacy-340xx-cfg1
The following NEW packages will be installed:
  glx-alternative-nvidia glx-diversions libegl1-nvidia-legacy-340xx
  libgl1-nvidia-legacy-340xx-glx libnvidia-legacy-340xx-eglcore
  libnvidia-legacy-340xx-glcore libnvidia-legacy-340xx-ml1
  nvidia-installer-cleanup nvidia-kernel-common
  nvidia-legacy-340xx-alternative nvidia-legacy-340xx-driver
  nvidia-legacy-340xx-driver-bin nvidia-legacy-340xx-driver-libs
  nvidia-legacy-340xx-kernel-dkms nvidia-legacy-340xx-kernel-support
  nvidia-legacy-340xx-vdpau-driver nvidia-modprobe nvidia-support
  nvidia-xconfig xserver-xorg-video-nvidia-legacy-340xx
0 upgraded, 20 newly installed, 0 to remove and 33 not upgraded.
Need to get 23.3 MB/23.5 MB of archives.
After this operation, 135 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://deb.debian.org/debian stretch/non-free amd64 nvidia-legacy-340xx-alternative amd64 340.102-1 [76.9 kB]
Get:2 http://deb.debian.org/debian stretch/non-free amd64 libnvidia-legacy-340xx-glcore amd64 340.102-1 [7,048 kB]
Get:3 http://deb.debian.org/debian stretch/non-free amd64 libgl1-nvidia-legacy-340xx-glx amd64 340.102-1 [465 kB]
Get:4 http://deb.debian.org/debian stretch/non-free amd64 libnvidia-legacy-340xx-eglcore amd64 340.102-1 [6,944 kB]
Get:5 http://deb.debian.org/debian stretch/non-free amd64 libegl1-nvidia-legacy-340xx amd64 340.102-1 [226 kB]
Get:6 http://deb.debian.org/debian stretch/non-free amd64 nvidia-legacy-340xx-driver-libs amd64 340.102-1 [75.1 kB]
Get:7 http://deb.debian.org/debian stretch/non-free amd64 libnvidia-legacy-340xx-ml1 amd64 340.102-1 [355 kB]
Get:8 http://deb.debian.org/debian stretch/non-free amd64 nvidia-legacy-340xx-driver-bin amd64 340.102-1 [157 kB]
Get:9 http://deb.debian.org/debian stretch/non-free amd64 xserver-xorg-video-nvidia-legacy-340xx amd64 340.102-1 [2,653 kB]
Get:10 http://deb.debian.org/debian stretch/non-free amd64 nvidia-legacy-340xx-vdpau-driver amd64 340.102-1 [913 kB]
Get:11 http://deb.debian.org/debian stretch/non-free amd64 nvidia-legacy-340xx-kernel-support amd64 340.102-1 [75.8 kB]
Get:12 http://deb.debian.org/debian stretch/non-free amd64 nvidia-legacy-340xx-kernel-dkms amd64 340.102-1 [3,974 kB]
Get:13 http://deb.debian.org/debian stretch/non-free amd64 nvidia-legacy-340xx-driver amd64 340.102-1 [361 kB]
Fetched 23.3 MB in 4s (5,786 kB/s)                   
Preconfiguring packages ...
Selecting previously unselected package nvidia-installer-cleanup.
(Reading database ... 122464 files and directories currently installed.)
Preparing to unpack .../nvidia-installer-cleanup_20151021+4_amd64.deb ...
Unpacking nvidia-installer-cleanup (20151021+4) ...
Setting up nvidia-installer-cleanup (20151021+4) ...
Selecting previously unselected package glx-diversions.
(Reading database ... 122472 files and directories currently installed.)
Preparing to unpack .../00-glx-diversions_0.7.4_amd64.deb ...
Unpacking glx-diversions (0.7.4) ...
Selecting previously unselected package glx-alternative-nvidia.
Preparing to unpack .../01-glx-alternative-nvidia_0.7.4_amd64.deb ...
Unpacking glx-alternative-nvidia (0.7.4) ...
Selecting previously unselected package nvidia-legacy-340xx-alternative.
Preparing to unpack .../02-nvidia-legacy-340xx-alternative_340.102-1_amd64.deb ...
Unpacking nvidia-legacy-340xx-alternative (340.102-1) ...
Selecting previously unselected package libnvidia-legacy-340xx-glcore:amd64.
Preparing to unpack .../03-libnvidia-legacy-340xx-glcore_340.102-1_amd64.deb ...
Unpacking libnvidia-legacy-340xx-glcore:amd64 (340.102-1) ...
Selecting previously unselected package nvidia-support.
Preparing to unpack .../04-nvidia-support_20151021+4_amd64.deb ...
Unpacking nvidia-support (20151021+4) ...
Selecting previously unselected package libgl1-nvidia-legacy-340xx-glx:amd64.
Preparing to unpack .../05-libgl1-nvidia-legacy-340xx-glx_340.102-1_amd64.deb ...
Unpacking libgl1-nvidia-legacy-340xx-glx:amd64 (340.102-1) ...
Selecting previously unselected package libnvidia-legacy-340xx-eglcore:amd64.
Preparing to unpack .../06-libnvidia-legacy-340xx-eglcore_340.102-1_amd64.deb ...
Unpacking libnvidia-legacy-340xx-eglcore:amd64 (340.102-1) ...
Selecting previously unselected package libegl1-nvidia-legacy-340xx:amd64.
Preparing to unpack .../07-libegl1-nvidia-legacy-340xx_340.102-1_amd64.deb ...
Unpacking libegl1-nvidia-legacy-340xx:amd64 (340.102-1) ...
Selecting previously unselected package nvidia-legacy-340xx-driver-libs:amd64.
Preparing to unpack .../08-nvidia-legacy-340xx-driver-libs_340.102-1_amd64.deb ...
Unpacking nvidia-legacy-340xx-driver-libs:amd64 (340.102-1) ...
Selecting previously unselected package libnvidia-legacy-340xx-ml1:amd64.
Preparing to unpack .../09-libnvidia-legacy-340xx-ml1_340.102-1_amd64.deb ...
Unpacking libnvidia-legacy-340xx-ml1:amd64 (340.102-1) ...
Selecting previously unselected package nvidia-legacy-340xx-driver-bin.
Preparing to unpack .../10-nvidia-legacy-340xx-driver-bin_340.102-1_amd64.deb ...
Unpacking nvidia-legacy-340xx-driver-bin (340.102-1) ...
Selecting previously unselected package xserver-xorg-video-nvidia-legacy-340xx.
Preparing to unpack .../11-xserver-xorg-video-nvidia-legacy-340xx_340.102-1_amd64.deb ...
Unpacking xserver-xorg-video-nvidia-legacy-340xx (340.102-1) ...
Selecting previously unselected package nvidia-legacy-340xx-vdpau-driver:amd64.
Preparing to unpack .../12-nvidia-legacy-340xx-vdpau-driver_340.102-1_amd64.deb ...
Unpacking nvidia-legacy-340xx-vdpau-driver:amd64 (340.102-1) ...
Selecting previously unselected package nvidia-kernel-common.
Preparing to unpack .../13-nvidia-kernel-common_20151021+4_amd64.deb ...
Unpacking nvidia-kernel-common (20151021+4) ...
Selecting previously unselected package nvidia-modprobe.
Preparing to unpack .../14-nvidia-modprobe_375.26-1_amd64.deb ...
Unpacking nvidia-modprobe (375.26-1) ...
Selecting previously unselected package nvidia-legacy-340xx-kernel-support.
Preparing to unpack .../15-nvidia-legacy-340xx-kernel-support_340.102-1_amd64.deb ...
Unpacking nvidia-legacy-340xx-kernel-support (340.102-1) ...
Selecting previously unselected package nvidia-legacy-340xx-kernel-dkms.
Preparing to unpack .../16-nvidia-legacy-340xx-kernel-dkms_340.102-1_amd64.deb ...
Unpacking nvidia-legacy-340xx-kernel-dkms (340.102-1) ...
Selecting previously unselected package nvidia-legacy-340xx-driver.
Preparing to unpack .../17-nvidia-legacy-340xx-driver_340.102-1_amd64.deb ...
Unpacking nvidia-legacy-340xx-driver (340.102-1) ...
Selecting previously unselected package nvidia-xconfig.
Preparing to unpack .../18-nvidia-xconfig_375.26-1_amd64.deb ...
Unpacking nvidia-xconfig (375.26-1) ...
Setting up nvidia-kernel-common (20151021+4) ...
Setting up libnvidia-legacy-340xx-glcore:amd64 (340.102-1) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for desktop-file-utils (0.23-1) ...
Setting up nvidia-support (20151021+4) ...
Processing triggers for libc-bin (2.24-11+deb9u1) ...
Setting up nvidia-xconfig (375.26-1) ...
Setting up glx-diversions (0.7.4) ...
Setting up nvidia-modprobe (375.26-1) ...
Setting up libnvidia-legacy-340xx-eglcore:amd64 (340.102-1) ...
Processing triggers for man-db (2.7.6.1-2) ...
Processing triggers for glx-alternative-mesa (0.7.4) ...
update-alternatives: using /usr/lib/mesa-diverted to provide /usr/lib/glx (glx) in auto mode
Setting up glx-alternative-nvidia (0.7.4) ...
Processing triggers for glx-alternative-nvidia (0.7.4) ...
Setting up nvidia-legacy-340xx-alternative (340.102-1) ...
Processing triggers for nvidia-legacy-340xx-alternative (340.102-1) ...
update-alternatives: using /usr/lib/nvidia/legacy-340xx to provide /usr/lib/nvidia/nvidia (nvidia) in auto mode
Setting up libnvidia-legacy-340xx-ml1:amd64 (340.102-1) ...
Setting up nvidia-legacy-340xx-driver-bin (340.102-1) ...
Setting up libgl1-nvidia-legacy-340xx-glx:amd64 (340.102-1) ...
Setting up xserver-xorg-video-nvidia-legacy-340xx (340.102-1) ...
Setting up nvidia-legacy-340xx-vdpau-driver:amd64 (340.102-1) ...
Setting up libegl1-nvidia-legacy-340xx:amd64 (340.102-1) ...
Setting up nvidia-legacy-340xx-kernel-support (340.102-1) ...
Setting up nvidia-legacy-340xx-driver-libs:amd64 (340.102-1) ...
Processing triggers for nvidia-legacy-340xx-alternative (340.102-1) ...
update-alternatives: updating alternative /usr/lib/nvidia/legacy-340xx because link group nvidia has changed slave links
Setting up nvidia-legacy-340xx-kernel-dkms (340.102-1) ...
Loading new nvidia-legacy-340xx-340.102 DKMS files...
Building for 4.9.0-4-amd64
Module build for kernel 4.9.0-4-amd64 was skipped since the
kernel headers for this kernel does not seem to be installed.
Setting up nvidia-legacy-340xx-driver (340.102-1) ...
Processing triggers for libc-bin (2.24-11+deb9u1) ...
Processing triggers for update-glx (0.7.4) ...
Processing triggers for glx-alternative-nvidia (0.7.4) ...
update-alternatives: using /usr/lib/nvidia to provide /usr/lib/glx (glx) in auto mode
Processing triggers for libc-bin (2.24-11+deb9u1) ...
Processing triggers for initramfs-tools (0.130) ...
update-initramfs: Generating /boot/initrd.img-4.9.0-4-amd64
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168h-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168h-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8402-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8105e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-1.fw for module r8169
root@Blackbird:/home/user#

I searched the internet and the Debian wiki and found a LOT of information, but after wading through it as best I could, am concerned that I can't fix it at this point.

Any assistance would be appreciated.

(I don't even know if I can reboot at this point.)

Caitlin
Last edited by Caitlin on 2018-02-18 16:43, edited 1 time in total.
Caitlin
 
Posts: 259
Joined: 2012-05-24 07:32

Re: Trouble Installing NVIDIA Driver (Again)

Postby dilberts_left_nut » 2018-02-15 07:45

Code: Select all
It is recommended to install the
    nvidia-driver
package.


Code: Select all
root@Blackbird:/home/user# apt-get install nvidia-xconfig xorg xorg-dev linux-headers-$(uname -r|sed 's/[^-]*-[^-]*-//') nvidia-legacy-340xx-driver --no-install-recommends


Why?
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 4837
Joined: 2009-10-05 07:54
Location: enzed

Re: Trouble Installing NVIDIA Driver (Again)

Postby Caitlin » 2018-02-15 11:32

Well, it happened. I rebooted and all I got was a blank (dark) screen. By banging around on the keyboard some, I was able to get a (CLI) login prompt, but rather than try to reinstall nouveau, I just restored the root partition from the backups I convieniently took last night.

At this point the xorg package is installed, xorg-dev is not, nvidia-driver is, and nouveau is blacklisted away. I have a usable system but not with all the functionality I need. When I try to start Quadrapassel, I get a message: Unable to initialize Clutter: Unable to initialize the Clutter backend: no available drivers found. This is what I'm trying to currently fix. I also want to use WINE.

@dln -- the message "it is recommended to install the nvidia-driver package" came out of the nvidia-detect script. The install: xorg and xorg-dev were to fix an error in the build, where some functionality was missing. This was something I read on the internet. The wiki said linux-headers-$(uname -r|sed 's/[^-]*-[^-]*-//') was needed. And the wiki also said that if you have a 340 legacy GPU, to install nvidia-legacy-340xx-driver (which I assumed was instead of nvidia-driver).

Caitlin
Caitlin
 
Posts: 259
Joined: 2012-05-24 07:32

Re: Trouble Installing NVIDIA Driver (Again)

Postby stevepusser » 2018-02-15 19:32

The nvidia-detect script is supposed to tell you if you need a legacy driver instead of the standard one. I'd follow its advice.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: GIMP 2.10.2, Pale Moon 27.9.3, wine-staging 3.10, QuiteRSS 0.18.11, Linux kernel 4.17, Krita 4.0.4
User avatar
stevepusser
 
Posts: 9648
Joined: 2009-10-06 05:53

Re: Trouble Installing NVIDIA Driver (Again)

Postby sunrat » 2018-02-16 01:52

the message "it is recommended to install the nvidia-driver package" came out of the nvidia-detect script.


Did you actually try
Code: Select all
apt install nvidia-driver
?
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 2328
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: Trouble Installing NVIDIA Driver (Again)

Postby Caitlin » 2018-02-16 05:16

Actually, I tried apt-get install nvidia-driver first. When that didn't work, I tried the legacy driver. But I'll try it again.

I think the key is to convince (apt? Nvidia?) that the build was deleted and should be built again.

Caitlin
Caitlin
 
Posts: 259
Joined: 2012-05-24 07:32

Re: Trouble Installing NVIDIA Driver (Again)

Postby sunrat » 2018-02-16 05:37

"Didn't work" doesn't help to solve the problem. What error messages were shown?
Possibly you don't have a build environment set up.
You can install module-assistant and then run
Code: Select all
m-a prepare
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 2328
Joined: 2006-08-29 09:12
Location: Melbourne, Australia

Re: Trouble Installing NVIDIA Driver (Again)

Postby Caitlin » 2018-02-16 19:03

@sunrat -- I have already installed build-essential, if that's what you mean.

Later on, I also installed xorg and xorg-dev. But like I said, I can't get it to attempt the build again.

What does module-assistant do exactly?

While searching around, I found some additional error messages I had missed before:

s-load[202]: modprobe: FATAL: Module nvidia-current-modeset not found in directory /lib/modules/4.9.0-4-amd64
s-load[202]: modprobe: FATAL: Module nvidia-current-drm not found in directory /lib/modules/4.9.0-4-amd64
Unable to initialize Clutter:
Unable to initialize the Clutter backend: no available drivers found.

Caitlin
Caitlin
 
Posts: 259
Joined: 2012-05-24 07:32

Re: Trouble Installing NVIDIA Driver (Again)

Postby stevepusser » 2018-02-16 19:26

Those error messages show that the nvidia-driver modules were not built or installed. Module-assistant is a set of tools to assist you to build modules! The "m-a prepare" script from it checks that you have everything you need to build modules for your kernel and will install any missing packages. The wiki should have people use that tool, IMHO.

My guess is that you are getting build failures in the terminal--could you copypaste the output in a code box here?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: GIMP 2.10.2, Pale Moon 27.9.3, wine-staging 3.10, QuiteRSS 0.18.11, Linux kernel 4.17, Krita 4.0.4
User avatar
stevepusser
 
Posts: 9648
Joined: 2009-10-06 05:53

Re: Trouble Installing NVIDIA Driver (Again)

Postby Caitlin » 2018-02-17 16:53

@Steve --

Code: Select all
Setting up nvidia-legacy-340xx-kernel-dkms (340.102-1) ...
Loading new nvidia-legacy-340xx-340.102 DKMS files...
Building for 4.9.0-4-amd64
Module build for kernel 4.9.0-4-amd64 was skipped since the
kernel headers for this kernel does not seem to be installed.
Setting up nvidia-legacy-340xx-driver (340.102-1) ...
Processing triggers for libc-bin (2.24-11+deb9u1) ...
Processing triggers for update-glx (0.7.4) ...
Processing triggers for glx-alternative-nvidia (0.7.4) ...
update-alternatives: using /usr/lib/nvidia to provide /usr/lib/glx (glx) in auto mode
Processing triggers for libc-bin (2.24-11+deb9u1) ...
Processing triggers for initramfs-tools (0.130) ...
update-initramfs: Generating /boot/initrd.img-4.9.0-4-amd64
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8107e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168h-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168h-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8402-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8105e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168d-1.fw for module r8169

I decided to take a "meat axe" approach to fixing this. I restored from an even earlier set of backups, redid some things that were backed out (that I didn't want to back out and are unrelated to Nvidia), backed up again, and now have a system where the video driver "has never been installed" (other than the Stretch-original version). In my notes, I commented the whole section as "difficult and unforgiving of mistakes".

One unexpected bonus -- my Clutter problem with the game Quadrapassel simply went away. I must have done something with the Nvidia install before to injure that.

I'll go through the steps again, with all the recommendations, and hope for the best. Film at 11.

Caitlin
Caitlin
 
Posts: 259
Joined: 2012-05-24 07:32

Re: Trouble Installing NVIDIA Driver (Again)

Postby stevepusser » 2018-02-17 18:43

I am still confused why you are still trying the 340 legacy drivers when the script says to use "nvidia-driver", which is 375.82.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: GIMP 2.10.2, Pale Moon 27.9.3, wine-staging 3.10, QuiteRSS 0.18.11, Linux kernel 4.17, Krita 4.0.4
User avatar
stevepusser
 
Posts: 9648
Joined: 2009-10-06 05:53

Re: Trouble Installing NVIDIA Driver (Again)

Postby Caitlin » 2018-02-18 07:20

I'm not trying to install a particular driver version. I'm just trying different things, hoping something will work.

Caitlin
Caitlin
 
Posts: 259
Joined: 2012-05-24 07:32

Re: Trouble Installing NVIDIA Driver (Again)

Postby Caitlin » 2018-02-18 16:42

I took your advice. First I restored from a week-old set of backups, then I brought everything EXCEPT Nvidia forward again, to where it was before the restore. Then I installed Nvidia, being very careful to do all the recommended setup work.

Everything's working now except one game, but I believe that's a game problem, not an Nvidia one.

Thank you all.

Caitlin
Caitlin
 
Posts: 259
Joined: 2012-05-24 07:32


Return to Installation

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable