Installing 8.4.0 onto a Barebones Asus P1-P5945G

Help with issues regarding installation of Debian

Installing 8.4.0 onto a Barebones Asus P1-P5945G

Postby KenHorse » 2018-03-01 02:31

Install goes smoothly, network works fine (as evidenced by being able to download from mirror) during install. However after boot, no network even though ifconfig shows eth0 is there, just doesn't have an IP assigned (using dhcp of course).

I'm not a newbie but I'm no expert either....

(yea I know jessie is old but I have the DVD so I figured I'd upgrade to stretch after I got this going. Kinda hard with no network tho!
KenHorse
 
Posts: 5
Joined: 2013-01-13 18:06

Re: Installing 8.4.0 onto a Barebones Asus P1-P5945G

Postby bw123 » 2018-03-01 10:15

I don't think jessie to stretch upgrade is the best strategy. If you are new to debian it might be better to do a fresh install of stretch.

If you want to continue there is plenty to learn about network here
https://wiki.debian.org/NetworkConfiguration

and upgrade advice is here
https://www.debian.org/releases/stable/releasenotes

good luck!
User avatar
bw123
 
Posts: 3074
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Installing 8.4.0 onto a Barebones Asus P1-P5945G

Postby KenHorse » 2018-03-01 16:16

Thanks but that really doesn't help.

My issue that the eth0 shows (ifconfig -a) but it simply isn't activated. My /etc/network/interfaces looks fine and is set for dhcp
KenHorse
 
Posts: 5
Joined: 2013-01-13 18:06

Re: Installing 8.4.0 onto a Barebones Asus P1-P5945G

Postby KenHorse » 2018-03-01 16:58

I found the problem

Not ONE of the installer images I've tried seems to install dhcp. After boot, if I change eth0 to be static and manually assign things in /etc/network/interfaces, it boots up just fine with network working.

Go figure....
KenHorse
 
Posts: 5
Joined: 2013-01-13 18:06


Return to Installation

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable