[SOLVED] [Jessie → Stretch Upgrade] Stuck upgrading Samba

Help with issues regarding installation of Debian

[SOLVED] [Jessie → Stretch Upgrade] Stuck upgrading Samba

Postby littlebigman » 2018-05-02 10:58


I followed this tutorial to upgrade Debian from Jessie to Stretch:
https://linuxconfig.org/how-to-upgrade- ... -9-stretch

After running "apt-get dist-upgrade", the application got stuck at some point… until I figured it was because I have a cron job that puts the computer to sleep every day after performing a backup job :-/

Once I logged back on, the upgrade seems to have gone OK, expect for Samba:
Code: Select all
root@debian:~# apt-get install samba
Reading package lists... Done
Building dependency tree
Setting up samba (2:4.5.12+dfsg-2+deb9u2) ...
Samba is not being run as an AD Domain Controller, masking samba-ad-dc-service.
Please ignore the following error about deb-systemd-helper not finding samba-ad-dc-service.
Created symlink /etc/systemd/system/multi-user.target.wants/nmbd.service → /lib/systemd/system/nmbd.service.
Created symlink /etc/systemd/system/multi-user.target.wants/samba-ad-dc.service → /lib/systemd/system/samba-ad-dc.service.
Created symlink /etc/systemd/system/multi-user.target.wants/smbd.service → /lib/systemd/system/smbd.service.
Job for samba-ad-dc.service failed because the control process exited with error code.
See "systemctl status samba-ad-dc.service" and "journalctl -xe" for details.
invoke-rc.d: initscript samba-ad-dc, action "start" failed.
● samba-ad-dc.service - Samba AD Daemon
   Loaded: loaded (/lib/systemd/system/samba-ad-dc.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Wed 2018-05-02 13:42:56 CEST; 34ms ago
     Docs: man:samba(8)
  Process: 24994 ExecStart=/usr/sbin/samba $SAMBAOPTIONS (code=exited, status=1/FAILURE)
 Main PID: 24994 (code=exited, status=1/FAILURE)
   Status: "daemon failed to start: Samba detected misconfigured 'server role' and exited. Check logs for details"
    Error: 22 (Invalid argument)

May 02 13:42:56 debian systemd[1]: Starting Samba AD Daemon...
May 02 13:42:56 debian systemd[1]: samba-ad-dc.service: Supervising process 24994 which is not our child. We'll most …it exits.
May 02 13:42:56 debian systemd[1]: samba-ad-dc.service: Main process exited, code=exited, status=1/FAILURE
May 02 13:42:56 debian systemd[1]: Failed to start Samba AD Daemon.
May 02 13:42:56 debian systemd[1]: samba-ad-dc.service: Unit entered failed state.
May 02 13:42:56 debian systemd[1]: samba-ad-dc.service: Failed with result 'exit-code'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: error processing package samba (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for libc-bin (2.24-11+deb9u3) ...
Processing triggers for systemd (232-25+deb9u3) ...
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any idea what I could try to finalize the upgrade?

Thank you.

Edit: Problem solved by editing /etc/samba/smb.conf with my own stuff, and rerunning the following commands

Code: Select all
# apt-get install samba
# dpkg --configure -a
# apt-get install samba
Posts: 15
Joined: 2008-01-16 21:30

Return to Installation

Who is online

Users browsing this forum: No registered users and 12 guests